/[packages]/cauldron/classworlds/current/SPECS/classworlds.spec
ViewVC logotype

Contents of /cauldron/classworlds/current/SPECS/classworlds.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 487055 - (show annotations) (download)
Thu Sep 26 20:21:03 2013 UTC (10 years, 2 months ago) by dmorgan
File size: 3898 byte(s)
Add specfile/sources
1 # Copyright (c) 2000-2005, JPackage Project
2 # All rights reserved.
3 #
4 # Redistribution and use in source and binary forms, with or without
5 # modification, are permitted provided that the following conditions
6 # are met:
7 #
8 # 1. Redistributions of source code must retain the above copyright
9 # notice, this list of conditions and the following disclaimer.
10 # 2. Redistributions in binary form must reproduce the above copyright
11 # notice, this list of conditions and the following disclaimer in the
12 # documentation and/or other materials provided with the
13 # distribution.
14 # 3. Neither the name of the JPackage Project nor the names of its
15 # contributors may be used to endorse or promote products derived
16 # from this software without specific prior written permission.
17 #
18 # THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
19 # "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
20 # LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
21 # A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
22 # OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
23 # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
24 # LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
25 # DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
26 # THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
27 # (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
28 # OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
29 #
30
31 Name: classworlds
32 Version: 1.1
33 Release: %mkrel 1
34 Epoch: 0
35 Summary: Classworlds Classloader Framework
36 Group: Development/Java
37 License: Plexus
38 URL: http://classworlds.codehaus.org/
39 # svn export svn://svn.classworlds.codehaus.org/classworlds/tags/CLASSWORLDS_1_1
40 # cd CLASSWORLDS_1_1
41 # tar cjf classworlds-1.1-CLASSWORLDS_1_1-src.tar.bz2 classworlds
42 # md5sum: 76be757e6d364eece0109a2c3fc303c9
43 Source0: %{name}-%{version}-CLASSWORLDS_1_1-src.tar.bz2
44 # This was generated by an upstream download of maven and hand-tuned
45 Source1: %{name}-%{version}-build.xml
46 Source2: http://repo1.maven.org/maven2/%{name}/%{name}/%{version}/%{name}-%{version}.pom
47
48
49 BuildArch: noarch
50 BuildRequires: ant
51 BuildRequires: xerces-j2
52 BuildRequires: xml-commons-apis
53 Requires: xerces-j2
54 Requires: xml-commons-apis
55
56 # Needed ? in the good package ?
57 Provides: mvn(classworlds:classworlds:1.1)
58
59 %description
60 Classworlds is a framework for container developers
61 who require complex manipulation of Java's ClassLoaders.
62 Java's native ClassLoader mechanims and classes can cause
63 much headache and confusion for certain types of
64 application developers. Projects which involve dynamic
65 loading of components or otherwise represent a 'container'
66 can benefit from the classloading control provided by
67 classworlds.
68
69 %package javadoc
70 Summary: Javadoc for %{name}
71 Group: Documentation
72
73 %description javadoc
74 %{summary}.
75
76
77 %prep
78 %setup -q -n %{name}
79 find ./ -name "*.jar" -delete
80 cp %{SOURCE1} build.xml
81
82 %build
83 # dist=jar+javadoc
84 ant dist -Dbuild.sysclasspath=only
85
86 %install
87 # jar
88 install -d -m 755 $RPM_BUILD_ROOT%{_javadir}
89 install -Dpm 644 target/%{name}-%{version}.jar \
90 $RPM_BUILD_ROOT%{_javadir}/%{name}-%{version}.jar
91 ln -s %{name}-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/%{name}.jar
92
93 # javadoc
94 install -dm 755 $RPM_BUILD_ROOT%{_javadocdir}/%{name}
95 cp -pr dist/docs/api/* $RPM_BUILD_ROOT%{_javadocdir}/%{name}
96
97 # POM and depmap
98 install -d -m 755 $RPM_BUILD_ROOT%{_mavenpomdir}
99 install -p -m 644 %{SOURCE2} $RPM_BUILD_ROOT%{_mavenpomdir}/JPP-%{name}.pom
100 %add_maven_depmap
101
102 %files
103 %doc LICENSE.txt
104 %{_javadir}/*.jar
105 %{_mavenpomdir}/JPP-%{name}.pom
106 %{_mavendepmapfragdir}/%{name}
107
108 %files javadoc
109 %doc LICENSE.txt
110 %{_javadocdir}/%{name}
111
112

  ViewVC Help
Powered by ViewVC 1.1.28