/[packages]/cauldron/clipart-openclipart/current/SPECS/clipart-openclipart.spec
ViewVC logotype

Annotation of /cauldron/clipart-openclipart/current/SPECS/clipart-openclipart.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 64822 - (hide annotations) (download)
Sat Mar 5 12:03:46 2011 UTC (13 years, 1 month ago) by ennael
File size: 2660 byte(s)
clean broken image

1 ennael 64036 %define clip_dir %{_datadir}/images/openclipart
2    
3     Name: clipart-openclipart
4 ennael 64455 Version: 2.0
5     Release: %mkrel 1
6 ennael 64036 Summary: Open Clip Art Library
7     License: Public Domain
8     Group: Graphics
9     Url: http://www.openclipart.org/
10     Source: http://www.openclipart.org/downloads/%version/openclipart-%{version}-svgonly.tar.bz2
11     Source1: clean-up-sources.sh
12     Buildarch: noarch
13     BuildRequires: inkscape
14     BuildRequires: urw-fonts
15     BuildRoot: %{_tmppath}/%{name}-%{version}-root
16    
17     %description
18     This is a collection of 100% license-free, royalty-free, and
19     restriction-free art that you can use for whatever purpose you see fit.
20    
21     Most of the art in this package is in the Scalable Vector Graphic (SVG)
22     format, which is an XML format approved by the W3C and used in a wide
23     range of software applications, including Inkscape, Adobe Illustrator,
24     Batik, and more.
25    
26     The goal of the Open Clip Art Library is to provide the public with a
27     huge collection of reusable art for any purpose.
28    
29     For more information, including how you can contribute to this growing
30     library, please see http://www.openclipart.org/
31    
32     %prep
33     %setup -q -n openclipart-%{version}-svgonly
34    
35     # clean ugly/broken
36     (cd clipart
37     rm -rf ./unsorted
38     rm -f ./computer/icons/lemon-theme/devices/automatic \
39 ennael 64822 StefanvonHalenbach/StefanvonHalenbach_Above_earth_in_space.svg \
40 ennael 64036 ./computer/icons/lemon-theme/actions/automatic \
41     ./computer/icons/lemon-theme/filesystems/automatic \
42     ./computer/icons/lemon-theme/apps/automatic \
43     ./computer/icons/lemon-theme/mimetypes/automatic \
44     ./buildings/perspectival_house_01.* \
45     ./signs_and_symbols/flags/america/united_states/.usa_hawaii.svg.swp
46     )
47    
48     %build
49     (cd clipart
50     # build png files (for OOo galleries), taken from OOo's "build-galleries" script
51     for pict_svg in `find ./ -name "*.svg" -type f`; do
52     pict_dir=${pict_svg#./}
53     pict_dir=${pict_dir%/*}
54     pict_png=${pict_svg##*/}
55     pict_png=${pict_png%.svg}.png
56     mkdir -p build/$pict_dir
57     echo "Converting $pict_svg to $pict_dir/$pict_png..."
58     inkscape -f $pict_svg -e $pict_dir/$pict_png
59     done
60     )
61    
62     %install
63     rm -rf $RPM_BUILD_ROOT
64    
65     mkdir -p $RPM_BUILD_ROOT%clip_dir
66     (cd ./clipart
67     tar c ./ | tar x -C $RPM_BUILD_ROOT%{clip_dir}
68     )
69    
70     rm -f $RPM_BUILD_ROOT%{clip_dir}/{PASSFAIL,README,TODO}
71    
72     # remove empty dirs
73     rm -rf $RPM_BUILD_ROOT%{clip_dir}/build
74    
75     find $RPM_BUILD_ROOT%{clip_dir} -name '*bat' -type f -exec rm '{}' \;
76     find $RPM_BUILD_ROOT%{clip_dir} -type f -exec chmod 644 '{}' \;
77    
78     # clean broken files
79     install %{SOURCE1} .
80     chmod +x ./clean-up-sources.sh
81     DESTDIR=$RPM_BUILD_ROOT ./clean-up-sources.sh %{clip_dir}
82    
83     %clean
84     rm -rf $RPM_BUILD_ROOT
85    
86     %files
87     %defattr(-,root,root)
88     %clip_dir
89     %doc README AUTHORS ChangeLog INSTALL LICENSE NEWS
90    
91    
92    
93    

  ViewVC Help
Powered by ViewVC 1.1.30