/[packages]/cauldron/cogl/current/SPECS/cogl.spec
ViewVC logotype

Annotation of /cauldron/cogl/current/SPECS/cogl.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 219593 - (hide annotations) (download)
Tue Mar 6 06:31:56 2012 UTC (12 years, 8 months ago) by fwang
File size: 7538 byte(s)
new version 1.9.8
1 wally 212289 %define major 8
2 wally 118689 %define pangomajor 0
3 dmorgan 118862 %define gi_major 1.0
4 dmorgan 117699
5 wally 118689 %define libname %mklibname %{name} %{major}
6     %define libname_pango %mklibname %{name}-pango %{pangomajor}
7     %define develname %mklibname -d %{name}
8     %define girname %mklibname %{name}-gir %{gi_major}
9 wally 118926 %define girname_pango %mklibname %{name}-pango-gir %{gi_major}
10 wally 118689
11 wally 155787 %define url_ver %(echo %{version}|cut -d. -f1,2)
12    
13 wally 132952 Name: cogl
14 fwang 219593 Version: 1.9.8
15     Release: %mkrel 1
16 wally 132952 Summary: A library for using 3D graphics hardware to draw pretty pictures
17     Group: System/Libraries
18     License: LGPLv2+
19     URL: http://www.clutter-project.org/
20 wally 155787 Source0: http://download.gnome.org/sources/%{name}/%{url_ver}/%{name}-%{version}.tar.xz
21 wally 132952 Patch0: cogl-1.7.6-linkage.patch
22 wally 170999 BuildRequires: pkgconfig(gl)
23 fwang 197202 BuildRequires: pkgconfig(x11)
24     BuildRequires: pkgconfig(xext)
25     BuildRequires: pkgconfig(xfixes) >= 3
26     BuildRequires: pkgconfig(xdamage)
27     BuildRequires: pkgconfig(xcomposite) >= 0.4
28     BuildRequires: pkgconfig(gobject-2.0) >= 2.28.0
29     BuildRequires: pkgconfig(gmodule-no-export-2.0)
30 wally 170999 BuildRequires: pkgconfig(gdk-pixbuf-2.0)
31 fwang 197202 BuildRequires: pkgconfig(cairo) >= 1.10
32 wally 170999 BuildRequires: pkgconfig(pangocairo) >= 1.20
33     BuildRequires: pkgconfig(gobject-introspection-1.0)
34     BuildRequires: pkgconfig(gtk-doc)
35 dmorgan 117699
36     %description
37     Cogl is a small open source library for using 3D graphics hardware to draw
38     pretty pictures. The API departs from the flat state machine style of
39     OpenGL and is designed to make it easy to write orthogonal components that
40     can render without stepping on each others toes.
41    
42     As well aiming for a nice API, we think having a single library as opposed
43     to an API specification like OpenGL has a few advantages too; like being
44     able to paper over the inconsistencies/bugs of different OpenGL
45     implementations in a centralized place, not to mention the myriad of OpenGL
46     extensions. It also means we are in a better position to provide utility
47     APIs that help software developers since they only need to be implemented
48     once and there is no risk of inconsistency between implementations.
49    
50     Having other backends, besides OpenGL, such as drm, Gallium or D3D are
51     options we are interested in for the future.
52    
53 wally 170959 #--------------------------------------------------------------------
54    
55     %package i18n
56     Summary: Translations for %{name}
57     Group: System/Internationalization
58     Obsoletes: %{name} < 1.9.2
59 fwang 197221 BuildArch: noarch
60 wally 170959
61     %description i18n
62     This contains the translation data for %{name}.
63    
64     %files i18n -f %{name}.lang
65 dmorgan 117699 %defattr(-,root,root,-)
66    
67     #--------------------------------------------------------------------
68    
69 wally 132952 %package -n %{libname}
70     Summary: A library for using 3D graphics hardware to draw pretty pictures
71     Group: System/Libraries
72 tv 212418 Requires: %{name}-i18n
73 dmorgan 117699
74 wally 132952 %description -n %{libname}
75 dmorgan 117699 Cogl is a small open source library for using 3D graphics hardware to draw
76     pretty pictures. The API departs from the flat state machine style of
77     OpenGL and is designed to make it easy to write orthogonal components that
78     can render without stepping on each others toes.
79    
80     As well aiming for a nice API, we think having a single library as opposed
81     to an API specification like OpenGL has a few advantages too; like being
82     able to paper over the inconsistencies/bugs of different OpenGL
83     implementations in a centralized place, not to mention the myriad of OpenGL
84     extensions. It also means we are in a better position to provide utility
85     APIs that help software developers since they only need to be implemented
86     once and there is no risk of inconsistency between implementations.
87    
88     Having other backends, besides OpenGL, such as drm, Gallium or D3D are
89     options we are interested in for the future.
90    
91 wally 132952 %files -n %{libname}
92 dmorgan 117699 %defattr(-, root, root)
93     %{_libdir}/libcogl.so.%{major}*
94    
95     #--------------------------------------------------------------------
96    
97 wally 132952 %package -n %{libname_pango}
98 wally 118926 Summary: A library for using 3D graphics hardware to draw pretty pictures
99     Group: System/Libraries
100 fwang 197221 Requires: %{name}-i18n
101 dmorgan 117699
102 wally 132952 %description -n %{libname_pango}
103 dmorgan 117699 Cogl is a small open source library for using 3D graphics hardware to draw
104     pretty pictures. The API departs from the flat state machine style of
105     OpenGL and is designed to make it easy to write orthogonal components that
106     can render without stepping on each others toes.
107    
108     As well aiming for a nice API, we think having a single library as opposed
109     to an API specification like OpenGL has a few advantages too; like being
110     able to paper over the inconsistencies/bugs of different OpenGL
111     implementations in a centralized place, not to mention the myriad of OpenGL
112     extensions. It also means we are in a better position to provide utility
113     APIs that help software developers since they only need to be implemented
114     once and there is no risk of inconsistency between implementations.
115    
116     Having other backends, besides OpenGL, such as drm, Gallium or D3D are
117     options we are interested in for the future.
118    
119 wally 132952 %files -n %{libname_pango}
120 dmorgan 117699 %defattr(-, root, root)
121 wally 118689 %{_libdir}/libcogl-pango.so.%{pangomajor}*
122 dmorgan 117699
123     #--------------------------------------------------------------------
124    
125 wally 118926 %package -n %{girname}
126 wally 132952 Summary: GObject Introspection interface description for %{name}
127     Group: System/Libraries
128     Requires: %{libname} = %{version}-%{release}
129 fwang 127735 Conflicts: %{mklibname %{name}-gir 0.0} < %{version}
130 wally 124377 Conflicts: %{mklibname clutter 1.0 0} < 1.7.2
131 dmorgan 117699
132 wally 118926 %description -n %{girname}
133     GObject Introspection interface description for %{name}.
134 dmorgan 117699
135 wally 118926 %files -n %{girname}
136 dmorgan 117699 %defattr(-, root, root)
137 wally 118926 %{_libdir}/girepository-1.0/Cogl-%{gi_major}.typelib
138 dmorgan 117699
139     #--------------------------------------------------------------------
140    
141 wally 118926 %package -n %{girname_pango}
142 wally 132952 Summary: GObject Introspection interface description for %{name}-pango
143     Group: System/Libraries
144 wally 118926 Requires: %{libname_pango} = %{version}-%{release}
145 fwang 127735 Conflicts: %{_lib}cogl-gir0.0 < %{version}
146 wally 118926
147     %description -n %{girname_pango}
148     GObject Introspection interface description for %{name}-pango.
149    
150     %files -n %{girname_pango}
151     %defattr(-, root, root)
152     %{_libdir}/girepository-1.0/CoglPango-%{gi_major}.typelib
153    
154     #--------------------------------------------------------------------
155    
156 wally 132952 %package -n %{develname}
157     Summary: %{name} development environment
158     Group: Development/C
159     Provides: %{name}-devel = %{version}-%{release}
160     Provides: lib%{name}-devel = %{version}-%{release}
161     Requires: %{libname_pango} = %{version}-%{release}
162     Requires: %{libname} = %{version}-%{release}
163 fwang 212479 Requires: pkgconfig(gl)
164 wally 132952 Conflicts: %{mklibname -d clutter 1.0} <= 1.6.16
165 dmorgan 117699
166 wally 132952 %description -n %{develname}
167 dmorgan 117699 Header files and libraries for building and developing apps with %{name}.
168    
169 wally 132952 %files -n %{develname}
170 dmorgan 117699 %defattr(-, root, root)
171 wally 170959 %doc NEWS README ChangeLog
172 dmorgan 117699 %{_includedir}/cogl
173     %{_libdir}/libcogl*.so
174     %{_libdir}/pkgconfig/*.pc
175 wally 118926 %{_datadir}/gir-1.0/Cogl*-%{gi_major}.gir
176 dmorgan 117699
177     #--------------------------------------------------------------------
178    
179 wally 132952 %package doc
180     Summary: Documentation for %{name}
181     Group: Books/Other
182 wally 170978 Requires: %{develname} = %{version}-%{release}
183 wally 132952 BuildArch: noarch
184 dmorgan 117699
185 wally 132952 %description doc
186 dmorgan 117699 This package contains documentation for %{name}.
187    
188     %files doc
189     %defattr(-, root, root)
190     %{_datadir}/gtk-doc/html/cogl
191 fwang 127735 %{_datadir}/gtk-doc/html/cogl-2.0-experimental
192 dmorgan 117699
193     #--------------------------------------------------------------------
194    
195     %prep
196     %setup -q
197 wally 132952 %patch0 -p1 -b .linkage
198 dmorgan 117699
199     %build
200 wally 197508 CFLAGS="%{optflags} -fPIC"
201 dmorgan 117699
202 wally 170959 %configure2_5x \
203     --enable-cairo=yes \
204 wally 170999 --enable-gdk-pixbuf=yes \
205 wally 170959 --enable-cogl-pango=yes \
206     --enable-glx=yes \
207     --enable-gtk-doc \
208     --enable-introspection=yes \
209     --enable-examples-install=no
210 dmorgan 117699
211 fwang 127735 %make
212 dmorgan 117699
213     %install
214     %makeinstall_std
215    
216 wally 170959 #Remove examples
217     rm -rf %{buildroot}%{_datadir}/%{name}/examples-data/
218    
219 dmorgan 117699 #Remove libtool archives.
220 wally 170959 find %{buildroot} -name "*.la" -delete
221 dmorgan 117699
222     %find_lang %{name}

  ViewVC Help
Powered by ViewVC 1.1.30