/[packages]/cauldron/conky/current/SPECS/conky.spec
ViewVC logotype

Contents of /cauldron/conky/current/SPECS/conky.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 640565 - (show annotations) (download)
Sat Jun 28 11:08:48 2014 UTC (9 years, 9 months ago) by tarakbumba
File size: 2306 byte(s)
- Fix BR and alsa support

1 %define enable_audacious 0
2
3 Name: conky
4 Version: 1.9.0
5 Release: %mkrel 6
6 Summary: A lightweight system monitor
7 License: GPLv3+
8 Group: Monitoring
9 Url: http://conky.sourceforge.net/
10 Source0: http://downloads.sourceforge.net/project/conky/conky/%{version}/%{name}-%{version}.tar.bz2
11 # fix for CVE-2011-3616
12 # taken from Debian: http://patch-tracker.debian.org/patch/series/view/conky/1.8.1-6/fix-race-condition.patch
13 Patch1: fix-race-condition.patch
14 BuildRequires: pkgconfig(libcurl)
15 BuildRequires: libxslt-proc
16 BuildRequires: libiw-devel
17 BuildRequires: lua5.1-devel
18 BuildRequires: tolua++-devel
19 BuildRequires: pkgconfig(imlib2)
20 BuildRequires: gettext-devel
21 BuildRequires: pkgconfig(cairo)
22 BuildRequires: pkgconfig(glib-2.0)
23 BuildRequires: pkgconfig(x11)
24 BuildRequires: pkgconfig(xdamage)
25 BuildRequires: pkgconfig(xext)
26 BuildRequires: pkgconfig(xfixes)
27 BuildRequires: pkgconfig(xft)
28 BuildRequires: pkgconfig(ncurses)
29 # There is no audclient beginning with audacious 3.5
30 # which is our current cauldron one and compilation
31 # fails. Disable audacious support until it is fixed by upstream.
32 %if %enable_audacious
33 BuildRequires: pkgconfig(audacious)
34 BuildRequires: pkgconfig(dbus-glib-1)
35 %endif
36 BuildRequires: pkgconfig(alsa)
37
38
39 %description
40 Conky is a free, light-weight system monitor for X,
41 that displays any information on your desktop.
42
43 %prep
44 %setup -q
45 %patch1 -p1 -b .fix-race-condition
46
47 %build
48 %configure2_5x \
49 --disable-rpath \
50 --disable-bmpx \
51 --disable-xmms2 \
52 --disable-nvidia \
53 --enable-own-window \
54 --enable-ncurses \
55 %if %enable_audacious
56 --enable-audacious=yes \
57 %endif
58 --enable-ibm \
59 --enable-hddtemp \
60 --enable-apcupsd \
61 --enable-iostats \
62 --enable-math \
63 --enable-mpd \
64 --enable-moc \
65 --enable-curl \
66 --enable-eve \
67 --enable-rss \
68 --enable-weather-metar \
69 --enable-weather-xoap \
70 --enable-x11 \
71 --enable-argb \
72 --enable-imlib2 \
73 --enable-lua-imlib2 \
74 --enable-lua \
75 --enable-lua-cairo \
76 --enable-wlan \
77 --enable-portmon \
78 --enable-double-buffer \
79 --enable-xdamage \
80 --enable-xft \
81 --enable-alsa
82
83 %make
84
85 %install
86 %makeinstall_std
87
88 %find_lang %{name}
89
90 %clean
91 rm -rf %{buildroot}
92
93 %files -f %{name}.lang
94 %defattr(-,root,root)
95 %config(noreplace) %{_sysconfdir}/%{name}
96 %{_bindir}/%{name}
97 %{_libdir}/%{name}
98 %{_mandir}/man1/*

  ViewVC Help
Powered by ViewVC 1.1.30