/[packages]/cauldron/cross-avr-gcc/current/SPECS/cross-avr-gcc.spec
ViewVC logotype

Annotation of /cauldron/cross-avr-gcc/current/SPECS/cross-avr-gcc.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 117222 - (hide annotations) (download)
Fri Jul 1 19:47:43 2011 UTC (12 years, 9 months ago) by kicer86
File size: 2493 byte(s)
Removed unnecessary %{_libexecdir}/gcc directory
1 kicer86 114876 %define target avr
2     %define version 4.5.3
3    
4     Name: cross-%{target}-gcc
5     Version: %{version}
6     Release: %mkrel 0
7     Summary: Cross Compiling GNU GCC targeted at %{target}
8     Group: Applications/Development
9     License: GPLv2+
10     URL: http://gcc.gnu.org/
11     Source0: ftp://ftp.gnu.org/gnu/gcc/gcc-4.5.3/gcc-core-4.5.3.tar.bz2
12     Source1: ftp://ftp.gnu.org/gnu/gcc/gcc-4.5.3/gcc-g++-4.5.3.tar.bz2
13     BuildRequires: cross-%{target}-binutils >= 2.13, zlib-devel gawk gmp-devel mpfr-devel libmpc-devel libelf-devel
14     Requires: cross-%{target}-binutils >= 2.13
15 kicer86 117216 Suggests: avr-libc
16 kicer86 114876
17     %description
18     This is a Cross Compiling version of GNU GCC, which can be used to
19     compile for the %{target} platform, instead of for the
20     native %{_arch} platform.
21    
22    
23     %package c++
24     Summary: Cross Compiling GNU GCC targeted at %{target}
25     Requires: %{name} = %{version}-%{release}
26    
27     %description c++
28     This package contains the Cross Compiling version of g++, which can be used to
29     compile c++ code for the %{target} platform, instead of for the native %{_arch}
30     platform.
31    
32    
33     %prep
34     %setup -q -c -n %{name} -a 1
35    
36     %build
37 kicer86 117216 %define _exec_prefix %{_prefix}/lib
38 kicer86 114876 mkdir -p gcc-%{target}
39     pushd gcc-%{target}
40 kicer86 117216 export CONFIGURE_TOP=../gcc-%{version} \
41     %configure2_5x \
42 kicer86 114876 --target=%{target} --enable-languages=c,c++ \
43     --disable-nls --disable-libssp --with-system-zlib \
44     --enable-version-specific-runtime-libs \
45     --enable-lto --enable-plugins \
46     --disable-werror CFLAGS="-Wno-format-security"
47    
48     # In general, building GCC is not smp-safe
49     make
50     popd
51    
52    
53     %install
54     rm -rf $RPM_BUILD_ROOT
55     pushd gcc-%{target}
56     make install DESTDIR=$RPM_BUILD_ROOT
57     popd
58     # we don't want these as we are a cross version
59     rm -r $RPM_BUILD_ROOT%{_infodir}
60     rm -r $RPM_BUILD_ROOT%{_mandir}/man7
61     rm $RPM_BUILD_ROOT%{_libdir}/libiberty.a
62    
63    
64     %clean
65     rm -rf $RPM_BUILD_ROOT
66    
67    
68     %files
69     %defattr(-,root,root,-)
70     %doc gcc-%{version}/COPYING gcc-%{version}/COPYING.LIB
71 kicer86 117216
72 kicer86 114876 %{_bindir}/%{target}-*
73 kicer86 117216
74 kicer86 114876 %dir %{_libdir}/gcc
75     %dir %{_libdir}/gcc/%{target}
76     %{_libdir}/gcc/%{target}/%{version}
77 kicer86 117216
78 kicer86 117222 # %dir %{_libexecdir}/gcc
79     # %dir %{_libexecdir}/gcc/%{target}
80     # %{_libexecdir}/gcc/%{target}/%{version}
81 kicer86 117216
82 kicer86 114876 %{_mandir}/man1/%{target}-*.1.xz
83 kicer86 117216
84 kicer86 114876 %exclude %{_bindir}/%{target}-?++
85     %exclude %{_libexecdir}/gcc/%{target}/%{version}/cc1plus
86     %exclude %{_mandir}/man1/%{target}-g++.1.xz
87    
88     %files c++
89     %defattr(-,root,root,-)
90     %{_bindir}/%{target}-?++
91     %{_libexecdir}/gcc/%{target}/%{version}/cc1plus
92     %{_mandir}/man1/%{target}-g++.1.xz
93    

  ViewVC Help
Powered by ViewVC 1.1.30