1 |
rtp |
17898 |
%bcond_with doc |
2 |
|
|
%bcond_without qt4 |
3 |
|
|
|
4 |
|
|
Name: doxygen |
5 |
fwang |
134791 |
Version: 1.7.5.1 |
6 |
rtp |
17898 |
Release: %mkrel 1 |
7 |
|
|
Epoch: 1 |
8 |
|
|
Summary: Doxygen is THE documentation system for C/C++ |
9 |
|
|
Group: Development/Other |
10 |
|
|
License: GPL+ |
11 |
|
|
URL: http://www.stack.nl/~dimitri/doxygen/ |
12 |
|
|
Source0: ftp://ftp.stack.nl/pub/users/dimitri/%{name}-%{version}.src.tar.gz |
13 |
|
|
Patch0: doxygen-1.2.12-fix-latex.patch |
14 |
|
|
Patch2: doxygen-1.5.8-mandir.patch |
15 |
|
|
BuildRequires: bison |
16 |
|
|
BuildRequires: flex |
17 |
|
|
BuildRequires: gcc-c++ |
18 |
|
|
BuildRequires: png-devel |
19 |
|
|
%if %with qt4 |
20 |
|
|
BuildRequires: qt4-devel |
21 |
|
|
%endif |
22 |
|
|
%if %with doc |
23 |
|
|
BuildRequires: tetex-latex |
24 |
|
|
BuildRequires: ghostscript python |
25 |
|
|
%endif |
26 |
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root |
27 |
|
|
|
28 |
|
|
%description |
29 |
|
|
Doxygen is a documentation system for C, C++ and IDL. It can generate |
30 |
|
|
an on-line class browser (in HTML) and/or an off-line reference manual |
31 |
|
|
(in LaTeX) from a set of documented source files. There is also |
32 |
|
|
support for generating man lpages and for converting the generated |
33 |
|
|
output into Postscript, hyperlinked PDF or compressed HTML. The |
34 |
|
|
documentation is extracted directly from the sources. |
35 |
|
|
|
36 |
|
|
Doxygen can also be configured to extract the code-structure from |
37 |
|
|
undocumented source files. This can be very useful to quickly find |
38 |
|
|
your way in large source distributions. |
39 |
|
|
|
40 |
|
|
%if %with qt4 |
41 |
|
|
%package doxywizard |
42 |
|
|
Summary: A GUI for creating and editing configuration files |
43 |
|
|
Group: Development/Other |
44 |
|
|
Requires: %{name} = %{epoch}:%{version} |
45 |
|
|
Conflicts: %{name} < 1:1.5.7.1 |
46 |
|
|
|
47 |
|
|
%description doxywizard |
48 |
|
|
Doxywizard is a GUI for creating and editing configuration files that |
49 |
|
|
are used by doxygen. |
50 |
|
|
%endif |
51 |
|
|
|
52 |
|
|
%prep |
53 |
|
|
%setup -q |
54 |
|
|
%patch0 -p1 |
55 |
|
|
%patch2 -p1 -b .man |
56 |
|
|
|
57 |
|
|
%{__perl} -pi -e "s|^TMAKE_CFLAGS_RELEASE.*|TMAKE_CFLAGS_RELEASE = %{optflags}|" tmake/lib/linux-g++/tmake.conf |
58 |
|
|
%{__perl} -pi -e "s|/lib$|/%{_lib}|" tmake/lib/linux-g++/tmake.conf |
59 |
|
|
# XXX configure is going to fail if both 32-bit and 64-bit qt3-devel |
60 |
|
|
# are installed |
61 |
|
|
find -type d -exec %{__chmod} 0755 {} \; |
62 |
|
|
# build with system libpng |
63 |
|
|
%{__rm} -rf libpng |
64 |
|
|
|
65 |
|
|
%build |
66 |
|
|
./configure \ |
67 |
|
|
--prefix %_prefix \ |
68 |
|
|
--make %{_bindir}/make \ |
69 |
|
|
%if %with qt4 |
70 |
|
|
--with-doxywizard |
71 |
|
|
%endif |
72 |
|
|
|
73 |
|
|
%make LFLAGS="%{?ldflags}" |
74 |
|
|
|
75 |
|
|
%if %with doc |
76 |
|
|
%{__make} docs |
77 |
|
|
%{__mv} doc/float.sty latex |
78 |
|
|
%{__mv} doc/fancyhdr.sty latex |
79 |
|
|
%{__make} pdf |
80 |
|
|
mkdir pdf |
81 |
|
|
%{__mv} latex/doxygen_manual.pdf pdf |
82 |
|
|
%endif |
83 |
|
|
|
84 |
|
|
%install |
85 |
|
|
%{__rm} -rf %{buildroot} |
86 |
|
|
|
87 |
|
|
make install INSTALL=%{buildroot}%{_prefix} |
88 |
|
|
|
89 |
|
|
%clean |
90 |
|
|
%{__rm} -rf %{buildroot} |
91 |
|
|
|
92 |
|
|
%files |
93 |
|
|
%defattr(-, root, root) |
94 |
|
|
%if %with doc |
95 |
|
|
%doc html examples pdf |
96 |
|
|
%endif |
97 |
|
|
%doc README |
98 |
|
|
%{_bindir}/doxygen |
99 |
|
|
%{_bindir}/doxytag |
100 |
|
|
%{_mandir}/man1/doxygen.1* |
101 |
|
|
%{_mandir}/man1/doxytag.1* |
102 |
|
|
|
103 |
|
|
%if %with qt4 |
104 |
|
|
%files doxywizard |
105 |
|
|
%defattr(-,root,root) |
106 |
|
|
%{_bindir}/doxywizard |
107 |
|
|
%{_mandir}/man1/doxywizard* |
108 |
|
|
%endif |
109 |
|
|
|
110 |
|
|
|