1 |
%define destdir %{_docdir}/installer-help |
2 |
|
3 |
Name: drakx-installer-help |
4 |
Version: 2.12 |
5 |
Release: %mkrel 1 |
6 |
Summary: installer help texts |
7 |
License: CC-BY-SA |
8 |
Group: Books/Other |
9 |
URL: http://svnweb.mageia.org/soft/drakx-installer-help/ |
10 |
# svn co svn+ssh://svn.mageia.org/svn/soft/drakx-installer-help |
11 |
# cd drakx-installer-help/trunk && make dist |
12 |
Source0: %{name}-%{version}.tar.xz |
13 |
|
14 |
BuildArch: noarch |
15 |
|
16 |
%description |
17 |
The help texts for the help buttons in drakx-installer-stage2 and |
18 |
an installer help manual that will be available after install. |
19 |
|
20 |
|
21 |
%prep |
22 |
%setup -q |
23 |
|
24 |
%build |
25 |
# nothing to do |
26 |
|
27 |
%install |
28 |
mkdir -p %{buildroot}%{destdir} |
29 |
|
30 |
# HTML pages |
31 |
install -p -m 644 *.html %{buildroot}%{destdir} |
32 |
|
33 |
# images |
34 |
install -p -m 644 *.png %{buildroot}%{destdir} |
35 |
|
36 |
# translations |
37 |
for lang in el fr nl; do |
38 |
for file in $lang/*.html $lang/*.png; do |
39 |
install -D -p -m 644 $file %{buildroot}%{destdir}/$file |
40 |
done |
41 |
done |
42 |
|
43 |
for file in $(find . -name "README"); do |
44 |
lang=`echo $file|sed 's,./\(.*\)/README,\1,'` |
45 |
[ "$file" == "./README" ] || cp $file README-$lang |
46 |
done |
47 |
|
48 |
for file in $(find . -name "COPYING"); do |
49 |
lang=`echo $file|sed 's,./\(.*\)/COPYING,\1,'` |
50 |
[ "$file" == "./COPYING" ] || cp $file COPYING-$lang |
51 |
done |
52 |
|
53 |
%files |
54 |
%doc README COPYING NEWS |
55 |
%doc README-* COPYING-* |
56 |
%{destdir}/*.html |
57 |
%{destdir}/*.png |
58 |
%{destdir}/el/*.html |
59 |
%{destdir}/el/*.png |
60 |
%{destdir}/fr/*.html |
61 |
%{destdir}/fr/*.png |
62 |
%{destdir}/nl/*.html |
63 |
%{destdir}/nl/*.png |