/[packages]/cauldron/eggdrop/current/SPECS/eggdrop.spec
ViewVC logotype

Annotation of /cauldron/eggdrop/current/SPECS/eggdrop.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1151572 - (hide annotations) (download)
Tue Sep 5 18:56:22 2017 UTC (6 years, 7 months ago) by ovitters
File size: 2898 byte(s)
SILENT convert -devel buildrequires into pkgconfig
1 kharec 2351 Name: eggdrop
2 solbu 1147614 Version: 1.8.2
3 solbu 1079757 Release: %mkrel 1
4 kharec 2351 Summary: IRC bot, written in C
5 daviddavid 886391 Group: Networking/IRC
6     License: GPLv2+
7     URL: http://www.eggheads.org/
8 solbu 1079757 Source0: ftp://ftp.eggheads.org/pub/%{name}/source/1.8/%{name}-%{version}.tar.gz
9 ovitters 644737 BuildRequires: tcl
10 ovitters 1144281 BuildRequires: pkgconfig(tcl)
11 ovitters 644737 BuildRequires: perl
12 ovitters 1151572 BuildRequires: pkgconfig(openssl)
13 kharec 2351
14     %description
15     Eggdrop is an IRC bot, written in C. If you don't know what IRC is,
16     this is probably not whatever you're looking for! Eggdrop, being a
17 solbu 1147614 bot, sits on a channel and takes protective measures: to keep the
18 kharec 2351 channel from being taken over (in the few ways that anything CAN),
19     to recognize banished users or sites and reject them, to recognize
20     privileged users and let them gain ops, etc.
21    
22     %prep
23 solbu 1079757 %setup -q
24 kharec 2351
25     %build
26     export CPPFLAGS="%{optflags} -DHAVE_TCL_THREADS"
27     #any optimizations on PPC break bots
28     %ifnarch ppc
29     export CFLAGS="%optflags"
30     %endif
31     %configure2_5x --prefix=%{_prefix} --libdir=%{_libdir}
32    
33     make config
34    
35     %make LD="gcc %ldflags" \
36     SHLIB_LD="gcc -shared -nostartfiles %ldflags" \
37     MOD_LD="gcc %ldflags"
38    
39     %install
40 solbu 1079757 mkdir -p %{buildroot}%{_libdir}/%{name}
41     mkdir -p %{buildroot}%{_libdir}
42     mkdir -p %{buildroot}%{_docdir}/%{name}-%{version}
43     mkdir -p %{buildroot}%{_mandir}
44 kharec 2351
45 solbu 1079757 make install prefix=%{buildroot}%{_libdir}/%{name}
46     mv %{buildroot}%{_libdir}/%{name}/doc/man1/ %{buildroot}%{_mandir}
47 kharec 2351
48     #rpm installation complains otherwise due to rpm looking up the executables..
49 solbu 1079757 perl -pi -e s":/path/to/executable/%{name}:%{_libdir}/%{name}/%{name}:" %{_builddir}/%{name}-%{version}/%{name}.conf
50     cp -fR %{_builddir}/%{name}-%{version}/%{name}.conf %{buildroot}%{_docdir}/%{name}-%{version}/
51     cp -Rf %{_builddir}/%{name}-%{version}/scripts/botchk %{buildroot}%{_docdir}/%{name}-%{version}/
52 kharec 2351
53 solbu 1079757 rm -rf %{buildroot}%{_libdir}/%{name}/filesys
54     cp -Rf %{buildroot}%{_libdir}/%{name}/doc/* %{buildroot}%{_docdir}/%{name}-%{version}/
55     rm -rf %{buildroot}%{_libdir}/%{name}/doc/
56     mv %{buildroot}%{_libdir}/%{name}/README %{buildroot}%{_docdir}/%{name}-%{version}/
57 kharec 2351
58     %files
59 solbu 1079757 %dir %{_libdir}/%{name}
60     %dir %{_libdir}/%{name}/language
61     %dir %{_libdir}/%{name}/modules-%{version}
62     %dir %{_libdir}/%{name}/help
63     %dir %{_libdir}/%{name}/help/msg
64     %dir %{_libdir}/%{name}/help/set
65     %dir %{_libdir}/%{name}/scripts
66     %dir %{_libdir}/%{name}/logs
67     %dir %{_libdir}/%{name}/text
68     %{_libdir}/%{name}/language/*.lang
69     %{_libdir}/%{name}/text/*
70     %{_libdir}/%{name}/logs/*
71     %{_libdir}/%{name}/modules-%{version}/*.so
72     %{_libdir}/%{name}/%{name}-%{version}
73     %{_libdir}/%{name}/%{name}
74     %{_libdir}/%{name}/help/*.help
75     %{_libdir}/%{name}/help/msg/*.help
76     %{_libdir}/%{name}/help/set/*.help
77     %{_libdir}/%{name}/scripts/CONTENTS
78     %{_libdir}/%{name}/scripts/*.tcl
79     %{_libdir}/%{name}/scripts/botchk
80     %{_libdir}/%{name}/scripts/autobotchk
81     %{_libdir}/%{name}/scripts/weed
82     %{_libdir}/%{name}/%{name}.conf
83     %{_libdir}/%{name}/%{name}-basic.conf
84     %{_mandir}/man1/%{name}.1*
85 kharec 2351
86     %doc %{_docdir}/*
87 solbu 1079757 %doc %{_libdir}/%{name}/modules

  ViewVC Help
Powered by ViewVC 1.1.30