/[packages]/cauldron/eggdrop/current/SPECS/eggdrop.spec
ViewVC logotype

Annotation of /cauldron/eggdrop/current/SPECS/eggdrop.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1578965 - (hide annotations) (download)
Mon May 4 08:26:30 2020 UTC (3 years, 11 months ago) by ovitters
File size: 2948 byte(s)
SILENT change make macro to make_build
1 kharec 2351 Name: eggdrop
2 solbu 1348322 Version: 1.8.4
3 umeabot 1521781 Release: %mkrel 2
4 kharec 2351 Summary: IRC bot, written in C
5 daviddavid 886391 Group: Networking/IRC
6     License: GPLv2+
7     URL: http://www.eggheads.org/
8 solbu 1079757 Source0: ftp://ftp.eggheads.org/pub/%{name}/source/1.8/%{name}-%{version}.tar.gz
9 wally 1234860 BuildRequires: tcl
10     BuildRequires: pkgconfig(tcl)
11 ovitters 644737 BuildRequires: perl
12 ovitters 1151572 BuildRequires: pkgconfig(openssl)
13 kharec 2351
14     %description
15     Eggdrop is an IRC bot, written in C. If you don't know what IRC is,
16     this is probably not whatever you're looking for! Eggdrop, being a
17 solbu 1147614 bot, sits on a channel and takes protective measures: to keep the
18 kharec 2351 channel from being taken over (in the few ways that anything CAN),
19     to recognize banished users or sites and reject them, to recognize
20     privileged users and let them gain ops, etc.
21    
22     %prep
23 solbu 1079757 %setup -q
24 kharec 2351
25 wally 1234860 # fix build on aarch64
26     cp -af %{_rpmconfigdir}/config.{guess,sub} misc/
27    
28 kharec 2351 %build
29     export CPPFLAGS="%{optflags} -DHAVE_TCL_THREADS"
30     #any optimizations on PPC break bots
31     %ifnarch ppc
32     export CFLAGS="%optflags"
33     %endif
34 wally 1478688 %configure
35 kharec 2351
36     make config
37    
38 ovitters 1578965 %make_build LD="gcc %ldflags" \
39 kharec 2351 SHLIB_LD="gcc -shared -nostartfiles %ldflags" \
40     MOD_LD="gcc %ldflags"
41    
42     %install
43 solbu 1079757 mkdir -p %{buildroot}%{_libdir}/%{name}
44     mkdir -p %{buildroot}%{_libdir}
45     mkdir -p %{buildroot}%{_docdir}/%{name}-%{version}
46     mkdir -p %{buildroot}%{_mandir}
47 kharec 2351
48 solbu 1079757 make install prefix=%{buildroot}%{_libdir}/%{name}
49     mv %{buildroot}%{_libdir}/%{name}/doc/man1/ %{buildroot}%{_mandir}
50 kharec 2351
51     #rpm installation complains otherwise due to rpm looking up the executables..
52 solbu 1079757 perl -pi -e s":/path/to/executable/%{name}:%{_libdir}/%{name}/%{name}:" %{_builddir}/%{name}-%{version}/%{name}.conf
53     cp -fR %{_builddir}/%{name}-%{version}/%{name}.conf %{buildroot}%{_docdir}/%{name}-%{version}/
54     cp -Rf %{_builddir}/%{name}-%{version}/scripts/botchk %{buildroot}%{_docdir}/%{name}-%{version}/
55 kharec 2351
56 solbu 1079757 rm -rf %{buildroot}%{_libdir}/%{name}/filesys
57     cp -Rf %{buildroot}%{_libdir}/%{name}/doc/* %{buildroot}%{_docdir}/%{name}-%{version}/
58     rm -rf %{buildroot}%{_libdir}/%{name}/doc/
59     mv %{buildroot}%{_libdir}/%{name}/README %{buildroot}%{_docdir}/%{name}-%{version}/
60 kharec 2351
61     %files
62 solbu 1079757 %dir %{_libdir}/%{name}
63     %dir %{_libdir}/%{name}/language
64     %dir %{_libdir}/%{name}/modules-%{version}
65     %dir %{_libdir}/%{name}/help
66     %dir %{_libdir}/%{name}/help/msg
67     %dir %{_libdir}/%{name}/help/set
68     %dir %{_libdir}/%{name}/scripts
69     %dir %{_libdir}/%{name}/logs
70     %dir %{_libdir}/%{name}/text
71     %{_libdir}/%{name}/language/*.lang
72     %{_libdir}/%{name}/text/*
73     %{_libdir}/%{name}/logs/*
74     %{_libdir}/%{name}/modules-%{version}/*.so
75     %{_libdir}/%{name}/%{name}-%{version}
76     %{_libdir}/%{name}/%{name}
77     %{_libdir}/%{name}/help/*.help
78     %{_libdir}/%{name}/help/msg/*.help
79     %{_libdir}/%{name}/help/set/*.help
80     %{_libdir}/%{name}/scripts/CONTENTS
81     %{_libdir}/%{name}/scripts/*.tcl
82     %{_libdir}/%{name}/scripts/botchk
83     %{_libdir}/%{name}/scripts/autobotchk
84     %{_libdir}/%{name}/scripts/weed
85     %{_libdir}/%{name}/%{name}.conf
86     %{_libdir}/%{name}/%{name}-basic.conf
87     %{_mandir}/man1/%{name}.1*
88 kharec 2351
89     %doc %{_docdir}/*
90 solbu 1079757 %doc %{_libdir}/%{name}/modules
91 solbu 1207050 %license COPYING

  ViewVC Help
Powered by ViewVC 1.1.30