/[packages]/cauldron/fife/current/SPECS/fife.spec
ViewVC logotype

Annotation of /cauldron/fife/current/SPECS/fife.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 119482 - (hide annotations) (download)
Wed Jul 6 16:51:20 2011 UTC (12 years, 9 months ago) by stblack
File size: 6289 byte(s)
SILENT: added mageia spec file policy
1 stblack 119482 #
2     # spec file for fife (Version 0.3.2)
3     #
4     # Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
5     #
6     # All modifications and additions to the file contributed by third parties
7     # remain the property of their copyright owners, unless otherwise agreed
8     # upon. The license for this file, and modifications and additions to the
9     # file, is the same license as for the pristine package itself (unless the
10     # license for the pristine package is not an Open Source License, in which
11     # case the license is the MIT License). An "Open Source License" is a
12     # license that conforms to the Open Source Definition (Version 1.9)
13     # published by the Open Source Initiative.
14    
15     # Please submit bugfixes or comments via http://bugs.opensuse.org/
16     #
17    
18     # norootforbuild
19    
20     %global soname 0
21     # Release sources: http://sourceforge.net/projects/fife/files/active/src/%{name}-%{version}.tar.gz/download
22     # The sources were recompressed as: %{name}-%{version}.tar.bz2 for this package.
23     # Not building the documentation for this package, anyone wants docs?
24    
25 stblack 117011 Name: fife
26 stblack 119482 # Quick workaround for a fast library package
27     %define _name libfife
28 stblack 117011 Version: 0.3.2
29 stblack 119482 Release: 1
30 stblack 117011 License: LGPLv2+
31 stblack 119482 Summary: A powerful 2D game engine
32     Url: http://www.fifengine.de
33     Group: Amusements/Games/Other
34     Source: %{name}-%{version}r2.tar.gz
35     # Currently: "macro-in-comment"
36     Source99: %{name}-rpmlintrc
37     # PATCH-FIX-OPENSUSE - fife-opensuse-packaging-fixes.patch nmarques@opensuse.org -- Remove 'ext' so we use system shared libraries
38     Patch0: %{name}-opensuse-packaging-fixes.patch
39     # PATCH-FIX-UPSTREAM - fife-changeset_r3592.patch nmarques@opensuse.org -- Cherry picked from git, fixes some issues with boost on vfsdirectory.cpp
40     Patch1: %{name}-changeset_r3592.patch
41     # PATCH-FIX-UPSTREAM - fife-soname-fix.patch -- Modified for openSUSE from existing Fedora patch
42     Patch2: %{name}-soname-fix.patch
43 stblack 117011 BuildRequires: boost-devel
44 stblack 119482 BuildRequires: lib64freeglut-devel
45     BuildRequires: gcc-c++
46 stblack 117011 BuildRequires: guichan-devel
47     BuildRequires: libpng-devel
48 stblack 119482 BuildRequires: libstdc++-devel
49     BuildRequires: pkgconfig(gl)
50     BuildRequires: pkgconfig(openal)
51     BuildRequires: pkgconfig(sdl)
52     BuildRequires: pkgconfig(vorbis)
53     BuildRequires: python-devel
54     # Required for a quick rpath workaround
55 stblack 117011 BuildRequires: chrpath
56 stblack 119482 BuildRequires: scons
57     BuildRequires: swig
58     BuildRequires: zlib-devel
59    
60 stblack 117011 %description
61 stblack 119482 FIFE stands for Flexible Isometric Free Engine and is a cross platform
62     game creation framework. It provides you with the ability to create a
63     game using Python interfaces.
64    
65     You can make just about any 2D game with FIFE but it is more geared
66     toward a RTS or RPG in just about any view style (isometric ortop-down).
67     For more information on FIFE's capabilities visit the Features page.
68    
69     ---
70     http://www.fifengine.de
71     http://wiki.fifengine.net/Features
72    
73     %package -n %{_name}%{soname}
74     Summary: System shared libraries for fife engine games
75     Group: Amusements/Games/Other
76    
77     %description -n %{_name}%{soname}
78     FIFE stands for Flexible Isometric Free Engine and is a cross platform
79     game creation framework. It provides you with the ability to create a
80     game using Python interfaces.
81    
82     This package provides the shared libraries.
83    
84     ---
85     http://www.fifengine.de
86     http://wiki.fifengine.net/Features
87    
88     %package -n %{name}-python
89     Summary: Python extensions for the fife engine
90     Group: Amusements/Games/Other
91     Requires: python
92    
93     %description -n %{name}-python
94     FIFE stands for Flexible Isometric Free Engine and is a cross platform
95     game creation framework. It provides you with the ability to create a
96     game using Python interfaces.
97    
98     This package provides the python extensions.
99    
100     ---
101     http://www.fifengine.de
102     http://wiki.fifengine.net/Features
103    
104     %package devel
105     Summary: Development files for %{name} engine
106     Group: Development/Libraries/Other
107     Requires: %{_name}%{soname} = %{version}
108     Requires: %{name}-python = %{version}
109     %if 0%{?suse_version}
110     Requires: pkg-config
111     %endif
112     %if 0%{?fedora_version}
113     Requires: pkgconfig
114     %endif
115    
116 stblack 117011 %description devel
117 stblack 119482 FIFE stands for Flexible Isometric Free Engine and is a cross platform
118     game creation framework. It provides you with the ability to create a
119     game using Python interfaces.
120    
121     This package provides the development files.
122    
123     ---
124     http://www.fifengine.de
125     http://wiki.fifengine.net/Features
126    
127 stblack 117011 %prep
128 stblack 119482 #%setup -q
129     %setup -n %{name}-%{version}r2
130     %patch0 -p1
131     %patch1 -p1
132     # Add soname to generated library
133     %patch2 -p1
134     sed -i "s|SONAME|%{soname}|g" \
135     engine/SConscript
136     # Use libdir instead of lib (for 64bit systems)
137 stblack 117011 for l in ./engine/SConscript ./build/linux2-config.py
138     do
139     sed -i "s|'lib'|'%{_lib}'|g" $l
140 stblack 119482 done
141     # UTF-8 friendly fix - upstream pinged!
142     for f in AUTHORS CHANGES COPYING README
143 stblack 117011 do
144     iconv -f iso-8859-1 -t utf-8 $f |sed 's|\r||g' > $f.utf8
145     touch -c -r $f $f.utf8
146     mv $f.utf8 $f
147 stblack 119482 done
148    
149 stblack 117011 %build
150 stblack 119482 # Parallel builds will break the package - upstream pinged
151     scons \
152     CXXFLAGS='%{optflags}' \
153     --prefix=%{_prefix} \
154     --python-prefix=%{python_sitelib} \
155     --enable-rend-camzone \
156     --enable-rend-grid \
157     %{name}-shared \
158     %{name}-python \
159     %{name}-swig
160    
161 stblack 117011 %install
162 stblack 119482 # Parallel builds will break the package - upstream pinged
163     scons \
164     CXXFLAGS='%{optflags}' \
165     DESTDIR=%{buildroot} \
166     install-shared \
167     install-python \
168     install-dev \
169     --prefix=%{_prefix} \
170     --python-prefix=%{python_sitelib}
171     # rpath workaround
172     find %{buildroot} -name '*.so' -print -type f -exec chrpath --delete {} \;
173 stblack 117011 # playing a little bit with soname
174 stblack 119482 mv %{buildroot}/%{_libdir}/%{_name}.so %{buildroot}/%{_libdir}/%{_name}.so.%{version}
175 stblack 117011 pushd %{buildroot}%{_libdir}
176 stblack 119482 ln -s %{_name}.so.%{version} %{_name}.so.%{soname}
177     ln -s %{_name}.so.%{version} %{_name}.so
178 stblack 117011 popd
179 stblack 119482 # We use system shared libraries, not static
180     find %{buildroot}%{_libdir} -name '*.a' -type f -delete -print
181    
182 stblack 117011 %clean
183 stblack 119482 %{?buildroot:%__rm -rf "%{buildroot}"}
184    
185     %post -n %{_name}%{soname} -p /sbin/ldconfig
186    
187     %postun -n %{_name}%{soname} -p /sbin/ldconfig
188    
189     %files -n %{_name}%{soname}
190     %defattr(-,root,root)
191     %doc AUTHORS COPYING README
192     %{_libdir}/*.so.*
193    
194     %files -n %{name}-python
195     %defattr(-,root,root)
196     %{python_sitelib}/fife/
197    
198 stblack 117011 %files devel
199 stblack 119482 %defattr(-,root,root)
200     %doc CHANGES
201     %{_includedir}/fife/
202     %{_libdir}/*.so
203    
204     %changelog

  ViewVC Help
Powered by ViewVC 1.1.30