/[packages]/cauldron/fife/current/SPECS/fife.spec
ViewVC logotype

Contents of /cauldron/fife/current/SPECS/fife.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1473998 - (show annotations) (download)
Fri Dec 27 20:12:04 2019 UTC (4 years, 9 months ago) by wally
File size: 3001 byte(s)
- build with new cmake macros
1 %define soname %{version}
2 %define libname %mklibname %{name} %{soname}
3 %define develname %mklibname -d %{name}
4
5 %define oname fifengine
6
7 Name: fife
8 Version: 0.4.2
9 Release: %mkrel 5
10 Summary: Cross-platform game creation framework
11 Group: Development/Tools
12 License: LGPLv2+
13 URL: http://www.fifengine.net
14 Source0: https://github.com/fifengine/fifengine/archive/%{version}/%{oname}-%{version}.tar.gz
15
16 BuildRequires: boost-devel
17 BuildRequires: cmake
18 BuildRequires: fifechan-devel >= 0.1.5
19 BuildRequires: pkgconfig(glew)
20 BuildRequires: pkgconfig(libpng)
21 BuildRequires: pkgconfig(openal)
22 BuildRequires: pkgconfig(python3)
23 BuildRequires: pkgconfig(sdl2)
24 BuildRequires: pkgconfig(SDL2_ttf)
25 BuildRequires: pkgconfig(SDL2_image)
26 BuildRequires: pkgconfig(tinyxml)
27 BuildRequires: pkgconfig(vorbis)
28 BuildRequires: pkgconfig(xcursor)
29 BuildRequires: pkgconfig(zlib)
30 BuildRequires: swig
31 Provides: %{name}-python = %{version}-%{release}
32 Provides: python3-%{name} = %{version}-%{release}
33 Requires: %{libname} = %{version}-%{release}
34
35 %description
36 FIFE is a free, open-source cross-platform game engine, written in C++,
37 making it highly portable (it supports Linux, Windows and Mac).
38
39 This package comes with the game engine only.
40 The game Unknown Horizons is one of the clients using this engine.
41
42 %package -n %{libname}
43 Summary: Shared libs for FIFE
44 Group: System/Libraries
45 Requires: %{name} = %{version}-%{release}
46 Conflicts: fife < 0.3.3-7
47
48 %description -n %{libname}
49 Shared libs for FIFE.
50
51 %package -n %{develname}
52 Summary: Development package for FIFE
53 Group: Development/C++
54 Requires: %{libname} = %{version}-%{release}
55 Provides: %{name}-devel = %{version}-%{release}
56 Obsoletes: %{name}-devel < %{version}-%{release}
57 Conflicts: fife < 0.3.3-7
58
59 %description -n %develname
60 Files for development with FIFE.
61
62 %prep
63 %autosetup -n %{oname}-%{version}
64
65 # Fix libdir
66 sed -i CMakeLists.txt -e 's@\${CMAKE_INSTALL_PREFIX}/lib@\${CMAKE_INSTALL_PREFIX}/%{_lib}@'
67
68 # Drop deprecated swig options
69 sed -i CMakeLists.txt \
70 -e '/CMAKE_SWIG_FLAGS/s@-modern\s\?@@' \
71 -e '/CMAKE_SWIG_FLAGS/s@-nosafecstrings\s\?@@' \
72 -e '/CMAKE_SWIG_FLAGS/s@-noproxydel\s\?@@' \
73 -e '/CMAKE_SWIG_FLAGS/s@-fastinit\s\?@@' \
74 -e '/CMAKE_SWIG_FLAGS/s@-fastunpack\s\?@@' \
75 -e '/CMAKE_SWIG_FLAGS/s@-fastquery\s\?@@' \
76 -e '/CMAKE_SWIG_FLAGS/s@-modernargs\s\?@@' \
77 -e '/CMAKE_SWIG_FLAGS/s@-nobuildnone\s\?@@'
78
79 %build
80
81 %ifarch armv7hl
82 # Try to avoid memory exhaustion
83 export CFLAGS="%optflags -g1"
84 export CXXFLAGS="%optflags -g1"
85 %endif
86
87 %cmake \
88 -DPYTHON_SITE_PACKAGES=%{python3_sitearch} \
89 -DPYTHON_EXECUTABLE="%__python3" \
90 -Dbuild-library=ON \
91 -Dbuild-python=ON \
92 -Drend-camzone=ON \
93 -Drend-grid=ON \
94 -Duse-githash=OFF \
95 %ifarch armv7hl
96 -DCMAKE_BUILD_TYPE=Release \
97 %endif
98
99 %cmake_build -j1
100
101 %install
102 %cmake_install
103
104 %files
105 %doc AUTHORS CHANGELOG.md LICENSE.md README.md
106 %{python3_sitearch}/%{name}
107
108 %files -n %{libname}
109 %{_libdir}/lib%{name}.so.%{version}
110
111 %files -n %{develname}
112 %{_libdir}/lib%{name}.so
113 %{_includedir}/%{name}/

  ViewVC Help
Powered by ViewVC 1.1.30