/[packages]/cauldron/fife/current/SPECS/fife.spec
ViewVC logotype

Contents of /cauldron/fife/current/SPECS/fife.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 2036450 - (show annotations) (download)
Wed Jan 31 17:49:56 2024 UTC (2 months, 3 weeks ago) by daviddavid
File size: 2804 byte(s)
SILENT: cleanup a bit

1 %define soname %{version}
2 %define libname %mklibname %{name} %{soname}
3 %define develname %mklibname %{name} -d
4
5 %define oname fifengine
6
7 Name: fife
8 Version: 0.4.2
9 Release: %mkrel 24
10 Summary: Cross-platform game creation framework
11 Group: Development/Tools
12 License: LGPLv2+
13 URL: https://www.fifengine.net/
14 Source0: https://github.com/fifengine/fifengine/archive/%{version}/%{oname}-%{version}.tar.gz
15 # Upstream
16 Patch1: 0001-removed-flags-that-are-not-supported-with-swig-4.0.patch
17 Patch2: 0001-remove-deprecated-getchildren.patch
18 # Debian
19 Patch51: 0004-Try-to-fix-993132-cherry-picking-upstream-patches.patch
20 # Others
21 Patch101: fifengine-missing-includes.patch
22 BuildRequires: boost-devel
23 BuildRequires: cmake
24 BuildRequires: fifechan-devel >= 0.1.5
25 BuildRequires: pkgconfig(glew)
26 BuildRequires: pkgconfig(libpng)
27 BuildRequires: pkgconfig(openal)
28 BuildRequires: pkgconfig(python3)
29 BuildRequires: pkgconfig(sdl2)
30 BuildRequires: pkgconfig(SDL2_ttf)
31 BuildRequires: pkgconfig(SDL2_image)
32 BuildRequires: pkgconfig(tinyxml)
33 BuildRequires: pkgconfig(vorbis)
34 BuildRequires: pkgconfig(xcursor)
35 BuildRequires: pkgconfig(zlib)
36 BuildRequires: swig
37 Provides: %{name}-python = %{version}-%{release}
38 Provides: python3-%{name} = %{version}-%{release}
39 Requires: %{libname} = %{version}-%{release}
40
41 %description
42 FIFE is a free, open-source cross-platform game engine, written in C++,
43 making it highly portable (it supports Linux, Windows and Mac).
44
45 This package comes with the game engine only.
46 The game Unknown Horizons is one of the clients using this engine.
47
48 %package -n %{libname}
49 Summary: Shared libs for FIFE
50 Group: System/Libraries
51 Requires: %{name} = %{version}-%{release}
52
53 %description -n %{libname}
54 Shared libs for FIFE.
55
56 %package -n %{develname}
57 Summary: Development package for FIFE
58 Group: Development/C++
59 Requires: %{libname} = %{version}-%{release}
60 Provides: %{name}-devel = %{version}-%{release}
61 Obsoletes: %{name}-devel < %{version}-%{release}
62
63 %description -n %develname
64 Files for development with FIFE.
65
66 %prep
67 %autosetup -n %{oname}-%{version} -p1
68
69 # Fix libdir
70 sed -i CMakeLists.txt -e 's@\${CMAKE_INSTALL_PREFIX}/lib@\${CMAKE_INSTALL_PREFIX}/%{_lib}@'
71
72 %build
73
74 %ifarch armv7hl
75 # Try to avoid memory exhaustion
76 export CFLAGS="%optflags -g1"
77 export CXXFLAGS="%optflags -g1"
78 %endif
79
80 %cmake \
81 -DPYTHON_SITE_PACKAGES=%{python3_sitearch} \
82 -DPYTHON_EXECUTABLE="%__python3" \
83 -Dbuild-library=ON \
84 -Dbuild-python=ON \
85 -Drend-camzone=ON \
86 -Drend-grid=ON \
87 -Duse-githash=OFF \
88 %ifarch armv7hl
89 -DCMAKE_BUILD_TYPE=Release \
90 %endif
91
92 %cmake_build -j1
93
94 %install
95 %cmake_install
96
97 %files
98 %doc AUTHORS CHANGELOG.md README.md
99 %license LICENSE.md
100 %{python3_sitearch}/%{name}
101
102 %files -n %{libname}
103 %{_libdir}/lib%{name}.so.%{version}
104
105 %files -n %{develname}
106 %{_libdir}/lib%{name}.so
107 %{_includedir}/%{name}/

  ViewVC Help
Powered by ViewVC 1.1.30