1 |
ennael |
59350 |
%define name gmetadom |
2 |
|
|
%define version 0.2.6 |
3 |
|
|
%define release %mkrel 9 |
4 |
|
|
|
5 |
|
|
%define major 0 |
6 |
|
|
%define libname %mklibname gmetadom_gdome_cpp_smart %major |
7 |
|
|
|
8 |
|
|
%define _disable_ld_as_needed 1 |
9 |
|
|
|
10 |
|
|
Summary: C++ Wrapper for GDOME |
11 |
|
|
Name: %name |
12 |
|
|
Version: %version |
13 |
|
|
Release: %release |
14 |
|
|
Group: System/Libraries |
15 |
|
|
License: LGPL |
16 |
|
|
URL: http://gmetadom.sourceforge.net/ |
17 |
|
|
Source: %{name}-%{version}.tar.bz2 |
18 |
|
|
Patch0: gmetadom-0.2.3-gcc4.1.patch.bz2 |
19 |
|
|
Patch1: gmetadom-0.2.6-fix-missing-header.patch |
20 |
|
|
BuildRequires: ocaml |
21 |
|
|
BuildRequires: ocaml-findlib |
22 |
|
|
BuildRequires: gdome2-devel |
23 |
|
|
BuildRequires: libgdome-devel |
24 |
|
|
BuildRoot: %_tmppath/%{name}-%{version} |
25 |
|
|
|
26 |
|
|
%description |
27 |
|
|
GMetaDOM is a collection of libraries, each library providing a |
28 |
|
|
DOM implementation. Each DOM implementation is generated |
29 |
|
|
automatically by means of XSLT stylesheets. |
30 |
|
|
|
31 |
|
|
%package -n %libname |
32 |
|
|
Summary: CPP Libraries for gdome2 |
33 |
|
|
Group: System/Libraries |
34 |
|
|
|
35 |
|
|
%description -n %libname |
36 |
|
|
GMetaDOM is a collection of libraries, each library providing a |
37 |
|
|
DOM implementation. Each DOM implementation is generated |
38 |
|
|
automatically by means of XSLT stylesheets. |
39 |
|
|
|
40 |
|
|
%package -n %libname-devel |
41 |
|
|
Summary: Libraries and include files for gdome2 |
42 |
|
|
Group: Development/C++ |
43 |
|
|
Requires: %libname = %{version} |
44 |
|
|
Requires: glib2-devel >= 2.4.4 libgdome-devel libxml2-devel >= 2.6.11 |
45 |
|
|
Provides: %name-devel = %version-%release |
46 |
|
|
Provides: libgmetadom_gdome_cpp_smart-devel = %version-%release |
47 |
|
|
|
48 |
|
|
%description -n %libname-devel |
49 |
|
|
GMetaDOM is a collection of libraries, each library providing a |
50 |
|
|
DOM implementation. Each DOM implementation is generated |
51 |
|
|
automatically by means of XSLT stylesheets. |
52 |
|
|
|
53 |
|
|
%package -n ocaml-%{name} |
54 |
|
|
Group: Development/Other |
55 |
|
|
Summary: Ocaml bindings for %name |
56 |
|
|
Obsoletes: %{name}-ocaml |
57 |
|
|
|
58 |
|
|
%description -n ocaml-%{name} |
59 |
|
|
GMetaDOM is a collection of libraries, each library providing a |
60 |
|
|
DOM implementation. Each DOM implementation is generated |
61 |
|
|
automatically by means of XSLT stylesheets. |
62 |
|
|
|
63 |
|
|
This are the Ocaml bindings of GMetaDOM. |
64 |
|
|
|
65 |
|
|
%prep |
66 |
|
|
%setup -qn %{name}-%{version} |
67 |
|
|
%patch1 -p 1 |
68 |
|
|
|
69 |
|
|
%build |
70 |
|
|
#gw we have to disable libtoolize, as the ocaml path doesn't build otherwise |
71 |
|
|
%define __libtoolize true |
72 |
|
|
%configure2_5x --with-ocaml-lib-prefix=%{_libdir}/ocaml |
73 |
|
|
|
74 |
|
|
%install |
75 |
|
|
%makeinstall_std |
76 |
|
|
|
77 |
|
|
%clean |
78 |
|
|
rm -rf %{buildroot} |
79 |
|
|
|
80 |
|
|
%files -n %libname |
81 |
|
|
%defattr(-, root, root) |
82 |
|
|
%_libdir/lib*.so.* |
83 |
|
|
|
84 |
|
|
%files -n %libname-devel |
85 |
|
|
%defattr(-,root,root) |
86 |
|
|
%doc AUTHORS COPYING ChangeLog HISTORY INSTALL LICENSE |
87 |
|
|
%_includedir/* |
88 |
|
|
%_libdir/pkgconfig/*.pc |
89 |
|
|
%_libdir/lib*.so |
90 |
|
|
%_libdir/*.a |
91 |
|
|
%_libdir/*.la |
92 |
|
|
|
93 |
|
|
%files -n ocaml-%{name} |
94 |
|
|
%defattr(-, root, root) |
95 |
|
|
%{_libdir}/ocaml/gdome2 |
96 |
|
|
%{_libdir}/ocaml/stublibs/* |
97 |
|
|
|
98 |
|
|
|