1 |
%define name gnome-power-manager |
2 |
%define version 3.1.2 |
3 |
%define release %mkrel 1 |
4 |
%define schemasdir %{_datadir}/glib-2.0/schemas |
5 |
|
6 |
Name: %name |
7 |
Version: %version |
8 |
Release: %release |
9 |
Summary: GNOME Power Manager |
10 |
License: GPLv2+ |
11 |
Group: Graphical desktop/GNOME |
12 |
URL: http://www.gnome.org/projects/gnome-power-manager/ |
13 |
Source0: http://ftp.gnome.org/pub/GNOME/sources/gnome-power-manager/%{name}-%{version}.tar.xz |
14 |
BuildRequires: glib2-devel >= 2.25.9 |
15 |
BuildRequires: gtk+3-devel |
16 |
BuildRequires: libwnck-devel >= 2.10.0 |
17 |
BuildRequires: dbus-devel >= 0.50 |
18 |
BuildRequires: libcanberra-gtk-devel >= 0.10 |
19 |
BuildRequires: libGConf2-devel >= 2.31.1 |
20 |
BuildRequires: libgnome-keyring-devel >= 0.6.0 |
21 |
BuildRequires: libxrandr-devel >= 1.2.0 |
22 |
BuildRequires: libxrender-devel |
23 |
BuildRequires: libx11-devel |
24 |
BuildRequires: libxext-devel |
25 |
BuildRequires: x11-proto-devel |
26 |
BuildRequires: UPower-devel >= 0.9.1 |
27 |
BuildRequires: libnotify-devel >= 0.7.0 |
28 |
BuildRequires: xmlto |
29 |
BuildRequires: intltool |
30 |
BuildRequires: docbook-utils |
31 |
BuildRequires: docbook-dtd41-sgml |
32 |
BuildRequires: gnome-doc-utils >= 0.3.2 |
33 |
BuildRequires: libxslt-proc |
34 |
BuildRequires: imagemagick |
35 |
BuildRequires: desktop-file-utils |
36 |
Requires: gnome-mime-data |
37 |
Requires: gnome-icon-theme |
38 |
Requires(pre): GConf2 |
39 |
Requires(post): GConf2 |
40 |
Requires(post): scrollkeeper |
41 |
Requires(preun): GConf2 |
42 |
Requires(postun): scrollkeeper |
43 |
Requires: devicekit-power |
44 |
|
45 |
%description |
46 |
GNOME Power Manager uses the information and facilities provided by Upower |
47 |
displaying icons and handling user callbacks in an interactive GNOME session. |
48 |
GNOME Power Preferences allows authorised users to set policy and |
49 |
change preferences. |
50 |
|
51 |
%prep |
52 |
%setup -q |
53 |
|
54 |
%build |
55 |
libtoolize --copy --force --install |
56 |
autoreconf -fi |
57 |
%configure2_5x \ |
58 |
--with-doc-dir=%{buildroot}%{_datadir}/doc \ |
59 |
--with-dbus-services=%{buildroot}%{_datadir}/dbus-1/services |
60 |
make |
61 |
|
62 |
%install |
63 |
rm -rf %{buildroot} |
64 |
%makeinstall _ENABLE_SK=false gsettingsschemadir=%{buildroot}%{schemasdir} |
65 |
|
66 |
rm -f %{buildroot}%{_datadir}/icons/hicolor/icon-theme.cache |
67 |
rm -f %{buildroot}%{schemasdir}/gschemas.compiled |
68 |
|
69 |
%find_lang %name |
70 |
|
71 |
%define schemas %name |
72 |
|
73 |
%post |
74 |
glib-compile-schemas %{schemasdir} |
75 |
|
76 |
%files -f %{name}.lang |
77 |
%doc AUTHORS COPYING INSTALL NEWS README |
78 |
%{_sysconfdir}/xdg/autostart/gnome-power-manager.desktop |
79 |
%{_bindir}/* |
80 |
%_sbindir/gnome-power-backlight-helper |
81 |
%_datadir/polkit-1/actions/org.gnome.power.policy |
82 |
%{_datadir}/applications/* |
83 |
%{_datadir}/dbus-1/services/* |
84 |
%{_datadir}/gnome-power-manager |
85 |
%{_datadir}/gnome/help/gnome-power-manager |
86 |
%{_datadir}/omf/gnome-power-manager |
87 |
%{_mandir}/man1/* |
88 |
%{_datadir}/icons/hicolor/*/apps/gnome-* |
89 |
%{_datadir}/GConf/gsettings/org.gnome.power-manager.gschema.migrate |
90 |
%{schemasdir}/org.gnome.power-manager.gschema.xml |
91 |
%{_iconsdir}/gnome/scalable/status/keyboard-brightness-symbolic.svg |
92 |
|
93 |
|
94 |
|