/[packages]/cauldron/gnome-python-extras/current/SPECS/gnome-python-extras.spec
ViewVC logotype

Contents of /cauldron/gnome-python-extras/current/SPECS/gnome-python-extras.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 135837 - (show annotations) (download)
Sun Aug 28 05:09:17 2011 UTC (12 years, 7 months ago) by fwang
File size: 4996 byte(s)
rebuild for new ff
1 %define buildgtkhtml 1
2 %define pygtk 2.4.0
3 %define gnomepython 2.10.0
4 %define oname gnome-python
5 %define build_gda 1
6 %define gdaapi 4.0
7 %define build_gksu 0
8 %define build_gksu2 0
9
10 Summary: GNOME extra bindings for Python
11 Name: gnome-python-extras
12 Version: 2.25.3
13 Release: %mkrel 27
14 Source: ftp://ftp.gnome.org/pub/GNOME/sources/%{name}/%{name}-%{version}.tar.bz2
15 Patch3: gnome-python-extras-2.25.1-linkage.patch
16 Patch4: gnome-python-extras-2.25.3-drop-private-gdl-types.patch
17 URL: ftp://ftp.gnome.org/pub/GNOME/sources/gnome-python-extras
18 License: GPLv2+ and LGPLv2+
19 Group: Development/GNOME and GTK+
20 BuildRequires: pygtk2.0-devel >= %{pygtk}
21 BuildRequires: gnome-python >= %{gnomepython}
22 BuildRequires: python-devel >= 2.2
23 BuildRequires: libgnomeui2-devel >= 2.0.0
24 BuildRequires: gtksourceview1-devel >= 1.1.0
25 BuildRequires: libexpat-devel
26 BuildRequires: avahi-glib-devel
27 BuildRequires: avahi-client-devel
28 BuildRequires: gtk-doc
29 # gstreamer suggests codeine, codeine requires gnome-python-gtkmozembed
30 # which means gnome-python-extras requires itself to build.
31 # To fix this problem, we need to conflicts with gtkmozbembed, until
32 # iurt uses '--no-suggests' by default.
33 BuildConflicts: gnome-python-gtkmozembed
34 Requires: gnome-python >= %{gnomepython}
35 Requires: gnome-python-gnomevfs >= %{gnomepython}
36
37 %if %{buildgtkhtml}
38 BuildRequires: libgtkhtml2-devel >= 1.99.9
39 %endif
40
41 %description
42 The gnome-python-extras package contains the additional Python
43 bindings for GNOME.
44
45 %if %build_gda
46 %package -n %{oname}-gda
47 Summary: Python bindings for GNU Data Access
48 Group: Development/GNOME and GTK+
49 Requires: %{name} = %{version}-%{release}
50 BuildRequires: libgda%{gdaapi}-devel >= 3.99.9
51
52 %description -n %{oname}-gda
53 This module contains a wrapper that allows programs written in Python
54 to use GNU Data Access.
55
56 %package -n %{oname}-gda-devel
57 Summary: C header of the GNU Data Access Python bindings
58 Group: Development/C
59 Requires: %{oname}-gda = %{version}-%{release}
60
61 %description -n %{oname}-gda-devel
62 This is a C header needed for building extensions to the GNU Data
63 Access Python bindings.
64 %endif
65
66 %if %build_gksu
67 %package -n %{oname}-gksu
68 Summary: Python bindings for GKSu
69 Group: Development/GNOME and GTK+
70 Requires: %{name} = %{version}-%{release}
71 BuildRequires: libgksu1.2-devel
72 BuildRequires: libgksuui-devel
73
74 %description -n %{oname}-gksu
75 This module contains a wrapper that allows programs written in Python
76 to use GKSu.
77 %endif
78
79 %if %build_gksu2
80 %package -n %{oname}-gksu2
81 Summary: Python bindings for GKSu2
82 Group: Development/GNOME and GTK+
83 Requires: %{name} = %{version}-%{release}
84 BuildRequires: libgksu2-devel
85
86 %description -n %{oname}-gksu2
87 This module contains a wrapper that allows programs written in Python
88 to use GKSu.
89 %endif
90
91 %package -n %{oname}-gtkspell
92 Summary: Python bindings for gtkspell
93 Group: Development/GNOME and GTK+
94 Requires: %{name} = %{version}-%{release}
95 BuildRequires: gtkspell-devel
96
97 %description -n %{oname}-gtkspell
98 This module contains a wrapper that allows gnome python apps to use
99 the gtkspell library.
100
101 %package -n %{oname}-gtkmozembed
102 Summary: Python bindings for mozilla
103 Group: Development/GNOME and GTK+
104 Requires: %{name} = %{version}-%{release}
105 BuildRequires: xulrunner-devel
106 Requires: libxulrunner = %xulrunner_version
107
108 %description -n %{oname}-gtkmozembed
109 This module contains a wrapper that allows gnome python apps to embed
110 the mozilla browser.
111
112 %package -n %{oname}-gtkhtml2
113 Summary: Python bindings for interacting with gtkhtml2
114 Group: Development/GNOME and GTK+
115
116 %description -n %{oname}-gtkhtml2
117 This module contains a wrapper that allows the use of gtkhtml2 via
118 Python.
119
120 %prep
121 %setup -q
122 %patch3 -p1 -b .linkage
123 %patch4 -p0 -b .gdl
124 autoreconf -fi
125
126 %build
127 %configure2_5x --with-gtkmozembed=mozilla --enable-docs
128 %make
129
130 %install
131 rm -rf %{buildroot}
132 %makeinstall_std
133
134 #we don't want these
135 find %{buildroot} -name '*.la' -exec rm {} \;
136
137 %clean
138 rm -rf %{buildroot}
139
140 %files
141 %defattr(-,root,root)
142 %doc AUTHORS ChangeLog examples/egg/
143 %{_datadir}/pygtk/2.0/defs/
144 %{_libdir}/pkgconfig/%{name}-2.0.pc
145 %{python_sitearch}/gtk-2.0/egg/
146
147 %if %{build_gksu}
148 %files -n %{oname}-gksu
149 %defattr(-,root,root)
150 %{python_sitearch}/gtk-2.0/gksu/
151 %endif
152
153 %if %build_gksu2
154 %files -n %{oname}-gksu2
155 %defattr(-,root,root)
156 %{python_sitearch}/gtk-2.0/gksu2/
157 %endif
158
159 %if %build_gda
160 %files -n %{oname}-gda
161 %defattr(-,root,root)
162 %{_datadir}/pygtk/2.0/argtypes/gda-*
163 %{python_sitearch}/gtk-2.0/gda.so
164
165 %files -n %{oname}-gda-devel
166 %defattr(-,root,root)
167 %{_libdir}/pkgconfig/pygda-%{gdaapi}.pc
168 %{_includedir}/pygda-%{gdaapi}/
169 %endif
170
171 %files -n %{oname}-gtkspell
172 %defattr(-,root,root)
173 %doc examples/gtkspell
174 %doc %{_datadir}/gtk-doc/html/pygtkspell
175 %{python_sitearch}/gtk-2.0/gtkspell.so
176
177 %files -n %{oname}-gtkmozembed
178 %defattr(-,root,root)
179 %doc %{_datadir}/gtk-doc/html/pygtkmozembed
180 %{python_sitearch}/gtk-2.0/gtkmozembed.so
181
182 %if %{buildgtkhtml}
183 %files -n %{oname}-gtkhtml2
184 %defattr(-,root,root)
185 %doc examples/gtkhtml2
186 %{python_sitearch}/gtk-2.0/gtkhtml2.so
187 %endif

  ViewVC Help
Powered by ViewVC 1.1.30