/[packages]/cauldron/gnome-session/current/SPECS/gnome-session.spec
ViewVC logotype

Contents of /cauldron/gnome-session/current/SPECS/gnome-session.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 103471 - (show annotations) (download)
Sat Jun 11 13:01:44 2011 UTC (12 years, 10 months ago) by cjw
File size: 4583 byte(s)
- add dependency on notification-daemon

1 %define po_package gnome-session-3.0
2
3 Summary: The gnome desktop programs for the GNOME GUI desktop environment
4 Name: gnome-session
5 Version: 3.0.1
6 Release: %mkrel 2
7 License: GPLv2+
8 Group: Graphical desktop/GNOME
9 Source0: ftp://ftp.gnome.org/pub/GNOME/sources/%{name}/%{name}-%{version}.tar.bz2
10 Source1: gnome-session-startgnome
11 Source2: gnome-session-gnomerc
12 Source4: gnome-wm.desktop
13 # (blino) allow to pass sm client id to compositing wm
14 #Patch9: gnome-session-2.26.2-compositing-wm.patch
15 # https://bugzilla.gnome.org/show_bug.cgi?id=644325
16 #Patch10: gnome-session-3.0.1-renderer-blacklist.patch
17 Patch11: gnome-session-3.0.1-fix-format-string.patch
18 URL: http://www.gnome.org/softwaremap/projects/gnome-session/
19 Requires: GConf2 >= 1.2.1
20 Requires: desktop-common-data
21 Requires: gnome-user-docs
22 Requires: gnome-settings-daemon
23 Requires: %{name}-bin >= %{version}-%{release}
24 Requires: gsettings-desktop-schemas
25 Requires: dconf
26 Requires: notification-daemon >= 0.7.1-1
27 BuildRequires: x11-xtrans-devel
28 BuildRequires: libxtst-devel
29 BuildRequires: usermode-consoleonly
30 BuildRequires: tcp_wrappers-devel
31 BuildRequires: libGConf2-devel >= 1.2.1
32 BuildRequires: gtk+3-devel
33 BuildRequires: startup-notification-devel
34 BuildRequires: gnome-settings-daemon-devel
35 BuildRequires: UPower-devel
36 BuildRequires: avahi-glib-devel avahi-client-devel
37 BuildRequires: libgcrypt-devel
38 BuildRequires: intltool >= 0.40.0
39 BuildRequires: desktop-file-utils
40 BuildRequires: automake1.9
41 BuildRequires: libsm-devel
42 BuildRequires: librsvg-devel
43 BuildRequires: libxt-devel
44 BuildRequires: libxtst-devel
45 BuildRequires: libxau-devel
46 BuildRequires: libxrandr-devel
47 BuildRequires: x11-xtrans-devel
48 BuildRequires: mesagl-devel
49
50 %description
51 GNOME (GNU Network Object Model Environment) is a user-friendly
52 set of applications and desktop tools to be used in conjunction with a
53 window manager for the X Window System.
54
55 The GNOME Session Manager restores a set session (group of applications)
56 when you log into GNOME.
57
58 %package bin
59 Group: %{group}
60 Summary: %{summary}
61 Conflicts: gnome-session < 2.31.2
62 Requires: GConf2-sanity-check
63
64 %description bin
65 This package contains the binaries for the GNOME Session Manager, but
66 no startup scripts. It is meant for applications such as GDM that use
67 gnome-session internally.
68
69 %prep
70 %setup -q
71 %apply_patches
72
73 %build
74
75 %configure2_5x --with-default-wm=gnome-wm --enable-splash --with-gtk=3.0
76 %make
77
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81
82 GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1 %makeinstall_std
83
84 # wmsession session file
85 mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/X11/wmsession.d
86 cat << EOF > $RPM_BUILD_ROOT%{_sysconfdir}/X11/wmsession.d/02GNOME
87 NAME=GNOME
88 ICON=gnome-logo-icon-transparent.png
89 DESC=GNOME 3 Environment
90 EXEC=%{_bindir}/startgnome
91 SCRIPT:
92 exec %{_bindir}/startgnome
93 EOF
94
95 desktop-file-install --vendor="" \
96 --add-category="X-MandrivaLinux-System-Configuration-GNOME-Advanced" \
97 --add-category="GTK" \
98 --add-category="GNOME" \
99 --dir $RPM_BUILD_ROOT%{_datadir}/applications $RPM_BUILD_ROOT%{_datadir}/applications/*
100
101
102 install -m 0755 %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}/startgnome
103
104 mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/gnome
105 install -m 0755 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/gnome/gnomerc
106 # gw these produce rpmlint errors:
107 rm -rf %buildroot%_datadir/locale/{be@latin}
108
109 %find_lang %{po_package}
110
111
112 # remove unpackaged files
113 rm -rf $RPM_BUILD_ROOT%{_datadir}/xsessions
114
115
116 %define schemas gnome-session
117
118 %post
119 if [ "$1" = "2" -a -r /etc/sysconfig/desktop ]; then
120 sed -i -e "s|^DESKTOP=Gnome$|DESKTOP=GNOME|g" /etc/sysconfig/desktop
121 fi
122 %{make_session}
123
124 %preun bin
125 %preun_uninstall_gconf_schemas %{schemas}
126
127 %postun
128 %{make_session}
129
130 %posttrans
131 glib-compile-schemas %{_datadir}/glib-2.0/schemas || :
132
133 %clean
134 [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
135
136 %files bin
137 %defattr (-, root, root)
138 %{_datadir}/glib-2.0/schemas/org.gnome.SessionManager.gschema.xml
139 %{_bindir}/gnome-session
140 %{_mandir}/*/gnome-session.*
141 %{_datadir}/%name
142 %_datadir/icons/hicolor/*/apps/*
143
144 %files -f %{name}-3.0.lang
145 %defattr (-, root, root)
146 %config(noreplace) %{_sysconfdir}/X11/wmsession.d/*
147 %{_sysconfdir}/gnome/gnomerc
148 %{_bindir}/startgnome
149 %{_bindir}/gnome-session-quit
150 %{_bindir}/gnome-session-properties
151 %{_libdir}/gnome-session-check-accelerated
152 %{_libdir}/gnome-session-check-accelerated-helper
153 %{_datadir}/GConf/gsettings/gnome-session.convert
154 %{_datadir}/applications/*
155 %{_mandir}/*/gnome-session-properties.*
156 %{_mandir}/*/gnome-session-quit.*

  ViewVC Help
Powered by ViewVC 1.1.30