/[packages]/cauldron/gnome-vfsmm2.6/current/SPECS/gnome-vfsmm2.6.spec
ViewVC logotype

Contents of /cauldron/gnome-vfsmm2.6/current/SPECS/gnome-vfsmm2.6.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 48957 - (show annotations) (download)
Tue Feb 8 11:38:24 2011 UTC (13 years, 2 months ago) by ennael
File size: 3113 byte(s)
remove mdk version

1 %define version 2.26.0
2 %define release %mkrel 3
3
4 %define major 1
5 %define api_version 2.6
6
7 %define glibmm_version 2.4.0
8 %define gnome_vfs_version 2.8.1
9
10 %define pkgname gnome-vfsmm
11 %define libname %mklibname %pkgname %api_version %{major}
12 %define libname_orig %mklibname %pkgname %api_version
13 %define develname %mklibname -d %pkgname %api_version
14
15 Name: %{pkgname}%{api_version}
16 Summary: A C++ interface for GNOME VFS library
17 Version: %version
18 Release: %release
19 License: LGPLv2+
20 Group: System/Libraries
21 Source: http://ftp.gnome.org/pub/GNOME/sources/%{pkgname}/%{pkgname}-%{version}.tar.bz2
22 URL: http://gtkmm.sourceforge.net/
23 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
24 BuildRequires: gnome-vfs2-devel >= %{gnome_vfs_version}
25 BuildRequires: glibmm2.4-devel >= %{glibmm_version}
26 BuildRequires: doxygen
27
28 %description
29 This package provides a C++ interface for gnome-vfs (the GNOME
30 Virtual File System), which provides an abstraction to common file
31 system operations like reading, writing and copying files, listing
32 directories and so on. It is a subpackage of the gnomemm project,
33 which provides a C++ interface for GNOME libraries.
34
35 %package -n %{libname}
36 Summary: %{summary}
37 Group: %{group}
38 Provides: %{name} = %{version}-%{release}
39 Provides: %{libname_orig} = %{version}-%{release}
40
41 %description -n %{libname}
42 This package provides a C++ interface for gnome-vfs (the GNOME
43 Virtual File System), which provides an abstraction to common file
44 system operations like reading, writing and copying files, listing
45 directories and so on. It is a subpackage of the gnomemm project,
46 which provides a C++ interface for GNOME libraries.
47
48
49 %package -n %develname
50 Summary: Headers and development files of GNOME VFS C++ wrapper
51 Group: Development/GNOME and GTK+
52 Provides: %{name}-devel = %{version}-%{release}
53 Provides: %{libname_orig}-devel = %{version}-%{release}
54 Requires: %{libname} = %{version}
55 Requires: gnome-vfs2-devel >= %{gnome_vfs_version}
56 Requires: glibmm2.4-devel >= %{glibmm_version}
57 Obsoletes: %mklibname -d %pkgname 2.6 1
58
59 %description -n %develname
60 This package contains the headers and various development files needed,
61 when compiling or developing programs which want C++ wrapper of GNOME
62 VFS library.
63
64 %package doc
65 Summary: Documentation of %{pkgname} library
66 Group: Books/Other
67
68 %description doc
69 This package provides API documentation of %{pkgname} library.
70
71
72 %prep
73 %setup -q -n %pkgname-%version
74
75 %build
76 %configure2_5x --enable-static
77 %make
78
79 ### Build doc
80 pushd docs/reference
81 perl -pi -e 's/^(HAVE_DOT.*=) YES/$1 NO/' Doxyfile
82 make all
83 popd
84
85 %install
86 rm -rf %{buildroot}
87 %makeinstall_std
88 find %buildroot -name \*.la|xargs chmod 644
89
90 %clean
91 rm -rf %{buildroot}
92
93 %files -n %{libname}
94 %defattr(-, root, root)
95 %doc COPYING
96 %{_libdir}/libgnomevfsmm-%{api_version}.so.%{major}*
97
98 %files -n %develname
99 %defattr(-, root, root)
100 %doc AUTHORS COPYING ChangeLog NEWS README
101 %{_includedir}/*
102 %{_libdir}/%{pkgname}-%{api_version}
103 %{_libdir}/pkgconfig/*.pc
104 %{_libdir}/*.a
105 %{_libdir}/*.la
106 %{_libdir}/*.so
107
108 %files doc
109 %defattr(-, root, root)
110 %doc docs/reference/html
111
112
113
114

  ViewVC Help
Powered by ViewVC 1.1.30