/[packages]/cauldron/gobject-introspection/current/SPECS/gobject-introspection.spec
ViewVC logotype

Annotation of /cauldron/gobject-introspection/current/SPECS/gobject-introspection.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 72156 - (hide annotations) (download)
Tue Mar 15 20:25:25 2011 UTC (13 years, 1 month ago) by ahmad
File size: 4445 byte(s)
- update to 0.10.4
- rediff patches (add one more linking fix)

1 dmorgan 7041 %define name gobject-introspection
2 ahmad 72156 %define version 0.10.4
3 dmorgan 7041 %define git 0
4     %define rel 2
5 ahmad 72156 %define major_ver 0.10
6 dmorgan 7041 %if %git
7     %define release %mkrel -c %git %rel
8     %else
9     %define release %mkrel %rel
10     %endif
11    
12 rtp 52848 %define bootstrap 0
13     %{?_without_bootstrap: %global bootstrap 0}
14     %{?_with_bootstrap: %global bootstrap 1}
15 dmorgan 7041
16     %define api 1.0
17     %define major 1
18     %define libname %mklibname girepository %api %major
19     %define develname %mklibname -d girepository
20    
21     Summary: GObject Introspection
22     Name: %{name}
23     Version: %{version}
24     Release: %{release}
25     %if %git
26     Source0: %{name}-%{git}.tar.xz
27     %else
28 ahmad 72156 Source0: ftp://ftp.gnome.org/pub/GNOME/sources/%name/%{major_ver}/%{name}-%{version}.tar.bz2
29 dmorgan 7041 %endif
30     Patch0: gobject-introspection-fix-link.patch
31     Patch2: gobject-introspection-add-workarounds-for-libgnomekeyring-and-libgda.patch
32     License: GPLv2+ and LGPLv2+
33     Group: Development/C
34     Url: http://www.gnome.org
35     BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
36     BuildRequires: glib2-devel >= 2.25.8
37     BuildRequires: ffi5-devel
38     BuildRequires: python-devel
39     BuildRequires: freetype2-devel
40     BuildRequires: cairo-devel
41     BuildRequires: fontconfig-devel
42     BuildRequires: GL-devel
43     BuildRequires: libxft-devel
44     BuildRequires: flex bison
45     BuildRequires: gnome-common
46     BuildRequires: libtool
47 rtp 52848 %if !%bootstrap
48 dmorgan 7041 BuildRequires: gtk-doc
49 rtp 52848 %endif
50 dmorgan 7041 Conflicts: %{mklibname girepository 1.0 0} < 0.6.10-5mdv
51     Conflicts: gir-repository < 0.6.5-12.20100622.3mdv
52    
53     %description
54     The goal of the project is to describe the APIs and collect them in
55     a uniform, machine readable format.
56    
57     %package -n %libname
58     Group: System/Libraries
59     Summary: GObject Introspection shared library
60     Conflicts: %name < 0.6.8-2mdv
61     Requires: %name >= %version
62    
63     %description -n %libname
64     The goal of the project is to describe the APIs and collect them in
65     a uniform, machine readable format.
66    
67    
68     %package -n %develname
69     Group: Development/C
70     Summary: GObject Introspection development libraries
71     Requires: %libname = %version-%release
72     Provides: libgirepository-devel = %version-%release
73     Provides: %name-devel = %version-%release
74     #gw /usr/bin/libtool is called in giscanner
75     Requires: libtool
76    
77     %description -n %develname
78     The goal of the project is to describe the APIs and collect them in
79     a uniform, machine readable format.
80    
81     %prep
82     %if %git
83     %setup -q -n %name
84     %else
85     %setup -q
86     %endif
87     %apply_patches
88     %if %git
89     ./autogen.sh -V
90     %else
91     autoreconf -fi
92     %endif
93    
94     %build
95 rtp 52848 %configure2_5x --disable-static \
96     %if !%bootstrap
97     --enable-gtk-doc
98     %endif
99    
100 dmorgan 7041 %make
101    
102     %install
103     rm -rf %{buildroot}
104     %makeinstall_std
105    
106     %check
107     #gw: https://bugzilla.gnome.org/show_bug.cgi?id=630136
108     #make check
109    
110     %clean
111     rm -rf %{buildroot}
112    
113     %files
114     %defattr(-,root,root)
115     %doc README NEWS TODO AUTHORS
116     %dir %_libdir/girepository-%api
117     %_libdir/girepository-%api/DBus-1.0.typelib
118     %_libdir/girepository-%api/DBusGLib-1.0.typelib
119     %_libdir/girepository-%api/GIRepository-2.0.typelib
120     %_libdir/girepository-%api/GL-1.0.typelib
121     %_libdir/girepository-%api/GLib-2.0.typelib
122     %_libdir/girepository-%api/GModule-2.0.typelib
123     %_libdir/girepository-%api/GObject-2.0.typelib
124     %_libdir/girepository-%api/Gio-2.0.typelib
125     %_libdir/girepository-%api/cairo-1.0.typelib
126     %_libdir/girepository-%api/fontconfig-2.0.typelib
127     %_libdir/girepository-%api/freetype2-2.0.typelib
128     %_libdir/girepository-%api/libxml2-2.0.typelib
129     %_libdir/girepository-%api/xfixes-4.0.typelib
130     %_libdir/girepository-%api/xft-2.0.typelib
131     %_libdir/girepository-%api/xlib-2.0.typelib
132     %_libdir/girepository-%api/xrandr-1.3.typelib
133    
134     %files -n %libname
135     %defattr(-,root,root)
136     %_libdir/libgirepository-%api.so.%{major}*
137    
138     %files -n %develname
139     %defattr(-,root,root)
140     %doc ChangeLog
141     %_libdir/libgirepository-%api.so
142     %_libdir/libgirepository*a
143     %_libdir/pkgconfig/gobject-introspection-%api.pc
144     %_libdir/pkgconfig/gobject-introspection-no-export-%api.pc
145     %_includedir/%name-%api
146     %_datadir/aclocal/*.m4
147     %_datadir/%name-%api
148     %_bindir/g-ir-*
149     %_libdir/%name
150     %_datadir/gtk-doc/html/gi
151     %dir %_datadir/gir-%api
152     %_datadir/gir-%api/DBus-1.0.gir
153     %_datadir/gir-%api/DBusGLib-1.0.gir
154     %_datadir/gir-%api/GIRepository-2.0.gir
155     %_datadir/gir-%api/GL-1.0.gir
156     %_datadir/gir-%api/GLib-2.0.gir
157     %_datadir/gir-%api/GModule-2.0.gir
158     %_datadir/gir-%api/GObject-2.0.gir
159     %_datadir/gir-%api/Gio-2.0.gir
160     %_datadir/gir-%api/cairo-1.0.gir
161     %_datadir/gir-%api/fontconfig-2.0.gir
162     %_datadir/gir-%api/freetype2-2.0.gir
163     %_datadir/gir-%api/libxml2-2.0.gir
164     %_datadir/gir-%api/xfixes-4.0.gir
165     %_datadir/gir-%api/xft-2.0.gir
166     %_datadir/gir-%api/xlib-2.0.gir
167     %_datadir/gir-%api/xrandr-1.3.gir
168     %_mandir/man1/*
169    
170    

  ViewVC Help
Powered by ViewVC 1.1.30