1 |
%define api 1.0 |
2 |
%define major 1 |
3 |
%define libname %mklibname girepository %{api} %{major} |
4 |
%define develname %mklibname -d girepository |
5 |
|
6 |
%define url_ver %(echo %{version} | cut -d. -f1,2) |
7 |
|
8 |
Summary: GObject Introspection |
9 |
Name: gobject-introspection |
10 |
Version: 1.41.91 |
11 |
Release: %mkrel 7 |
12 |
Source0: https://download.gnome.org/sources/%{name}/%{url_ver}/%{name}-%{version}.tar.xz |
13 |
# PATCH-FIX-UPSTREAM g-ir-dep-tool.patch bgo#665672 dimstar@opensuse.org -- Add g-ir-dep-tool to get further automatic dependencies. |
14 |
Patch0: g-ir-dep-tool.patch |
15 |
License: GPLv2+ and LGPLv2+ |
16 |
Group: Development/C |
17 |
Url: http://www.gnome.org |
18 |
BuildRequires: pkgconfig(cairo) |
19 |
BuildRequires: pkgconfig(cairo-gobject) |
20 |
BuildRequires: pkgconfig(gio-2.0) |
21 |
BuildRequires: pkgconfig(gio-unix-2.0) |
22 |
BuildRequires: pkgconfig(glib-2.0) >= 2.29.7 |
23 |
BuildRequires: pkgconfig(gmodule-2.0) |
24 |
BuildRequires: pkgconfig(gobject-2.0) |
25 |
BuildRequires: pkgconfig(gthread-2.0) |
26 |
BuildRequires: pkgconfig(libffi) |
27 |
BuildRequires: pkgconfig(python) |
28 |
BuildRequires: python-mako |
29 |
BuildRequires: flex |
30 |
BuildRequires: bison |
31 |
BuildRequires: gnome-common |
32 |
BuildRequires: libtool |
33 |
BuildRequires: gtk-doc |
34 |
# temp cauldron fix: |
35 |
BuildRequires: rpm-mageia-setup-build >= 2.0-2.mga5 |
36 |
Conflicts: %{mklibname girepository 1.0 0} < 0.6.10-5mdv |
37 |
Conflicts: gir-repository < 0.6.5-12.20100622.3mdv |
38 |
|
39 |
%description |
40 |
The goal of the project is to describe the APIs and collect them in |
41 |
a uniform, machine readable format. |
42 |
|
43 |
%package -n %{libname} |
44 |
Group: System/Libraries |
45 |
Summary: GObject Introspection shared library |
46 |
Conflicts: %{name} < 0.6.8-2mdv |
47 |
Requires: %{name} >= %{version} |
48 |
|
49 |
%description -n %{libname} |
50 |
The goal of the project is to describe the APIs and collect them in |
51 |
a uniform, machine readable format. |
52 |
|
53 |
|
54 |
#--------------------------------------------------------------- |
55 |
%if "%{_lib}" == "lib64" |
56 |
%define mark64 ()(64bit) |
57 |
%else |
58 |
%define mark64 %nil |
59 |
%endif |
60 |
|
61 |
#--------------------------------------------------------------- |
62 |
%define girglibname %mklibname glib-gir 2.0 |
63 |
|
64 |
%package -n %{girglibname} |
65 |
Summary: GObject Introspection interface description for glib |
66 |
Group: System/Libraries |
67 |
Conflicts: %{name} < 1.29.16-3 |
68 |
Requires: libglib-2.0.so.0%{mark64} |
69 |
Requires: libgmodule-2.0.so.0%{mark64} |
70 |
Requires: libgio-2.0.so.0%{mark64} |
71 |
Requires: libgobject-2.0.so.0%{mark64} |
72 |
|
73 |
%description -n %{girglibname} |
74 |
GObject Introspection interface description for glib. |
75 |
|
76 |
%files -n %{girglibname} |
77 |
%{_libdir}/girepository-1.0/GLib-2.0.typelib |
78 |
%{_libdir}/girepository-1.0/GModule-2.0.typelib |
79 |
%{_libdir}/girepository-1.0/GObject-2.0.typelib |
80 |
%{_libdir}/girepository-1.0/Gio-2.0.typelib |
81 |
|
82 |
#--------------------------------------------------------------- |
83 |
%define girdbusname %mklibname dbus-gir 1.0 |
84 |
|
85 |
%package -n %{girdbusname} |
86 |
Summary: GObject Introspection interface description for dbus |
87 |
Group: System/Libraries |
88 |
Conflicts: %{name} < 1.29.16-3 |
89 |
Requires: libdbus-1.so.3%{mark64} |
90 |
|
91 |
%description -n %{girdbusname} |
92 |
GObject Introspection interface description for dbus. |
93 |
|
94 |
%files -n %{girdbusname} |
95 |
%{_libdir}/girepository-1.0/DBus-1.0.typelib |
96 |
|
97 |
#--------------------------------------------------------------- |
98 |
%define girdbusglibname %mklibname dbusglib-gir 1.0 |
99 |
|
100 |
%package -n %{girdbusglibname} |
101 |
Summary: GObject Introspection interface description for dbusglib |
102 |
Group: System/Libraries |
103 |
Conflicts: %{name} < 1.29.16-3 |
104 |
Requires: libdbus-glib-1.so.2%{mark64} |
105 |
|
106 |
%description -n %{girdbusglibname} |
107 |
GObject Introspection interface description for dbusglib. |
108 |
|
109 |
%files -n %{girdbusglibname} |
110 |
%{_libdir}/girepository-1.0/DBusGLib-1.0.typelib |
111 |
|
112 |
#--------------------------------------------------------------- |
113 |
%define girgirepositoryname %mklibname girepository-gir 2.0 |
114 |
|
115 |
%package -n %{girgirepositoryname} |
116 |
Summary: GObject Introspection interface description for girepository |
117 |
Group: System/Libraries |
118 |
Conflicts: %{name} < 1.29.16-3 |
119 |
Requires: %{libname} = %{version}-%{release} |
120 |
|
121 |
%description -n %{girgirepositoryname} |
122 |
GObject Introspection interface description for girepository. |
123 |
|
124 |
%files -n %{girgirepositoryname} |
125 |
%{_libdir}/girepository-1.0/GIRepository-2.0.typelib |
126 |
|
127 |
#--------------------------------------------------------------- |
128 |
%define girglname %mklibname gl-gir 1.0 |
129 |
|
130 |
%package -n %{girglname} |
131 |
Summary: GObject Introspection interface description for OpenGL |
132 |
Group: System/Libraries |
133 |
Conflicts: %{name} < 1.29.16-3 |
134 |
Requires: libGL.so.1%{mark64} |
135 |
|
136 |
%description -n %{girglname} |
137 |
GObject Introspection interface description for OpenGL. |
138 |
|
139 |
%files -n %{girglname} |
140 |
%{_libdir}/girepository-1.0/GL-1.0.typelib |
141 |
|
142 |
#--------------------------------------------------------------- |
143 |
%define gircaironame %mklibname cairo-gir 1.0 |
144 |
|
145 |
%package -n %{gircaironame} |
146 |
Summary: GObject Introspection interface description for cairo |
147 |
Group: System/Libraries |
148 |
Conflicts: %{name} < 1.29.16-3 |
149 |
Requires: libcairo.so.2%{mark64} |
150 |
|
151 |
%description -n %{gircaironame} |
152 |
GObject Introspection interface description for cairo. |
153 |
|
154 |
%files -n %{gircaironame} |
155 |
%{_libdir}/girepository-1.0/cairo-1.0.typelib |
156 |
|
157 |
#--------------------------------------------------------------- |
158 |
%define girfontconfigname %mklibname fontconfig-gir 2.0 |
159 |
|
160 |
%package -n %{girfontconfigname} |
161 |
Summary: GObject Introspection interface description for fontconfig |
162 |
Group: System/Libraries |
163 |
Conflicts: %{name} < 1.29.16-3 |
164 |
Requires: libfontconfig.so.1%{mark64} |
165 |
|
166 |
%description -n %{girfontconfigname} |
167 |
GObject Introspection interface description for fontconfig. |
168 |
|
169 |
%files -n %{girfontconfigname} |
170 |
%{_libdir}/girepository-1.0/fontconfig-2.0.typelib |
171 |
|
172 |
#--------------------------------------------------------------- |
173 |
%define girfreetypename %mklibname freetype-gir 2.0 |
174 |
|
175 |
%package -n %{girfreetypename} |
176 |
Summary: GObject Introspection interface description for freetype |
177 |
Group: System/Libraries |
178 |
Conflicts: %{name} < 1.29.16-3 |
179 |
Requires: libfreetype.so.6%{mark64} |
180 |
|
181 |
%description -n %{girfreetypename} |
182 |
GObject Introspection interface description for freetype. |
183 |
|
184 |
%files -n %{girfreetypename} |
185 |
%{_libdir}/girepository-1.0/freetype2-2.0.typelib |
186 |
|
187 |
#--------------------------------------------------------------- |
188 |
%define girlibxml2name %mklibname xml2-gir 2.0 |
189 |
|
190 |
%package -n %{girlibxml2name} |
191 |
Summary: GObject Introspection interface description for libxml2 |
192 |
Group: System/Libraries |
193 |
Conflicts: %{name} < 1.29.16-3 |
194 |
Requires: libxml2.so.2%{mark64} |
195 |
Obsoletes: %{_lib}libxml2-gir2.0 < 1.36.0-2 |
196 |
|
197 |
%description -n %{girlibxml2name} |
198 |
GObject Introspection interface description for libxml2. |
199 |
|
200 |
%files -n %{girlibxml2name} |
201 |
%{_libdir}/girepository-1.0/libxml2-2.0.typelib |
202 |
|
203 |
#--------------------------------------------------------------- |
204 |
%define girxfixesname %mklibname xfixes-gir 4.0 |
205 |
|
206 |
%package -n %{girxfixesname} |
207 |
Summary: GObject Introspection interface description for xfixes |
208 |
Group: System/Libraries |
209 |
Conflicts: %{name} < 1.29.16-3 |
210 |
Requires: libXfixes.so.3%{mark64} |
211 |
|
212 |
%description -n %{girxfixesname} |
213 |
GObject Introspection interface description for xfixes. |
214 |
|
215 |
%files -n %{girxfixesname} |
216 |
%{_libdir}/girepository-1.0/xfixes-4.0.typelib |
217 |
|
218 |
#--------------------------------------------------------------- |
219 |
%define girxftname %mklibname xft-gir 2.0 |
220 |
|
221 |
%package -n %{girxftname} |
222 |
Summary: GObject Introspection interface description for xft |
223 |
Group: System/Libraries |
224 |
Conflicts: %{name} < 1.29.16-3 |
225 |
Requires: libXft.so.2%{mark64} |
226 |
|
227 |
%description -n %{girxftname} |
228 |
GObject Introspection interface description for xft. |
229 |
|
230 |
%files -n %{girxftname} |
231 |
%{_libdir}/girepository-1.0/xft-2.0.typelib |
232 |
|
233 |
#--------------------------------------------------------------- |
234 |
%define girxlibname %mklibname xlib-gir 2.0 |
235 |
|
236 |
%package -n %{girxlibname} |
237 |
Summary: GObject Introspection interface description for xlib |
238 |
Group: System/Libraries |
239 |
Conflicts: %{name} < 1.29.16-3 |
240 |
Requires: libX11.so.6%{mark64} |
241 |
|
242 |
%description -n %{girxlibname} |
243 |
GObject Introspection interface description for xlib. |
244 |
|
245 |
%files -n %{girxlibname} |
246 |
%{_libdir}/girepository-1.0/xlib-2.0.typelib |
247 |
|
248 |
#--------------------------------------------------------------- |
249 |
%define girxrandrname %mklibname xrandr-gir 1.3 |
250 |
|
251 |
%package -n %{girxrandrname} |
252 |
Summary: GObject Introspection interface description for xrandr |
253 |
Group: System/Libraries |
254 |
Conflicts: %{name} < 1.29.16-3 |
255 |
Requires: libXrandr.so.2%{mark64} |
256 |
|
257 |
%description -n %{girxrandrname} |
258 |
GObject Introspection interface description for xrandr. |
259 |
|
260 |
%files -n %{girxrandrname} |
261 |
%{_libdir}/girepository-1.0/xrandr-1.3.typelib |
262 |
|
263 |
#--------------------------------------------------------------- |
264 |
%define girwin32name %mklibname win32-gir 1.0 |
265 |
|
266 |
%package -n %{girwin32name} |
267 |
Summary: GObject Introspection interface description for win32 |
268 |
Group: System/Libraries |
269 |
|
270 |
%description -n %{girwin32name} |
271 |
GObject Introspection interface description for win32. |
272 |
|
273 |
%files -n %{girwin32name} |
274 |
%{_libdir}/girepository-1.0/win32-1.0.typelib |
275 |
|
276 |
#--------------------------------------------------------------- |
277 |
%package -n %{develname} |
278 |
Group: Development/C |
279 |
Summary: GObject Introspection development libraries |
280 |
Requires: %{libname} = %{version}-%{release} |
281 |
Requires: %{girglibname} = %{version}-%{release} |
282 |
Requires: %{girdbusname} = %{version}-%{release} |
283 |
Requires: %{girdbusglibname} = %{version}-%{release} |
284 |
Requires: %{girgirepositoryname} = %{version}-%{release} |
285 |
Requires: %{girglname} = %{version}-%{release} |
286 |
Requires: %{gircaironame} = %{version}-%{release} |
287 |
Requires: %{girfontconfigname} = %{version}-%{release} |
288 |
Requires: %{girfreetypename} = %{version}-%{release} |
289 |
Requires: %{girlibxml2name} = %{version}-%{release} |
290 |
Requires: %{girxfixesname} = %{version}-%{release} |
291 |
Requires: %{girxftname} = %{version}-%{release} |
292 |
Requires: %{girxlibname} = %{version}-%{release} |
293 |
Requires: %{girxrandrname} = %{version}-%{release} |
294 |
Requires: %{girwin32name} = %{version}-%{release} |
295 |
Provides: libgirepository-devel = %{version}-%{release} |
296 |
Provides: %{name}-devel = %{version}-%{release} |
297 |
#gw /usr/bin/libtool is called in giscanner |
298 |
Requires: libtool |
299 |
|
300 |
%description -n %{develname} |
301 |
The goal of the project is to describe the APIs and collect them in |
302 |
a uniform, machine readable format. |
303 |
|
304 |
#--------------------------------------------------------------- |
305 |
%prep |
306 |
%setup -q |
307 |
%apply_patches |
308 |
|
309 |
%build |
310 |
autoreconf -fi |
311 |
%configure2_5x \ |
312 |
--disable-static --enable-doctool --enable-gtk-doc |
313 |
|
314 |
%make |
315 |
|
316 |
%install |
317 |
%makeinstall_std |
318 |
|
319 |
# don't ship .la |
320 |
find %{buildroot} -name '*.la' -delete |
321 |
|
322 |
%check |
323 |
make check |
324 |
|
325 |
%files |
326 |
%doc README NEWS TODO AUTHORS |
327 |
%dir %{_libdir}/girepository-%{api} |
328 |
|
329 |
%files -n %{libname} |
330 |
%{_libdir}/libgirepository-%{api}.so.%{major}* |
331 |
|
332 |
%files -n %{develname} |
333 |
%doc ChangeLog |
334 |
%{_libdir}/libgirepository-%{api}.so |
335 |
%{_libdir}/pkgconfig/gobject-introspection-%{api}.pc |
336 |
%{_libdir}/pkgconfig/gobject-introspection-no-export-%{api}.pc |
337 |
%{_includedir}/%{name}-%{api} |
338 |
%{_datadir}/aclocal/*.m4 |
339 |
%{_datadir}/%{name}-%{api} |
340 |
%{_bindir}/g-ir-* |
341 |
%{_libdir}/%{name} |
342 |
%{_datadir}/gtk-doc/html/gi |
343 |
%dir %{_datadir}/gir-%{api} |
344 |
%{_datadir}/gir-%{api}/DBus-1.0.gir |
345 |
%{_datadir}/gir-%{api}/DBusGLib-1.0.gir |
346 |
%{_datadir}/gir-%{api}/GIRepository-2.0.gir |
347 |
%{_datadir}/gir-%{api}/GL-1.0.gir |
348 |
%{_datadir}/gir-%{api}/GLib-2.0.gir |
349 |
%{_datadir}/gir-%{api}/GModule-2.0.gir |
350 |
%{_datadir}/gir-%{api}/GObject-2.0.gir |
351 |
%{_datadir}/gir-%{api}/Gio-2.0.gir |
352 |
%{_datadir}/gir-%{api}/cairo-1.0.gir |
353 |
%{_datadir}/gir-%{api}/fontconfig-2.0.gir |
354 |
%{_datadir}/gir-%{api}/freetype2-2.0.gir |
355 |
%{_datadir}/gir-%{api}/libxml2-2.0.gir |
356 |
%{_datadir}/gir-%{api}/xfixes-4.0.gir |
357 |
%{_datadir}/gir-%{api}/xft-2.0.gir |
358 |
%{_datadir}/gir-%{api}/xlib-2.0.gir |
359 |
%{_datadir}/gir-%{api}/xrandr-1.3.gir |
360 |
%{_datadir}/gir-%{api}/win32-1.0.gir |
361 |
%{_mandir}/man1/* |