1 |
thatsamguy |
559391 |
%define prerelease 74691fb6f83716190870cde1b658538dd4b18eb0 |
2 |
|
|
%define import_path code.google.com/p/gosqlite |
3 |
|
|
%define gopath %{_libdir}/golang |
4 |
|
|
%define gosrc %{gopath}/src/%{import_path} |
5 |
|
|
%define shortcommit %(c=%{prerelease}; echo ${c:0:12}) |
6 |
|
|
Summary: Trivial sqlite3 binding for Go |
7 |
|
|
Name: golang-sqlite |
8 |
|
|
Version: 0.1.git%{shortcommit} |
9 |
|
|
Release: %mkrel 1 |
10 |
|
|
License: BSD |
11 |
|
|
Group: Development/Other |
12 |
|
|
Url: http://gosqlite.googlecode.com |
13 |
|
|
Source0: http://gosqlite.googlecode.com/archive/%{prerelease}.zip |
14 |
|
|
Provides: golang(%{import_path}) = %{version}-%{release} |
15 |
|
|
Provides: golang(%{import_path}/sqlite) = %{version}-%{release} |
16 |
|
|
Provides: golang(%{import_path}/sqlite3) = %{version}-%{release} |
17 |
|
|
|
18 |
|
|
%description |
19 |
|
|
Trivial sqlite3 binding for Go |
20 |
|
|
|
21 |
|
|
%prep |
22 |
|
|
cd %{_builddir} |
23 |
|
|
unzip %{SOURCE0} |
24 |
|
|
|
25 |
|
|
%build |
26 |
|
|
cd %{_builddir}/gosqlite-%{shortcommit} |
27 |
|
|
|
28 |
|
|
%install |
29 |
|
|
mkdir -p %{buildroot}%{gosrc} |
30 |
|
|
cp -av %{_builddir}/gosqlite-%{shortcommit}/* %{buildroot}%{gosrc}/ |
31 |
|
|
|
32 |
|
|
%files |
33 |
|
|
%{gosrc}/* |