1 |
thatsamguy |
559391 |
%define prerelease 74691fb6f83716190870cde1b658538dd4b18eb0 |
2 |
|
|
%define import_path code.google.com/p/gosqlite |
3 |
|
|
%define gopath %{_libdir}/golang |
4 |
bcornec |
641554 |
%define gosrc %{gopath}/src/pkg/%{import_path} |
5 |
thatsamguy |
559391 |
%define shortcommit %(c=%{prerelease}; echo ${c:0:12}) |
6 |
bcornec |
641554 |
|
7 |
thatsamguy |
559391 |
Summary: Trivial sqlite3 binding for Go |
8 |
|
|
Name: golang-sqlite |
9 |
|
|
Version: 0.1.git%{shortcommit} |
10 |
umeabot |
1791910 |
Release: %mkrel 8 |
11 |
thatsamguy |
559391 |
License: BSD |
12 |
|
|
Group: Development/Other |
13 |
|
|
Url: http://gosqlite.googlecode.com |
14 |
|
|
Source0: http://gosqlite.googlecode.com/archive/%{prerelease}.zip |
15 |
|
|
Provides: golang(%{import_path}) = %{version}-%{release} |
16 |
|
|
Provides: golang(%{import_path}/sqlite) = %{version}-%{release} |
17 |
|
|
Provides: golang(%{import_path}/sqlite3) = %{version}-%{release} |
18 |
|
|
|
19 |
|
|
%description |
20 |
|
|
Trivial sqlite3 binding for Go |
21 |
|
|
|
22 |
|
|
%prep |
23 |
|
|
cd %{_builddir} |
24 |
|
|
unzip %{SOURCE0} |
25 |
|
|
|
26 |
|
|
%build |
27 |
|
|
cd %{_builddir}/gosqlite-%{shortcommit} |
28 |
|
|
|
29 |
|
|
%install |
30 |
|
|
mkdir -p %{buildroot}%{gosrc} |
31 |
|
|
cp -av %{_builddir}/gosqlite-%{shortcommit}/* %{buildroot}%{gosrc}/ |
32 |
|
|
|
33 |
|
|
%files |
34 |
|
|
%{gosrc}/* |