/[packages]/cauldron/gstreamer0.10-plugins-ugly/current/SPECS/gstreamer0.10-plugins-ugly.spec
ViewVC logotype

Contents of /cauldron/gstreamer0.10-plugins-ugly/current/SPECS/gstreamer0.10-plugins-ugly.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 87682 - (show annotations) (download)
Mon Apr 18 12:45:38 2011 UTC (13 years ago) by wally
File size: 7346 byte(s)
- new version 0.10.17
- rediff patch
- clean .spec a bit

1 %define version 0.10.17
2 %define release 1
3
4 %define _glib2 2.2
5 %define major 0.10
6 %define majorminor 0.10
7 %define bname gstreamer0.10
8 %define name %{bname}-plugins-ugly
9 %define build_plf 0
10 %{?_with_plf: %{expand: %%global build_plf 1}}
11 %define build_experimental 0
12 %{?_with_experimental: %{expand: %%global build_experimental 1}}
13 %define build_lame 0
14 %define build_amrnb 0
15 %define build_amrwbdec 0
16 %define build_x264 0
17
18 %if %build_plf
19 %define distsuffix plf
20 %define build_lame 1
21 %define build_x264 1
22 %define build_amrnb 1
23 %define build_amrwbdec 1
24 %endif
25
26 Summary: GStreamer Streaming-media framework plug-ins
27 Name: %{name}
28 Version: %{version}
29 Release: %mkrel %{release}
30 License: LGPLv2+
31 Group: Sound
32 Source: http://gstreamer.freedesktop.org/src/gst-plugins-ugly/gst-plugins-ugly-%{version}.tar.bz2
33 Patch0: gstreamer-plugins-ugly-0.10.17-amr-linking.patch
34 URL: http://gstreamer.freedesktop.org/
35 #gw for the pixbuf plugin
36 BuildRequires: gtk+2-devel
37 BuildRequires: glib2-devel >= %_glib2
38 BuildRequires: liborc-devel >= 0.4.5
39 BuildRequires: libgstreamer-plugins-base-devel >= %version
40 BuildRequires: libmesaglu-devel
41 BuildRequires: libmad-devel
42 BuildRequires: libid3tag-devel
43 BuildRequires: libdvdread-devel
44
45 %ifnarch %mips %arm
46 BuildRequires: valgrind
47 %endif
48
49 BuildRequires: libcheck-devel
50 Provides: %{bname}-audiosrc
51 Provides: %{bname}-audiosink
52
53 %description
54 GStreamer is a streaming-media framework, based on graphs of filters which
55 operate on media data. Applications using this library can do anything
56 from real-time sound processing to playing videos, and just about anything
57 else media-related. Its plugin-based architecture means that new data
58 types or processing capabilities can be added simply by installing new
59 plug-ins.
60
61 This package contains a set of plug-ins that have good quality and
62 correct functionality, but distributing them might pose problems. The
63 license on either the plug-ins or the supporting libraries might not
64 be how the GStreamer authors like. The code might be widely known to
65 present patent problems.
66
67 %if %build_plf
68 This package is in PLF as it violates some patents.
69 %endif
70
71 %prep
72 %setup -q -n gst-plugins-ugly-%{version}
73 %apply_patches
74 autoconf
75
76 %build
77 %configure2_5x --disable-dependency-tracking \
78 %if %build_plf
79 --with-package-name='PLF %name package' \
80 --with-package-origin='http://plf.zarb.org/' \
81 %else
82 --with-package-name='Mageia %name package' \
83 --with-package-origin='http://www.mageia.org/' \
84 %endif
85 %if ! %build_lame
86 --disable-lame \
87 %endif
88 %if %build_experimental
89 --enable-experimental
90 %endif
91
92 %make
93
94 %check
95 cd tests/check
96 make check
97
98 %install
99 rm -rf %{buildroot}
100 GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1 %makeinstall_std
101
102 %find_lang gst-plugins-ugly-%{majorminor}
103 # Clean out files that should not be part of the rpm.
104 # This is the recommended way of dealing with it for RH8
105 rm -f %{buildroot}%{_libdir}/gstreamer-%{majorminor}/*.la
106 rm -f %{buildroot}%{_libdir}/gstreamer-%{majorminor}/*.a
107 rm -f %{buildroot}%{_libdir}/*.a
108 rm -f %{buildroot}%{_libdir}/*.la
109
110 %clean
111 rm -rf %{buildroot}
112
113 %files -f gst-plugins-ugly-%majorminor.lang
114 %defattr(-, root, root)
115 %doc AUTHORS COPYING README NEWS
116 %{_libdir}/gstreamer-%majorminor/libgstasf.so
117 %{_libdir}/gstreamer-%majorminor/libgstdvdlpcmdec.so
118 %{_libdir}/gstreamer-%majorminor/libgstdvdread.so
119 %{_libdir}/gstreamer-%majorminor/libgstdvdsub.so
120 %{_libdir}/gstreamer-%majorminor/libgstiec958.so
121 %{_libdir}/gstreamer-%majorminor/libgstmad.so
122 %{_libdir}/gstreamer-%majorminor/libgstmpegaudioparse.so
123 %{_libdir}/gstreamer-%majorminor/libgstmpegstream.so
124 %{_libdir}/gstreamer-%majorminor/libgstrmdemux.so
125 %if %build_experimental
126 %{_libdir}/gstreamer-%majorminor/libgstsynaesthesia.so
127 %endif
128
129 %if %build_lame
130 ### LAME ###
131 %package -n %{bname}-lame
132 Summary: GStreamer plug-in for encoding mp3 songs using lame
133 Group: Sound
134 Requires: %{bname}-plugins >= %{version}-%{release}
135 BuildRequires: liblame-devel >= 3.89
136
137 %description -n %{bname}-lame
138 Plug-in for encoding mp3 with lame under GStreamer.
139
140 This package is in PLF as it violates some patents.
141 %files -n %{bname}-lame
142 %defattr(-, root, root)
143 %{_libdir}/gstreamer-%{majorminor}/libgstlame.so
144 %endif
145
146 %if %build_x264
147 %package -n %{bname}-x264
148 Summary: GStreamer plug-in for H264/AVC video encoding
149 Group: Video
150 BuildRequires: libx264-devel
151
152 %description -n %{bname}-x264
153 Plug-in for encoding H264/AVC video.
154
155 This package is in PLF as it violates some patents.
156 %files -n %{bname}-x264
157 %defattr(-, root, root)
158 %{_libdir}/gstreamer-%{majorminor}/libgstx264.so
159 %{_datadir}/gstreamer-%{majorminor}/presets/GstX264Enc.prs
160 %endif
161
162 %if %build_amrnb
163 %package -n %{bname}-amrnb
164 Summary: GStreamer plug-in for AMR-NB support
165 Group: Sound
166 Requires: %{bname}-plugins >= %{version}-%{release}
167 BuildRequires: opencore-amr-devel
168
169 %description -n %{bname}-amrnb
170 Plug-in for decoding AMR-NB under GStreamer.
171
172 This package is in PLF as it violates some patents.
173
174 %files -n %{bname}-amrnb
175 %defattr(-, root, root)
176 %{_libdir}/gstreamer-%{majorminor}/libgstamrnb.so
177 %{_datadir}/gstreamer-%{majorminor}/presets/GstAmrnbEnc.prs
178 %endif
179
180 %if %build_amrwbdec
181 %package -n %{bname}-amrwbdec
182 Summary: GStreamer plug-in for AMR-WB decoding support
183 Group: Sound
184 Requires: %{bname}-plugins >= %{version}-%{release}
185 BuildRequires: opencore-amr-devel
186
187 %description -n %{bname}-amrwbdec
188 Plug-in for decoding AMR-Wb under GStreamer.
189
190 This package is in PLF as it violates some patents.
191
192 %files -n %{bname}-amrwbdec
193 %defattr(-, root, root)
194 %{_libdir}/gstreamer-%{majorminor}/libgstamrwbdec.so
195 %endif
196
197 ### SIDPLAY ###
198 %package -n %{bname}-sid
199 Summary: GStreamer Sid C64 music plugin
200 Group: Sound
201 Requires: %{bname}-plugins >= %{version}-%{release}
202 BuildRequires: sidplay-devel => 1.36.0
203
204 %description -n %{bname}-sid
205 Plugin for playback of C64 SID format music files
206
207 %files -n %{bname}-sid
208 %defattr(-, root, root)
209 %{_libdir}/gstreamer-%{majorminor}/libgstsid.so
210
211 ### A52DEC ###
212 %package -n %{bname}-a52dec
213 Summary: GStreamer VOB decoder plugin
214 Group: Sound
215 Requires: %{bname}-plugins >= %{version}-%{release}
216 BuildRequires: a52dec-devel >= 0.7.3
217
218 %description -n %{bname}-a52dec
219 Plugin for decoding of VOB files.
220
221 %files -n %{bname}-a52dec
222 %defattr(-, root, root)
223 %{_libdir}/gstreamer-%{majorminor}/libgsta52dec.so
224
225 %package -n %{bname}-mpeg
226 Summary: GStreamer plug-ins for MPEG video playback and encoding
227 Group: Video
228 Requires: %{bname}-plugins >= %{version}-%{release}
229 BuildRequires: libmpeg2dec-devel => 0.3.1
230
231 %description -n %{bname}-mpeg
232 Plug-ins for playing and encoding MPEG video.
233
234 %files -n %{bname}-mpeg
235 %defattr(-, root, root)
236 %{_libdir}/gstreamer-%{majorminor}/libgstmpeg2dec.so
237
238 %package -n %{bname}-cdio
239 Summary: GStreamer plug-in for audio CD playback
240 Group: Sound
241 Requires: %{bname}-plugins >= %{version}-%{release}
242 BuildRequires: libcdio-devel
243 Conflicts: %{bname}-plugins-good < 0.10.10
244
245 %description -n %{bname}-cdio
246 Plug-in for audio CD playback.
247
248 %files -n %{bname}-cdio
249 %defattr(-, root, root)
250 %{_libdir}/gstreamer-%{majorminor}/libgstcdio.so
251
252 %package -n %{bname}-twolame
253 Summary: GStreamer plug-in for MP2 encoding support
254 Group: Sound
255 Requires: %{bname}-plugins >= %{version}-%{release}
256 BuildRequires: libtwolame-devel
257
258 %description -n %{bname}-twolame
259 Plug-in for encoding MP2 under GStreamer.
260
261 %files -n %{bname}-twolame
262 %defattr(-, root, root)
263 %{_libdir}/gstreamer-%{majorminor}/libgsttwolame.so

  ViewVC Help
Powered by ViewVC 1.1.30