/[packages]/cauldron/gstreamer1.0-plugins-ugly/current/SPECS/gstreamer1.0-plugins-ugly.spec
ViewVC logotype

Contents of /cauldron/gstreamer1.0-plugins-ugly/current/SPECS/gstreamer1.0-plugins-ugly.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 303338 - (show annotations) (download)
Mon Oct 8 01:49:36 2012 UTC (11 years, 6 months ago) by fwang
File size: 6901 byte(s)
new version 1.0.1
1 %define version 1.0.1
2 %define release 1
3
4 %define _glib2 2.2
5 %define major 1.0
6 %define majorminor 1.0
7 %define bname gstreamer1.0
8 %define name %{bname}-plugins-ugly
9
10 %define build_plf 0
11
12 %if "%{?distro_section}" == "tainted"
13 %define build_plf 1
14 %endif
15
16 %define build_experimental 0
17 %{?_with_experimental: %{expand: %%global build_experimental 1}}
18 %define build_lame 0
19 %define build_amrnb 0
20 %define build_amrwbdec 0
21 %define build_x264 0
22
23 %if %build_plf
24 %define build_lame 1
25 %define build_x264 1
26 %define build_amrnb 1
27 %define build_amrwbdec 1
28 %endif
29
30 Summary: GStreamer Streaming-media framework plug-ins
31 Name: %{name}
32 Version: %{version}
33 Release: %mkrel %{release}
34 License: LGPLv2+
35 Group: Sound/Utilities
36 Source: http://gstreamer.freedesktop.org/src/gst-plugins-ugly/gst-plugins-ugly-%{version}.tar.xz
37 Patch0: gstreamer-plugins-ugly-0.10.17-amr-linking.patch
38 URL: http://gstreamer.freedesktop.org/
39 #gw for the pixbuf plugin
40 BuildRequires: gtk+2-devel
41 BuildRequires: glib2-devel >= %_glib2
42 BuildRequires: liborc-devel >= 0.4.5
43 BuildRequires: gstreamer1.0-plugins-base-devel >= %{version}
44 BuildRequires: libmesaglu-devel
45 BuildRequires: libmad-devel
46 BuildRequires: libid3tag-devel
47 BuildRequires: libdvdread-devel
48
49 %ifnarch %mips %arm
50 BuildRequires: valgrind-devel
51 %endif
52
53 BuildRequires: libcheck-devel
54 Provides: %{bname}-audiosrc
55 Provides: %{bname}-audiosink
56
57 %description
58 GStreamer is a streaming-media framework, based on graphs of filters which
59 operate on media data. Applications using this library can do anything
60 from real-time sound processing to playing videos, and just about anything
61 else media-related. Its plugin-based architecture means that new data
62 types or processing capabilities can be added simply by installing new
63 plug-ins.
64
65 This package contains a set of plug-ins that have good quality and
66 correct functionality, but distributing them might pose problems. The
67 license on either the plug-ins or the supporting libraries might not
68 be how the GStreamer authors like. The code might be widely known to
69 present patent problems.
70
71 %if %build_plf
72 This package is in the 'tainted' section as it violates some patents.
73 %endif
74
75 %prep
76 %setup -q -n gst-plugins-ugly-%{version}
77
78 %build
79 %configure2_5x --disable-dependency-tracking --disable-static \
80 --with-package-name='%{distribution} %name package' \
81 --with-package-origin='http://www.mageia.org/' \
82 %if ! %build_lame
83 --disable-lame \
84 %endif
85 %if %build_experimental
86 --enable-experimental
87 %endif
88
89 %make
90
91 %check
92 cd tests/check
93 make check
94
95 %install
96 GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1 %makeinstall_std
97
98 %find_lang gst-plugins-ugly-%{majorminor}
99
100 # Clean out files that should not be part of the rpm.
101 # This is the recommended way of dealing with it for RH8
102 find %{buildroot} -name '*.la' -delete
103
104 %files -f gst-plugins-ugly-%{majorminor}.lang
105 %doc AUTHORS COPYING README NEWS
106 %{_libdir}/gstreamer-%{majorminor}/libgstasf.so
107 %{_libdir}/gstreamer-%{majorminor}/libgstdvdlpcmdec.so
108 %{_libdir}/gstreamer-%{majorminor}/libgstdvdread.so
109 %{_libdir}/gstreamer-%{majorminor}/libgstdvdsub.so
110 %{_libdir}/gstreamer-%{majorminor}/libgstmad.so
111 %{_libdir}/gstreamer-%{majorminor}/libgstrmdemux.so
112 %if %build_experimental
113 %{_libdir}/gstreamer-%{majorminor}/libgstsynaesthesia.so
114 %endif
115 %{_libdir}/gstreamer-%{majorminor}/libgstxingmux.so
116
117 %if %build_lame
118 ### LAME ###
119 %package -n %{bname}-lame
120 Summary: GStreamer plug-in for encoding mp3 songs using lame
121 Group: Sound/Utilities
122 Requires: %{bname}-plugins >= %{version}-%{release}
123 BuildRequires: liblame-devel >= 3.89
124
125 %description -n %{bname}-lame
126 Plug-in for encoding mp3 with lame under GStreamer.
127
128 This package is in the 'tainted' section as it violates some patents.
129
130 %files -n %{bname}-lame
131 %{_libdir}/gstreamer-%{majorminor}/libgstlame.so
132 %endif
133
134 %if %build_x264
135 %package -n %{bname}-x264
136 Summary: GStreamer plug-in for H264/AVC video encoding
137 Group: Video/Utilities
138 BuildRequires: libx264-devel
139
140 %description -n %{bname}-x264
141 Plug-in for encoding H264/AVC video.
142
143 This package is in the 'tainted' section as it violates some patents.
144 %files -n %{bname}-x264
145 %{_libdir}/gstreamer-%{majorminor}/libgstx264.so
146 %{_datadir}/gstreamer-%{majorminor}/presets/GstX264Enc.prs
147 %endif
148
149 %if %build_amrnb
150 %package -n %{bname}-amrnb
151 Summary: GStreamer plug-in for AMR-NB support
152 Group: Sound/Utilities
153 Requires: %{bname}-plugins >= %{version}-%{release}
154 BuildRequires: opencore-amr-devel
155
156 %description -n %{bname}-amrnb
157 Plug-in for decoding AMR-NB under GStreamer.
158
159 This package is in the 'tainted' section as it violates some patents.
160
161 %files -n %{bname}-amrnb
162 %{_libdir}/gstreamer-%{majorminor}/libgstamrnb.so
163 %{_datadir}/gstreamer-%{majorminor}/presets/GstAmrnbEnc.prs
164 %endif
165
166 %if %build_amrwbdec
167 %package -n %{bname}-amrwbdec
168 Summary: GStreamer plug-in for AMR-WB decoding support
169 Group: Sound/Utilities
170 Requires: %{bname}-plugins >= %{version}-%{release}
171 BuildRequires: opencore-amr-devel
172
173 %description -n %{bname}-amrwbdec
174 Plug-in for decoding AMR-Wb under GStreamer.
175
176 This package is in the 'tainted' section as it violates some patents.
177
178 %files -n %{bname}-amrwbdec
179 %{_libdir}/gstreamer-%{majorminor}/libgstamrwbdec.so
180 %endif
181
182 ### SIDPLAY ###
183 %package -n %{bname}-sid
184 Summary: GStreamer Sid C64 music plugin
185 Group: Sound/Utilities
186 Requires: %{bname}-plugins >= %{version}-%{release}
187 BuildRequires: sidplay-devel => 1.36.0
188
189 %description -n %{bname}-sid
190 Plugin for playback of C64 SID format music files
191
192 %files -n %{bname}-sid
193 %{_libdir}/gstreamer-%{majorminor}/libgstsid.so
194
195 ### A52DEC ###
196 %package -n %{bname}-a52dec
197 Summary: GStreamer VOB decoder plugin
198 Group: Sound/Utilities
199 Requires: %{bname}-plugins >= %{version}-%{release}
200 BuildRequires: a52dec-devel >= 0.7.3
201
202 %description -n %{bname}-a52dec
203 Plugin for decoding of VOB files.
204
205 %files -n %{bname}-a52dec
206 %{_libdir}/gstreamer-%{majorminor}/libgsta52dec.so
207
208 %package -n %{bname}-mpeg
209 Summary: GStreamer plug-ins for MPEG video playback and encoding
210 Group: Video/Utilities
211 Requires: %{bname}-plugins >= %{version}-%{release}
212 BuildRequires: libmpeg2dec-devel => 0.3.1
213
214 %description -n %{bname}-mpeg
215 Plug-ins for playing and encoding MPEG video.
216
217 %files -n %{bname}-mpeg
218 %{_libdir}/gstreamer-%{majorminor}/libgstmpeg2dec.so
219
220 %package -n %{bname}-cdio
221 Summary: GStreamer plug-in for audio CD playback
222 Group: Sound/Utilities
223 Requires: %{bname}-plugins >= %{version}-%{release}
224 BuildRequires: libcdio-devel
225 Conflicts: %{bname}-plugins-good < 0.10.10
226
227 %description -n %{bname}-cdio
228 Plug-in for audio CD playback.
229
230 %files -n %{bname}-cdio
231 %{_libdir}/gstreamer-%{majorminor}/libgstcdio.so
232
233 %package -n %{bname}-twolame
234 Summary: GStreamer plug-in for MP2 encoding support
235 Group: Sound/Utilities
236 Requires: %{bname}-plugins >= %{version}-%{release}
237 BuildRequires: libtwolame-devel
238
239 %description -n %{bname}-twolame
240 Plug-in for encoding MP2 under GStreamer.
241
242 %files -n %{bname}-twolame
243 %{_libdir}/gstreamer-%{majorminor}/libgsttwolame.so

  ViewVC Help
Powered by ViewVC 1.1.30