/[packages]/cauldron/gtk+3.0/current/SPECS/gtk+3.0.spec
ViewVC logotype

Annotation of /cauldron/gtk+3.0/current/SPECS/gtk+3.0.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 102517 - (hide annotations) (download)
Thu Jun 9 17:23:40 2011 UTC (12 years, 10 months ago) by dmorgan
File size: 10180 byte(s)
Do not package libgailutil-3.la
1 saispo 93254 # enable_gtkdoc: Toggle if gtk-doc files should be rebuilt.
2     # 0 = no
3     # 1 = yes
4     %define enable_gtkdoc 0
5    
6     # enable_bootstrap: Toggle if bootstrapping package
7     # 0 = no
8     # 1 = yes
9 dmorgan 101505 %define enable_bootstrap 1
10 saispo 93254
11     # enable_tests: Run test suite in build
12     # 0 = no
13     # 1 = yes
14     %define enable_tests 0
15    
16     %{?_without_gtkdoc: %{expand: %%define enable_gtkdoc 0}}
17     %{?_without_bootstrap: %{expand: %%define enable_bootstrap 0}}
18     %{?_without_tests: %{expand: %%define enable_tests 0}}
19    
20     %{?_with_gtkdoc: %{expand: %%define enable_gtkdoc 1}}
21     %{?_with_bootstrap: %{expand: %%define enable_bootstrap 1}}
22     %{?_with_tests: %{expand: %%define enable_tests 1}}
23    
24    
25     # required version of various libraries
26     %define req_glib_version 2.28.0
27     %define req_pango_version 1.24.0
28     %define req_atk_version 1.30
29     %define req_cairo_version 1.10.0
30     %define req_gdk_pixbuf_version 2.22.0
31    
32     %define pkgname gtk+
33     %define api 3
34     %define api_version 3.0
35     %define binary_version 3.0.0
36     %define lib_major 0
37     %define libname %mklibname %{pkgname} %{api} %{lib_major}
38     %define develname %mklibname -d %pkgname %api_version
39    
40     %define gail_major 0
41     %define gail_libname %mklibname gail %{api} %gail_major
42     %define gaildevelname %mklibname -d gail %api_version
43    
44     Summary: The GIMP ToolKit (GTK+), a library for creating GUIs
45     Name: %{pkgname}%{api_version}
46 dmorgan 101505 Version: 3.0.11
47 dmorgan 102517 Release: %mkrel 4
48 saispo 93254 License: LGPLv2+
49     Group: System/Libraries
50 dmorgan 101505 Source0: http://ftp.gnome.org/pub/GNOME/sources/%pkgname/%{pkgname}-%{version}.tar.xz
51     Source1: im-cedilla.conf
52     %if !%{enable_bootstrap}
53     # use oxygen gtk3 theme by default if available
54     Patch12: gtk+-defaulttheme.patch
55     %endif
56 saispo 93254 URL: http://www.gtk.org
57     Requires: common-licenses
58     BuildRequires: gettext-devel
59     BuildRequires: libglib2-devel >= %{req_glib_version}
60     BuildRequires: libatk1.0-devel >= %{req_atk_version}
61     BuildRequires: cairo-devel >= %{req_cairo_version}
62     BuildRequires: pango-devel >= %{req_pango_version}
63     BuildRequires: libgdk_pixbuf2.0-devel >= %req_gdk_pixbuf_version
64     BuildRequires: gobject-introspection-devel >= 0.10.1
65     BuildRequires: cups-devel
66     BuildRequires: libx11-devel
67     BuildRequires: libxrandr-devel
68     BuildRequires: libxrender-devel
69     BuildRequires: libxcursor-devel
70     BuildRequires: libxfixes-devel
71     BuildRequires: libxinerama-devel
72     BuildRequires: libxcomposite-devel
73     BuildRequires: libxdamage-devel
74     BuildRequires: libxi-devel
75     #gw needed for gtk-update-icon-cache in gtk+3.0 3.0.9
76     BuildRequires: gtk+2.0
77     %if %enable_tests
78     BuildRequires: x11-server-xvfb
79     %endif
80     %if %enable_gtkdoc
81     BuildRequires: gtk-doc >= 0.9
82     BuildRequires: sgml-tools
83     BuildRequires: texinfo
84     %endif
85     # gw tests will fail without this
86     BuildRequires: fonts-ttf-dejavu
87     %if !%{enable_bootstrap}
88     Suggests: xdg-user-dirs-gtk
89 dmorgan 101505 Suggests: oxygen-gtk3
90 saispo 93254 %endif
91     Requires: %{libname} = %{version}
92     Obsoletes: gtk-engines3 < 3.0.0
93     Provides: %{pkgname}%{api} = %{version}-%{release}
94    
95     %description
96     The gtk+ package contains the GIMP ToolKit (GTK+), a library for creating
97     graphical user interfaces for the X Window System. GTK+ was originally
98     written for the GIMP (GNU Image Manipulation Program) image processing
99     program, but is now used by several other programs as well.
100    
101     If you are planning on using the GIMP or another program that uses GTK+,
102     you'll need to have the gtk+ package installed.
103    
104 dmorgan 101505 %post
105     gtk-query-immodules-3.0-%{__isa_bits} --update-cache
106     glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
107    
108     %files -f gtk30.lang
109     %defattr(-, root, root)
110     %doc README
111     %_mandir/man1/gtk-query-immodules-%{api_version}.1*
112     %{_datadir}/themes
113     %{_datadir}/glib-2.0/schemas/org.gtk.Settings.FileChooser.gschema.xml
114     %dir %{_sysconfdir}/gtk-%{api_version}
115     %config(noreplace) %{_sysconfdir}/gtk-%{api_version}/im-multipress.conf
116     %{_sysconfdir}/X11/xinit/xinput.d/im-cedilla.conf
117    
118     #--------------------------------------------------------------------
119    
120 saispo 93254 %package -n %{libname}
121     Summary: %{summary}
122     Group: %{group}
123     Provides: lib%{pkgname}%{api} = %{version}-%{release}
124     Provides: lib%{name} = %{version}-%{release}
125     Obsoletes: %{_lib}gtk+3.0_0 < 3.0.0
126     Obsoletes: %{_lib}gtk+-x11-3.0_0 < 3.0.0
127     Obsoletes: %{_lib}gtk-engines3 < 3.0.0
128     Requires: libglib2.0 >= %{req_glib_version}
129     Requires: libpango1.0 >= %{req_pango_version}
130     Requires: libatk1.0 >= %{req_atk_version}
131    
132     %description -n %{libname}
133     This package contains the library needed to run programs dynamically
134     linked with gtk+.
135    
136 dmorgan 101505 %post -n %{libname}
137     if [ "$1" = "2" ]; then
138     if [ -f %{_sysconfdir}/gtk-%{api_version}/gtk.immodules ]; then
139     rm -f %{_sysconfdir}/gtk-%{api_version}/gtk.immodules
140     fi
141     fi
142     gtk-query-immodules-3.0-%{__isa_bits} --update-cache
143    
144     %files -n %{libname}
145     %defattr(-, root, root)
146     %doc README
147     %{_bindir}/gtk-query-immodules-%{api_version}-*
148     %ghost %verify (not md5 mtime size) %_libdir/gtk-%{api_version}/3.0.0/immodules.cache
149     %dir %{_libdir}/gtk-%{api_version}
150     %dir %{_libdir}/gtk-%{api_version}/modules
151     %dir %{_libdir}/gtk-%{api_version}/%{binary_version}
152     %dir %{_libdir}/gtk-%{api_version}/%{binary_version}/immodules
153     %{_libdir}/gtk-%{api_version}/%{binary_version}/immodules/*.so
154     %dir %{_libdir}/gtk-%{api_version}/%{binary_version}/printbackends
155     %{_libdir}/gtk-%{api_version}/%{binary_version}/printbackends/*.so
156     %{_libdir}/libgtk-3.so.%{lib_major}
157     %{_libdir}/libgtk-3.so.%{lib_major}.*
158     %{_libdir}/libgdk-3.so.%{lib_major}
159     %{_libdir}/libgdk-3.so.%{lib_major}.*
160     %_libdir/girepository-1.0/Gdk-%{api_version}.typelib
161     %_libdir/girepository-1.0/GdkX11-%{api_version}.typelib
162     %_libdir/girepository-1.0/Gtk-%{api_version}.typelib
163    
164     #--------------------------------------------------------------------
165    
166 saispo 93254 %package -n %{develname}
167     Summary: Development files for GTK+ (GIMP ToolKit) applications
168     Group: Development/GNOME and GTK+
169     Provides: %{pkgname}%{api}-devel = %{version}-%{release}
170     Provides: lib%{pkgname}%{api}-devel = %{version}-%{release}
171     Provides: lib%{pkgname}%{api_version}-devel = %{version}-%{release}
172     Provides: lib%{pkgname}-x11-%{api_version}-devel = %{version}-%{release}
173     Provides: %{name}-devel = %{version}-%{release}
174     Requires: %{libname} = %{version}
175     Requires: libgdk_pixbuf2.0-devel >= %req_gdk_pixbuf_version
176     Requires: libatk1.0-devel >= %{req_atk_version}
177     Requires: libpango1.0-devel >= %{req_pango_version}
178    
179     %description -n %{develname}
180     The libgtk+-devel package contains the static libraries and header files
181     needed for developing GTK+ (GIMP ToolKit) applications. The libgtk+-devel
182     package contains GDK (the General Drawing Kit, which simplifies the interface
183     for writing GTK+ widgets and using GTK+ widgets in applications), and GTK+
184     (the widget set).
185    
186 dmorgan 101505 %files -n %{develname}
187     %defattr(-, root, root)
188     %doc docs/*.txt AUTHORS ChangeLog NEWS* README*
189     %doc %{_datadir}/gtk-doc/html/gdk3
190     %doc %{_datadir}/gtk-doc/html/gtk3
191     %{_bindir}/gtk3-demo
192     %{_datadir}/aclocal/*
193     %{_datadir}/gtk-%{api_version}
194     %{_includedir}/gtk-%{api_version}
195     %{_libdir}/libgtk-%{api}.so
196     %{_libdir}/libgtk-%{api}.la
197     %{_libdir}/libgdk-%{api}.so
198     %{_libdir}/libgdk-%{api}.la
199     %{_libdir}/pkgconfig/gdk-*%{api_version}.pc
200     %{_libdir}/pkgconfig/gtk+-*%{api_version}.pc
201     %_datadir/gir-1.0/Gdk-%{api_version}.gir
202     %_datadir/gir-1.0/GdkX11-%{api_version}.gir
203     %_datadir/gir-1.0/Gtk-%{api_version}.gir
204    
205     #--------------------------------------------------------------------
206    
207 saispo 93254 %package -n %{gail_libname}
208     Summary: GNOME Accessibility Implementation Library
209     Group: System/Libraries
210     Provides: libgail = %{version}-%{release}
211     Obsoletes: %{_lib}gail3.0_0 < 3.0.0
212    
213     %description -n %{gail_libname}
214     Gail is the GNOME Accessibility Implementation Library
215    
216 dmorgan 101505 %files -n %gail_libname
217     %defattr(-,root,root)
218     %{_libdir}/libgailutil-%{api}.so.%{gail_major}*
219     %{_libdir}/gtk-%{api_version}/modules/libferret.so
220     %{_libdir}/gtk-%{api_version}/modules/libgail.so
221    
222     #--------------------------------------------------------------------
223    
224 saispo 93254 %package -n %gaildevelname
225     Summary: Static libraries, include files for GAIL
226     Group: Development/GNOME and GTK+
227     Provides: libgail-%{api_version}-devel = %{version}-%{release}
228     Requires: %{gail_libname} = %{version}
229    
230     %description -n %gaildevelname
231     Gail is the GNOME Accessibility Implementation Library
232    
233 dmorgan 101505 %files -n %gaildevelname
234     %defattr(-,root,root)
235     %{_datadir}/gtk-doc/html/gail-libgail-util3
236     %{_libdir}/libgailutil-%{api}.so
237     %{_includedir}/gail-%{api_version}
238     %{_libdir}/pkgconfig/gail-%{api_version}.pc
239    
240     #--------------------------------------------------------------------
241    
242 saispo 93254 %prep
243     %setup -qn %{pkgname}-%{version}
244     %apply_patches
245    
246     %build
247    
248 dmorgan 101505 (if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; CONFIGFLAGS=--enable-gtk-doc; fi;
249     %configure $CONFIGFLAGS \
250     --enable-gtk2-dependency \
251     --enable-xkb \
252     --enable-xinerama \
253     --enable-xinput \
254     --enable-xrandr \
255     --enable-xfixes \
256     --enable-xcomposite \
257     --enable-xdamage \
258     --enable-x11-backend \
259     )
260 saispo 93254
261 dmorgan 101505 # fight unused direct deps
262     sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
263 saispo 93254
264     %make
265    
266     %check
267     %if %enable_tests
268     XDISPLAY=$(i=1; while [ -f /tmp/.X$i-lock ]; do i=$(($i+1)); done; echo $i)
269     %{_bindir}/Xvfb :$XDISPLAY &
270     export DISPLAY=:$XDISPLAY
271     make check
272     kill $(cat /tmp/.X$XDISPLAY-lock) ||:
273     %endif
274    
275     %install
276     rm -rf $RPM_BUILD_ROOT
277    
278     %makeinstall_std RUN_QUERY_IMMODULES_TEST=false RUN_QUERY_LOADER_TEST=false
279    
280     touch $RPM_BUILD_ROOT%_libdir/gtk-%{api_version}/%{binary_version}/immodules.cache
281     mkdir -p $RPM_BUILD_ROOT%{_libdir}/gtk-%{api_version}/modules
282    
283 dmorgan 101505 (cd $RPM_BUILD_ROOT%{_bindir}
284     mv gtk-query-immodules-3.0 gtk-query-immodules-3.0-%{__isa_bits}
285     )
286 saispo 93254
287 dmorgan 101505 # Input method frameworks want this
288     install -D %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/X11/xinit/xinput.d/im-cedilla.conf
289 saispo 93254 %{find_lang} gtk30 gtk30 gtk30-properties
290    
291     #remove not packaged files
292     rm -f $RPM_BUILD_ROOT%{_libdir}/gtk-%{api_version}/%{binary_version}/immodules/*.la \
293     $RPM_BUILD_ROOT%{_libdir}/gtk-%{api_version}/%{binary_version}/loaders/*.la \
294     $RPM_BUILD_ROOT%{_libdir}/gtk-%{api_version}/%{binary_version}/engines/*.la \
295     $RPM_BUILD_ROOT%{_libdir}/gtk-%{api_version}/%{binary_version}/printbackends/*.la \
296     $RPM_BUILD_ROOT%{_libdir}/gtk-%{api_version}/modules/*.la \
297     $RPM_BUILD_ROOT%_mandir/man1/gtk-update-icon-cache.1*
298 dmorgan 102517 rm -f $RPM_BUILD_ROOT%{_libdir}/libgailutil-%{api}.la
299 saispo 93254
300     %clean
301     rm -rf $RPM_BUILD_ROOT
302    

  ViewVC Help
Powered by ViewVC 1.1.30