1 |
blino |
19172 |
%define name gvfs |
2 |
|
|
%define version 1.6.6 |
3 |
blino |
19174 |
%define release %mkrel 2 |
4 |
blino |
19172 |
|
5 |
|
|
%define major 0 |
6 |
|
|
%define libname %mklibname %name %major |
7 |
|
|
%define develname %mklibname -d %name |
8 |
|
|
|
9 |
|
|
%define enable_gphoto2 1 |
10 |
|
|
%define enable_iphone 1 |
11 |
|
|
|
12 |
|
|
%define enable_gdu 1 |
13 |
|
|
|
14 |
|
|
%define giolibname %mklibname gio2.0_ 0 |
15 |
|
|
|
16 |
|
|
Summary: Glib VFS library |
17 |
|
|
Name: %{name} |
18 |
|
|
Version: %{version} |
19 |
|
|
Release: %{release} |
20 |
|
|
Source0: ftp://ftp.gnome.org/pub/GNOME/sources/%name/%{name}-%{version}.tar.bz2 |
21 |
|
|
Source1: bash-completion |
22 |
|
|
#gw from Ubuntu, fix music player detection |
23 |
|
|
# https://bugs.freedesktop.org/show_bug.cgi?id=24500 |
24 |
|
|
Patch0: gvfs-music-player-mimetype.patch |
25 |
|
|
License: LGPLv2+ |
26 |
|
|
Group: System/Libraries |
27 |
|
|
Url: http://www.gnome.org/ |
28 |
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot |
29 |
|
|
BuildRequires: libgudev-devel |
30 |
|
|
BuildRequires: libcdio-devel |
31 |
|
|
BuildRequires: fuse-devel |
32 |
|
|
BuildRequires: libsmbclient-devel |
33 |
|
|
BuildRequires: libsoup-devel >= 2.23.91 |
34 |
|
|
BuildRequires: glib2-devel >= 2.23.4 |
35 |
|
|
BuildRequires: libarchive-devel |
36 |
|
|
BuildRequires: libGConf2-devel |
37 |
|
|
BuildRequires: intltool |
38 |
|
|
%if %{enable_gphoto2} |
39 |
|
|
BuildRequires: gphoto2-devel |
40 |
|
|
%endif |
41 |
|
|
%if %{enable_iphone} |
42 |
|
|
BuildRequires: libimobiledevice-devel >= 1.0.0 |
43 |
|
|
%endif |
44 |
|
|
BuildRequires: libgnome-keyring-devel |
45 |
|
|
BuildRequires: avahi-glib-devel |
46 |
|
|
BuildRequires: avahi-client-devel |
47 |
|
|
BuildRequires: bluez-devel |
48 |
|
|
BuildRequires: dbus-glib-devel |
49 |
|
|
BuildRequires: expat-devel |
50 |
|
|
BuildRequires: gtk-doc |
51 |
|
|
%if %{enable_gdu} |
52 |
|
|
BuildRequires: libgdu-devel >= 2.29.0 |
53 |
|
|
%else |
54 |
|
|
BuildRequires: libhal-devel |
55 |
|
|
Suggests: gnome-mount |
56 |
|
|
%endif |
57 |
|
|
#gw the dbus service depends on the daemon in the library package |
58 |
|
|
Requires: %libname = %version |
59 |
|
|
Suggests: %name-fuse |
60 |
|
|
Suggests: %name-smb |
61 |
|
|
Suggests: %name-archive |
62 |
|
|
#Suggests: %name-obexftp |
63 |
|
|
%if %{enable_gphoto2} |
64 |
|
|
Suggests: %name-gphoto2 |
65 |
|
|
%endif |
66 |
|
|
|
67 |
|
|
%description |
68 |
|
|
This is a Virtual File System library based on gio and Glib. |
69 |
|
|
|
70 |
|
|
%package -n %{libname} |
71 |
|
|
Group: System/Libraries |
72 |
|
|
Summary: Glib VFS library |
73 |
|
|
Requires: %name >= %version |
74 |
blino |
19174 |
Requires(post): %giolibname |
75 |
|
|
Requires(postun): %giolibname |
76 |
blino |
19172 |
|
77 |
|
|
%description -n %{libname} |
78 |
|
|
This is a Virtual File System library based on gio and Glib. |
79 |
|
|
|
80 |
|
|
%package -n %develname |
81 |
|
|
Group: Development/C |
82 |
|
|
Summary: Glib VFS Library - development files |
83 |
|
|
Requires: %libname = %version |
84 |
|
|
Provides: libgvfs-devel = %version-%release |
85 |
|
|
|
86 |
|
|
%description -n %develname |
87 |
|
|
This is a Virtual File System library based on gio and Glib. |
88 |
|
|
|
89 |
|
|
%package fuse |
90 |
|
|
Summary: FUSE support for gvfs |
91 |
|
|
Group: System/Libraries |
92 |
|
|
Requires: %{name} = %{version}-%{release} |
93 |
|
|
Requires: fuse |
94 |
|
|
|
95 |
|
|
%description fuse |
96 |
|
|
This package provides support for applications not using gio |
97 |
|
|
to access the gvfs filesystems. |
98 |
|
|
|
99 |
|
|
|
100 |
|
|
%package smb |
101 |
|
|
Summary: Windows fileshare support for gvfs |
102 |
|
|
Group: System/Libraries |
103 |
|
|
Requires: %{name} = %{version}-%{release} |
104 |
|
|
|
105 |
|
|
%description smb |
106 |
|
|
This package provides support for reading and writing files on windows |
107 |
|
|
shares (SMB) to applications using gvfs. |
108 |
|
|
|
109 |
|
|
%package archive |
110 |
|
|
Summary: Archiving support for gvfs |
111 |
|
|
Group: System/Libraries |
112 |
|
|
Requires: %{name} = %{version}-%{release} |
113 |
|
|
|
114 |
|
|
%description archive |
115 |
|
|
This package provides support for accessing files inside Zip and Tar archives, |
116 |
|
|
as well as ISO images, to applications using gvfs. |
117 |
|
|
|
118 |
|
|
|
119 |
|
|
%package obexftp |
120 |
|
|
Summary: ObexFTP support for gvfs |
121 |
|
|
Group: System/Libraries |
122 |
|
|
Requires: %{name} = %{version}-%{release} |
123 |
|
|
Requires: obex-data-server >= 0.3.4-6 |
124 |
|
|
|
125 |
|
|
%description obexftp |
126 |
|
|
This package provides support for reading files on Bluetooth mobile phones |
127 |
|
|
and devices through ObexFTP to applications using gvfs. |
128 |
|
|
|
129 |
|
|
%package gphoto2 |
130 |
|
|
Summary: gphoto2 support for gvfs |
131 |
|
|
Group: System/Libraries |
132 |
|
|
Requires: %{name} = %{version}-%{release} |
133 |
|
|
|
134 |
|
|
%description gphoto2 |
135 |
|
|
This package provides support for reading and writing files on |
136 |
|
|
PTP based cameras (Picture Transfer Protocol) and MTP based |
137 |
|
|
media players (Media Transfer Protocol) to applications using gvfs. |
138 |
|
|
|
139 |
|
|
%package iphone |
140 |
|
|
Summary: iphone support for gvfs |
141 |
|
|
Group: System/Libraries |
142 |
|
|
Requires: %{name} = %{version}-%{release} |
143 |
|
|
|
144 |
|
|
%description iphone |
145 |
|
|
This package provides support for reading and writing files on |
146 |
|
|
the iPhone and the iPod TouchP to applications using gvfs. |
147 |
|
|
|
148 |
|
|
|
149 |
|
|
%prep |
150 |
|
|
%setup -q |
151 |
|
|
%apply_patches |
152 |
|
|
|
153 |
|
|
%build |
154 |
|
|
%configure2_5x --with-dbus-service-dir=%_datadir/dbus-1/services \ |
155 |
|
|
%if !%{enable_gdu} |
156 |
|
|
--enable-hal --disable-gdu \ |
157 |
|
|
%endif |
158 |
|
|
--enable-gconf \ |
159 |
|
|
%if %{enable_gphoto2} |
160 |
|
|
--enable-gphoto2 |
161 |
|
|
%else |
162 |
|
|
--disable-gphoto2 |
163 |
|
|
%endif |
164 |
|
|
|
165 |
|
|
%make |
166 |
|
|
|
167 |
|
|
%install |
168 |
|
|
rm -rf %{buildroot} |
169 |
|
|
%makeinstall_std |
170 |
|
|
rm -f %buildroot%_libdir/gio/modules/*.la |
171 |
|
|
|
172 |
|
|
%find_lang gvfs |
173 |
|
|
|
174 |
|
|
# upstream bash completion is installed in the wrong place, with the wrong perms |
175 |
|
|
# and redefine system variables without notice |
176 |
|
|
rm -f %buildroot%_sysconfdir/profile.d/gvfs-bash-completion.sh |
177 |
|
|
install -d -m 755 %buildroot%_sysconfdir/bash_completion.d |
178 |
|
|
install -m 644 %{SOURCE1} %buildroot%_sysconfdir/bash_completion.d/%{name} |
179 |
|
|
|
180 |
|
|
%clean |
181 |
|
|
rm -rf %{buildroot} |
182 |
|
|
|
183 |
|
|
%post -n %libname |
184 |
|
|
%if %_lib != lib |
185 |
|
|
%{_bindir}/gio-querymodules-64 %{_libdir}/gio/modules |
186 |
|
|
%else |
187 |
|
|
%{_bindir}/gio-querymodules-32 %{_libdir}/gio/modules |
188 |
|
|
%endif |
189 |
|
|
|
190 |
|
|
%postun -n %libname |
191 |
|
|
if [ "$1" = "0" ]; then |
192 |
|
|
%if %_lib != lib |
193 |
|
|
%{_bindir}/gio-querymodules-64 %{_libdir}/gio/modules |
194 |
|
|
%else |
195 |
|
|
%{_bindir}/gio-querymodules-32 %{_libdir}/gio/modules |
196 |
|
|
%endif |
197 |
|
|
fi |
198 |
|
|
|
199 |
|
|
%files -f gvfs.lang |
200 |
|
|
%defattr(-,root,root) |
201 |
|
|
%_sysconfdir/bash_completion.d/gvfs |
202 |
|
|
%_bindir/gvfs-* |
203 |
|
|
%_datadir/dbus-1/services/gvfs-daemon.service |
204 |
|
|
%_datadir/dbus-1/services/gvfs-metadata.service |
205 |
|
|
%if %{enable_gdu} |
206 |
|
|
%_datadir/dbus-1/services/org.gtk.Private.GduVolumeMonitor.service |
207 |
|
|
%else |
208 |
|
|
%_datadir/dbus-1/services/org.gtk.Private.HalVolumeMonitor.service |
209 |
|
|
%endif |
210 |
|
|
%dir %_datadir/gvfs |
211 |
|
|
%dir %_datadir/gvfs/mounts |
212 |
|
|
%dir %_datadir/gvfs/remote-volume-monitors |
213 |
|
|
%if %{enable_gdu} |
214 |
|
|
%_datadir/gvfs/remote-volume-monitors/gdu.monitor |
215 |
|
|
%else |
216 |
|
|
%_datadir/gvfs/remote-volume-monitors/hal.monitor |
217 |
|
|
%endif |
218 |
|
|
%_datadir/gvfs/mounts/sftp.mount |
219 |
|
|
%_datadir/gvfs/mounts/trash.mount |
220 |
|
|
%_datadir/gvfs/mounts/cdda.mount |
221 |
|
|
%_datadir/gvfs/mounts/computer.mount |
222 |
|
|
%_datadir/gvfs/mounts/dav.mount |
223 |
|
|
%_datadir/gvfs/mounts/dav+sd.mount |
224 |
|
|
%_datadir/gvfs/mounts/http.mount |
225 |
|
|
%_datadir/gvfs/mounts/localtest.mount |
226 |
|
|
%_datadir/gvfs/mounts/burn.mount |
227 |
|
|
%_datadir/gvfs/mounts/dns-sd.mount |
228 |
|
|
%_datadir/gvfs/mounts/network.mount |
229 |
|
|
%_datadir/gvfs/mounts/ftp.mount |
230 |
|
|
|
231 |
|
|
%files -n %libname |
232 |
|
|
%defattr(-,root,root) |
233 |
|
|
%_libdir/gio/modules/libgiogconf.so |
234 |
|
|
%_libdir/gio/modules/libgioremote-volume-monitor.so |
235 |
|
|
%_libdir/gio/modules/libgvfsdbus.so |
236 |
|
|
%if %{enable_gdu} |
237 |
|
|
%_libexecdir/gvfs-gdu-volume-monitor |
238 |
|
|
%else |
239 |
|
|
%_libexecdir/gvfs-hal-volume-monitor |
240 |
|
|
%endif |
241 |
|
|
%_libexecdir/gvfsd |
242 |
|
|
%_libexecdir/gvfsd-ftp |
243 |
|
|
%_libexecdir/gvfsd-metadata |
244 |
|
|
%_libexecdir/gvfsd-sftp |
245 |
|
|
%_libexecdir/gvfsd-trash |
246 |
|
|
%_libexecdir/gvfsd-cdda |
247 |
|
|
%_libexecdir/gvfsd-computer |
248 |
|
|
%_libexecdir/gvfsd-dav |
249 |
|
|
%_libexecdir/gvfsd-http |
250 |
|
|
%_libexecdir/gvfsd-localtest |
251 |
|
|
%_libexecdir/gvfsd-burn |
252 |
|
|
%_libexecdir/gvfsd-dnssd |
253 |
|
|
%_libexecdir/gvfsd-network |
254 |
|
|
%_libdir/libgvfscommon.so.%{major}* |
255 |
|
|
%_libdir/libgvfscommon-dnssd.so.%{major}* |
256 |
|
|
|
257 |
|
|
%files -n %develname |
258 |
|
|
%defattr(-,root,root) |
259 |
|
|
%doc NEWS ChangeLog AUTHORS TODO |
260 |
|
|
%_libdir/lib*.so |
261 |
|
|
%_libdir/lib*.la |
262 |
|
|
#%_includedir/%name/ |
263 |
|
|
%_includedir/gvfs-client |
264 |
|
|
#%_libdir/pkgconfig/%name*.pc |
265 |
|
|
#%doc %_datadir/gtk-doc/html/%name |
266 |
|
|
|
267 |
|
|
%files fuse |
268 |
|
|
%defattr(-, root, root, -) |
269 |
|
|
%{_libexecdir}/gvfs-fuse-daemon |
270 |
|
|
|
271 |
|
|
|
272 |
|
|
%files smb |
273 |
|
|
%defattr(-, root, root, -) |
274 |
|
|
%{_libexecdir}/gvfsd-smb |
275 |
|
|
%{_libexecdir}/gvfsd-smb-browse |
276 |
|
|
%{_datadir}/gvfs/mounts/smb-browse.mount |
277 |
|
|
%{_datadir}/gvfs/mounts/smb.mount |
278 |
|
|
|
279 |
|
|
|
280 |
|
|
%files archive |
281 |
|
|
%defattr(-, root, root, -) |
282 |
|
|
#%dir %{_datadir}/applications/mount-archive.desktop |
283 |
|
|
%{_libexecdir}/gvfsd-archive |
284 |
|
|
%{_datadir}/gvfs/mounts/archive.mount |
285 |
|
|
|
286 |
|
|
|
287 |
|
|
%files obexftp |
288 |
|
|
%defattr(-, root, root, -) |
289 |
|
|
%{_libexecdir}/gvfsd-obexftp |
290 |
|
|
%{_datadir}/gvfs/mounts/obexftp.mount |
291 |
|
|
|
292 |
|
|
%if %{enable_gphoto2} |
293 |
|
|
%files gphoto2 |
294 |
|
|
%defattr(-, root, root, -) |
295 |
|
|
%{_libexecdir}/gvfsd-gphoto2 |
296 |
|
|
%{_datadir}/gvfs/mounts/gphoto2.mount |
297 |
|
|
%{_libexecdir}/gvfs-gphoto2-volume-monitor |
298 |
|
|
%{_datadir}/dbus-1/services/org.gtk.Private.GPhoto2VolumeMonitor.service |
299 |
|
|
%{_datadir}/gvfs/remote-volume-monitors/gphoto2.monitor |
300 |
|
|
%endif |
301 |
|
|
|
302 |
|
|
%if %{enable_iphone} |
303 |
|
|
%files iphone |
304 |
|
|
%defattr(-, root, root, -) |
305 |
|
|
%_libexecdir/gvfs-afc-volume-monitor |
306 |
|
|
%_libexecdir/gvfsd-afc |
307 |
|
|
%_datadir/dbus-1/services/org.gtk.Private.AfcVolumeMonitor.service |
308 |
|
|
%_datadir/gvfs/mounts/afc.mount |
309 |
|
|
%_datadir/gvfs/remote-volume-monitors/afc.monitor |
310 |
|
|
%endif |
311 |
|
|
|
312 |
|
|
|