1 |
blino |
19172 |
%define name gvfs |
2 |
ahmad |
75483 |
%define version 1.7.2 |
3 |
|
|
%define release %mkrel 1 |
4 |
blino |
19172 |
|
5 |
|
|
%define major 0 |
6 |
|
|
%define libname %mklibname %name %major |
7 |
|
|
%define develname %mklibname -d %name |
8 |
|
|
|
9 |
|
|
%define enable_gphoto2 1 |
10 |
ahmad |
75483 |
%define enable_iphone 0 |
11 |
blino |
19172 |
|
12 |
|
|
%define giolibname %mklibname gio2.0_ 0 |
13 |
|
|
|
14 |
|
|
Summary: Glib VFS library |
15 |
|
|
Name: %{name} |
16 |
|
|
Version: %{version} |
17 |
|
|
Release: %{release} |
18 |
ahmad |
75483 |
Source0: ftp://ftp.gnome.org/pub/GNOME/sources/gvfs/1.7/%{name}-%{version}.tar.bz2 |
19 |
blino |
19172 |
Source1: bash-completion |
20 |
|
|
#gw from Ubuntu, fix music player detection |
21 |
|
|
# https://bugs.freedesktop.org/show_bug.cgi?id=24500 |
22 |
|
|
Patch0: gvfs-music-player-mimetype.patch |
23 |
|
|
License: LGPLv2+ |
24 |
|
|
Group: System/Libraries |
25 |
|
|
Url: http://www.gnome.org/ |
26 |
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot |
27 |
|
|
BuildRequires: libgudev-devel |
28 |
|
|
BuildRequires: libcdio-devel |
29 |
|
|
BuildRequires: fuse-devel |
30 |
|
|
BuildRequires: libsmbclient-devel |
31 |
|
|
BuildRequires: libsoup-devel >= 2.23.91 |
32 |
|
|
BuildRequires: glib2-devel >= 2.23.4 |
33 |
|
|
BuildRequires: libarchive-devel |
34 |
|
|
BuildRequires: libGConf2-devel |
35 |
|
|
BuildRequires: intltool |
36 |
|
|
%if %{enable_gphoto2} |
37 |
|
|
BuildRequires: gphoto2-devel |
38 |
|
|
%endif |
39 |
|
|
%if %{enable_iphone} |
40 |
ahmad |
75483 |
BuildRequires: libimobiledevice-devel >= 1.1.0 |
41 |
blino |
19172 |
%endif |
42 |
|
|
BuildRequires: libgnome-keyring-devel |
43 |
|
|
BuildRequires: avahi-glib-devel |
44 |
|
|
BuildRequires: avahi-client-devel |
45 |
|
|
BuildRequires: bluez-devel |
46 |
|
|
BuildRequires: dbus-glib-devel |
47 |
|
|
BuildRequires: expat-devel |
48 |
|
|
BuildRequires: gtk-doc |
49 |
|
|
BuildRequires: libgdu-devel >= 2.29.0 |
50 |
|
|
#gw the dbus service depends on the daemon in the library package |
51 |
|
|
Requires: %libname = %version |
52 |
|
|
Suggests: %name-fuse |
53 |
|
|
Suggests: %name-smb |
54 |
|
|
Suggests: %name-archive |
55 |
|
|
#Suggests: %name-obexftp |
56 |
|
|
%if %{enable_gphoto2} |
57 |
|
|
Suggests: %name-gphoto2 |
58 |
|
|
%endif |
59 |
|
|
|
60 |
|
|
%description |
61 |
|
|
This is a Virtual File System library based on gio and Glib. |
62 |
|
|
|
63 |
|
|
%package -n %{libname} |
64 |
|
|
Group: System/Libraries |
65 |
|
|
Summary: Glib VFS library |
66 |
|
|
Requires: %name >= %version |
67 |
blino |
19174 |
Requires(post): %giolibname |
68 |
|
|
Requires(postun): %giolibname |
69 |
blino |
19172 |
|
70 |
|
|
%description -n %{libname} |
71 |
|
|
This is a Virtual File System library based on gio and Glib. |
72 |
|
|
|
73 |
|
|
%package -n %develname |
74 |
|
|
Group: Development/C |
75 |
|
|
Summary: Glib VFS Library - development files |
76 |
|
|
Requires: %libname = %version |
77 |
|
|
Provides: libgvfs-devel = %version-%release |
78 |
|
|
|
79 |
|
|
%description -n %develname |
80 |
|
|
This is a Virtual File System library based on gio and Glib. |
81 |
|
|
|
82 |
|
|
%package fuse |
83 |
|
|
Summary: FUSE support for gvfs |
84 |
|
|
Group: System/Libraries |
85 |
|
|
Requires: %{name} = %{version}-%{release} |
86 |
|
|
Requires: fuse |
87 |
|
|
|
88 |
|
|
%description fuse |
89 |
|
|
This package provides support for applications not using gio |
90 |
|
|
to access the gvfs filesystems. |
91 |
|
|
|
92 |
|
|
|
93 |
|
|
%package smb |
94 |
|
|
Summary: Windows fileshare support for gvfs |
95 |
|
|
Group: System/Libraries |
96 |
|
|
Requires: %{name} = %{version}-%{release} |
97 |
|
|
|
98 |
|
|
%description smb |
99 |
|
|
This package provides support for reading and writing files on windows |
100 |
|
|
shares (SMB) to applications using gvfs. |
101 |
|
|
|
102 |
|
|
%package archive |
103 |
|
|
Summary: Archiving support for gvfs |
104 |
|
|
Group: System/Libraries |
105 |
|
|
Requires: %{name} = %{version}-%{release} |
106 |
|
|
|
107 |
|
|
%description archive |
108 |
|
|
This package provides support for accessing files inside Zip and Tar archives, |
109 |
|
|
as well as ISO images, to applications using gvfs. |
110 |
|
|
|
111 |
|
|
|
112 |
|
|
%package obexftp |
113 |
|
|
Summary: ObexFTP support for gvfs |
114 |
|
|
Group: System/Libraries |
115 |
|
|
Requires: %{name} = %{version}-%{release} |
116 |
|
|
Requires: obex-data-server >= 0.3.4-6 |
117 |
|
|
|
118 |
|
|
%description obexftp |
119 |
|
|
This package provides support for reading files on Bluetooth mobile phones |
120 |
|
|
and devices through ObexFTP to applications using gvfs. |
121 |
|
|
|
122 |
|
|
%package gphoto2 |
123 |
|
|
Summary: gphoto2 support for gvfs |
124 |
|
|
Group: System/Libraries |
125 |
|
|
Requires: %{name} = %{version}-%{release} |
126 |
|
|
|
127 |
|
|
%description gphoto2 |
128 |
|
|
This package provides support for reading and writing files on |
129 |
|
|
PTP based cameras (Picture Transfer Protocol) and MTP based |
130 |
|
|
media players (Media Transfer Protocol) to applications using gvfs. |
131 |
|
|
|
132 |
|
|
%package iphone |
133 |
|
|
Summary: iphone support for gvfs |
134 |
|
|
Group: System/Libraries |
135 |
|
|
Requires: %{name} = %{version}-%{release} |
136 |
|
|
|
137 |
|
|
%description iphone |
138 |
|
|
This package provides support for reading and writing files on |
139 |
|
|
the iPhone and the iPod TouchP to applications using gvfs. |
140 |
|
|
|
141 |
|
|
|
142 |
|
|
%prep |
143 |
|
|
%setup -q |
144 |
|
|
%apply_patches |
145 |
|
|
|
146 |
|
|
%build |
147 |
|
|
%configure2_5x --with-dbus-service-dir=%_datadir/dbus-1/services \ |
148 |
ahmad |
75483 |
--enable-gdu \ |
149 |
blino |
19172 |
%if %{enable_gphoto2} |
150 |
|
|
--enable-gphoto2 |
151 |
|
|
%else |
152 |
|
|
--disable-gphoto2 |
153 |
|
|
%endif |
154 |
|
|
|
155 |
|
|
%make |
156 |
|
|
|
157 |
|
|
%install |
158 |
|
|
rm -rf %{buildroot} |
159 |
|
|
%makeinstall_std |
160 |
|
|
rm -f %buildroot%_libdir/gio/modules/*.la |
161 |
|
|
|
162 |
|
|
%find_lang gvfs |
163 |
|
|
|
164 |
|
|
# upstream bash completion is installed in the wrong place, with the wrong perms |
165 |
|
|
# and redefine system variables without notice |
166 |
|
|
rm -f %buildroot%_sysconfdir/profile.d/gvfs-bash-completion.sh |
167 |
|
|
install -d -m 755 %buildroot%_sysconfdir/bash_completion.d |
168 |
|
|
install -m 644 %{SOURCE1} %buildroot%_sysconfdir/bash_completion.d/%{name} |
169 |
|
|
|
170 |
|
|
%clean |
171 |
|
|
rm -rf %{buildroot} |
172 |
|
|
|
173 |
|
|
%post -n %libname |
174 |
|
|
%if %_lib != lib |
175 |
|
|
%{_bindir}/gio-querymodules-64 %{_libdir}/gio/modules |
176 |
|
|
%else |
177 |
|
|
%{_bindir}/gio-querymodules-32 %{_libdir}/gio/modules |
178 |
|
|
%endif |
179 |
|
|
|
180 |
|
|
%postun -n %libname |
181 |
|
|
if [ "$1" = "0" ]; then |
182 |
|
|
%if %_lib != lib |
183 |
|
|
%{_bindir}/gio-querymodules-64 %{_libdir}/gio/modules |
184 |
|
|
%else |
185 |
|
|
%{_bindir}/gio-querymodules-32 %{_libdir}/gio/modules |
186 |
|
|
%endif |
187 |
|
|
fi |
188 |
|
|
|
189 |
ahmad |
75483 |
glib-compile-schemas %{_datadir}/glib-2.0/schemas || : |
190 |
|
|
|
191 |
|
|
%posttrans |
192 |
|
|
glib-compile-schemas %{_datadir}/glib-2.0/schemas || : |
193 |
|
|
|
194 |
blino |
19172 |
%files -f gvfs.lang |
195 |
|
|
%defattr(-,root,root) |
196 |
|
|
%_sysconfdir/bash_completion.d/gvfs |
197 |
|
|
%_bindir/gvfs-* |
198 |
|
|
%_datadir/dbus-1/services/gvfs-daemon.service |
199 |
|
|
%_datadir/dbus-1/services/gvfs-metadata.service |
200 |
|
|
%_datadir/dbus-1/services/org.gtk.Private.GduVolumeMonitor.service |
201 |
|
|
%dir %_datadir/gvfs |
202 |
|
|
%dir %_datadir/gvfs/mounts |
203 |
|
|
%dir %_datadir/gvfs/remote-volume-monitors |
204 |
|
|
%_datadir/gvfs/remote-volume-monitors/gdu.monitor |
205 |
|
|
%_datadir/gvfs/mounts/sftp.mount |
206 |
|
|
%_datadir/gvfs/mounts/trash.mount |
207 |
|
|
%_datadir/gvfs/mounts/cdda.mount |
208 |
|
|
%_datadir/gvfs/mounts/computer.mount |
209 |
|
|
%_datadir/gvfs/mounts/dav.mount |
210 |
|
|
%_datadir/gvfs/mounts/dav+sd.mount |
211 |
|
|
%_datadir/gvfs/mounts/http.mount |
212 |
|
|
%_datadir/gvfs/mounts/localtest.mount |
213 |
|
|
%_datadir/gvfs/mounts/burn.mount |
214 |
|
|
%_datadir/gvfs/mounts/dns-sd.mount |
215 |
|
|
%_datadir/gvfs/mounts/network.mount |
216 |
|
|
%_datadir/gvfs/mounts/ftp.mount |
217 |
ahmad |
75483 |
%_datadir/GConf/gsettings/*.convert |
218 |
|
|
%_datadir/glib-2.0/schemas/*.xml |
219 |
blino |
19172 |
|
220 |
|
|
%files -n %libname |
221 |
|
|
%defattr(-,root,root) |
222 |
|
|
%_libdir/gio/modules/libgioremote-volume-monitor.so |
223 |
|
|
%_libdir/gio/modules/libgvfsdbus.so |
224 |
|
|
%_libexecdir/gvfs-gdu-volume-monitor |
225 |
ahmad |
75483 |
|
226 |
blino |
19172 |
%_libexecdir/gvfsd |
227 |
|
|
%_libexecdir/gvfsd-ftp |
228 |
|
|
%_libexecdir/gvfsd-metadata |
229 |
|
|
%_libexecdir/gvfsd-sftp |
230 |
|
|
%_libexecdir/gvfsd-trash |
231 |
|
|
%_libexecdir/gvfsd-cdda |
232 |
|
|
%_libexecdir/gvfsd-computer |
233 |
|
|
%_libexecdir/gvfsd-dav |
234 |
|
|
%_libexecdir/gvfsd-http |
235 |
|
|
%_libexecdir/gvfsd-localtest |
236 |
|
|
%_libexecdir/gvfsd-burn |
237 |
|
|
%_libexecdir/gvfsd-dnssd |
238 |
|
|
%_libexecdir/gvfsd-network |
239 |
|
|
%_libdir/libgvfscommon.so.%{major}* |
240 |
|
|
%_libdir/libgvfscommon-dnssd.so.%{major}* |
241 |
|
|
%files -n %develname |
242 |
|
|
%defattr(-,root,root) |
243 |
|
|
%doc NEWS ChangeLog AUTHORS TODO |
244 |
|
|
%_libdir/lib*.so |
245 |
|
|
%_libdir/lib*.la |
246 |
|
|
%_includedir/gvfs-client |
247 |
|
|
|
248 |
|
|
%files fuse |
249 |
|
|
%defattr(-, root, root, -) |
250 |
|
|
%{_libexecdir}/gvfs-fuse-daemon |
251 |
|
|
|
252 |
|
|
|
253 |
|
|
%files smb |
254 |
|
|
%defattr(-, root, root, -) |
255 |
|
|
%{_libexecdir}/gvfsd-smb |
256 |
|
|
%{_libexecdir}/gvfsd-smb-browse |
257 |
|
|
%{_datadir}/gvfs/mounts/smb-browse.mount |
258 |
|
|
%{_datadir}/gvfs/mounts/smb.mount |
259 |
|
|
|
260 |
|
|
%files archive |
261 |
|
|
%defattr(-, root, root, -) |
262 |
|
|
%{_libexecdir}/gvfsd-archive |
263 |
|
|
%{_datadir}/gvfs/mounts/archive.mount |
264 |
|
|
|
265 |
|
|
|
266 |
|
|
%files obexftp |
267 |
|
|
%defattr(-, root, root, -) |
268 |
|
|
%{_libexecdir}/gvfsd-obexftp |
269 |
|
|
%{_datadir}/gvfs/mounts/obexftp.mount |
270 |
|
|
|
271 |
|
|
%if %{enable_gphoto2} |
272 |
|
|
%files gphoto2 |
273 |
|
|
%defattr(-, root, root, -) |
274 |
|
|
%{_libexecdir}/gvfsd-gphoto2 |
275 |
|
|
%{_datadir}/gvfs/mounts/gphoto2.mount |
276 |
|
|
%{_libexecdir}/gvfs-gphoto2-volume-monitor |
277 |
|
|
%{_datadir}/dbus-1/services/org.gtk.Private.GPhoto2VolumeMonitor.service |
278 |
|
|
%{_datadir}/gvfs/remote-volume-monitors/gphoto2.monitor |
279 |
|
|
%endif |
280 |
|
|
|
281 |
|
|
%if %{enable_iphone} |
282 |
|
|
%files iphone |
283 |
|
|
%defattr(-, root, root, -) |
284 |
|
|
%_libexecdir/gvfs-afc-volume-monitor |
285 |
|
|
%_libexecdir/gvfsd-afc |
286 |
|
|
%_datadir/dbus-1/services/org.gtk.Private.AfcVolumeMonitor.service |
287 |
|
|
%_datadir/gvfs/mounts/afc.mount |
288 |
|
|
%_datadir/gvfs/remote-volume-monitors/afc.monitor |
289 |
|
|
%endif |