1 |
wally |
1193924 |
# build with -j12 broken? |
2 |
daviddavid |
1931928 |
%global _smp_ncpus_max 4 |
3 |
wally |
1193924 |
|
4 |
wally |
1193912 |
%bcond_without gphoto2 |
5 |
|
|
%bcond_without iphone |
6 |
|
|
%bcond_without mtp |
7 |
|
|
%bcond_without goa |
8 |
|
|
%bcond_without man |
9 |
blino |
19172 |
|
10 |
ovitters |
1709338 |
%define url_ver %{lua: ver = rpm.expand("%{version}"); majmin, count1 = string.gsub(ver, "^([0123456789]+%.[0123456789]+).*", "%1", 1); if count1 == 0 then print(ver); return; end; maj, count2 = string.gsub(majmin, "^([0123456789]+).*", "%1", 1); if count2 == 0 then print(majmin) elseif tonumber(majmin) < 40 then print(majmin) else print(maj) end} |
11 |
wally |
155765 |
|
12 |
wally |
121687 |
Summary: Glib VFS library |
13 |
fwang |
148671 |
Name: gvfs |
14 |
daviddavid |
2077841 |
Version: 1.54.2 |
15 |
daviddavid |
1982792 |
Release: %mkrel 1 |
16 |
wally |
121687 |
License: LGPLv2+ |
17 |
|
|
Group: System/Libraries |
18 |
wally |
1367555 |
Url: https://wiki.gnome.org/Projects/gvfs |
19 |
daviddavid |
1597889 |
Source0: https://download.gnome.org/sources/%{name}/%{url_ver}/%{name}-%{version}.tar.xz |
20 |
tv |
1825264 |
|
21 |
wally |
1193912 |
BuildRequires: meson |
22 |
tv |
1825264 |
BuildRequires: gcc |
23 |
daviddavid |
1597889 |
BuildRequires: gettext |
24 |
wally |
130651 |
BuildRequires: cdda-devel |
25 |
wally |
1193918 |
BuildRequires: openssh-clients |
26 |
ovitters |
642514 |
BuildRequires: pkgconfig(expat) |
27 |
ovitters |
1570363 |
BuildRequires: pkgconfig(libgcrypt) |
28 |
wally |
1193912 |
BuildRequires: pkgconfig(avahi-client) |
29 |
|
|
BuildRequires: pkgconfig(avahi-glib) |
30 |
|
|
BuildRequires: pkgconfig(bluez) |
31 |
fwang |
469962 |
BuildRequires: pkgconfig(dbus-1) |
32 |
wally |
1710777 |
BuildRequires: pkgconfig(fuse3) |
33 |
fwang |
469962 |
BuildRequires: pkgconfig(gio-2.0) |
34 |
|
|
BuildRequires: pkgconfig(gio-unix-2.0) |
35 |
wally |
1193912 |
BuildRequires: pkgconfig(libgdata) |
36 |
|
|
BuildRequires: pkgconfig(glib-2.0) |
37 |
fwang |
469962 |
BuildRequires: pkgconfig(gmodule-no-export-2.0) |
38 |
fwang |
159085 |
BuildRequires: pkgconfig(gobject-2.0) |
39 |
wally |
1193912 |
BuildRequires: pkgconfig(gtk+-3.0) |
40 |
|
|
BuildRequires: pkgconfig(gudev-1.0) |
41 |
wally |
130651 |
BuildRequires: pkgconfig(libarchive) |
42 |
fwang |
469962 |
BuildRequires: pkgconfig(libbluray) |
43 |
wally |
1193912 |
BuildRequires: pkgconfig(libcdio_paranoia) |
44 |
ovitters |
1427409 |
BuildRequires: pkgconfig(gsettings-desktop-schemas) |
45 |
wally |
1193912 |
BuildRequires: pkgconfig(libnfs) |
46 |
ovitters |
288151 |
BuildRequires: pkgconfig(libsecret-unstable) |
47 |
tv |
1800735 |
BuildRequires: pkgconfig(libsoup-3.0) |
48 |
danf |
1779355 |
BuildRequires: pkgconfig(libsystemd) |
49 |
daviddavid |
2050162 |
BuildRequires: pkgconfig(msgraph-0.1) |
50 |
ovitters |
1053814 |
BuildRequires: pkgconfig(polkit-gobject-1) |
51 |
wally |
1193912 |
BuildRequires: pkgconfig(libudev) |
52 |
fwang |
469962 |
BuildRequires: pkgconfig(libxml-2.0) |
53 |
|
|
BuildRequires: pkgconfig(smbclient) |
54 |
wally |
1193912 |
BuildRequires: pkgconfig(udisks2) |
55 |
wally |
121687 |
|
56 |
wally |
1193912 |
%if %{with gphoto2} |
57 |
|
|
BuildRequires: pkgconfig(libgphoto2) |
58 |
blino |
19172 |
%endif |
59 |
wally |
121687 |
|
60 |
wally |
1193912 |
%if %{with iphone} |
61 |
|
|
BuildRequires: pkgconfig(libimobiledevice-1.0) |
62 |
daviddavid |
1597889 |
BuildRequires: pkgconfig(libplist-2.0) |
63 |
blino |
19172 |
%endif |
64 |
wally |
121687 |
|
65 |
wally |
1193912 |
%if %{with mtp} |
66 |
daviddavid |
1931928 |
BuildRequires: pkgconfig(libmtp) |
67 |
dams |
427811 |
%endif |
68 |
|
|
|
69 |
wally |
1193912 |
%if %{with goa} |
70 |
|
|
BuildRequires: pkgconfig(goa-1.0) |
71 |
dams |
427811 |
%endif |
72 |
|
|
|
73 |
wally |
1193912 |
%if %{with_man} |
74 |
|
|
BuildRequires: xsltproc |
75 |
|
|
%endif |
76 |
|
|
|
77 |
blino |
19172 |
#gw the dbus service depends on the daemon in the library package |
78 |
ovitters |
653680 |
Requires: %{name} |
79 |
colin |
203867 |
Requires: udisks2 |
80 |
tv |
675732 |
Recommends: %{name}-fuse |
81 |
|
|
Recommends: %{name}-smb |
82 |
|
|
Recommends: %{name}-archive |
83 |
ovitters |
839598 |
Recommends: %mklibname glib-networking |
84 |
wally |
121687 |
|
85 |
wally |
1193912 |
%if %{with gphoto2} |
86 |
tv |
675732 |
Recommends: %{name}-gphoto2 |
87 |
blino |
19172 |
%endif |
88 |
|
|
|
89 |
wally |
1193912 |
%if %{with iphone} |
90 |
daviddavid |
1715278 |
Recommends: %{name}-iphone |
91 |
dams |
427811 |
%endif |
92 |
|
|
|
93 |
wally |
1193912 |
%if %{with mtp} |
94 |
daviddavid |
1715278 |
Recommends: %{name}-mtp |
95 |
dams |
427811 |
%endif |
96 |
|
|
|
97 |
blino |
19172 |
%description |
98 |
|
|
This is a Virtual File System library based on gio and Glib. |
99 |
wally |
1193912 |
|
100 |
ovitters |
653680 |
%package -n %{name}-devel |
101 |
wally |
121687 |
Group: Development/C |
102 |
|
|
Summary: Glib VFS Library - development files |
103 |
ovitters |
653680 |
Obsoletes: %{_lib}gvfs-devel |
104 |
blino |
19172 |
|
105 |
ovitters |
653680 |
%description -n %{name}-devel |
106 |
blino |
19172 |
This is a Virtual File System library based on gio and Glib. |
107 |
|
|
|
108 |
|
|
%package fuse |
109 |
wally |
121687 |
Summary: FUSE support for gvfs |
110 |
|
|
Group: System/Libraries |
111 |
|
|
Requires: %{name} = %{version}-%{release} |
112 |
wally |
1710777 |
Requires: fuse3 |
113 |
blino |
19172 |
|
114 |
|
|
%description fuse |
115 |
|
|
This package provides support for applications not using gio |
116 |
|
|
to access the gvfs filesystems. |
117 |
|
|
|
118 |
|
|
%package smb |
119 |
wally |
121687 |
Summary: Windows fileshare support for gvfs |
120 |
|
|
Group: System/Libraries |
121 |
|
|
Requires: %{name} = %{version}-%{release} |
122 |
blino |
19172 |
|
123 |
|
|
%description smb |
124 |
|
|
This package provides support for reading and writing files on windows |
125 |
|
|
shares (SMB) to applications using gvfs. |
126 |
|
|
|
127 |
|
|
%package archive |
128 |
wally |
121687 |
Summary: Archiving support for gvfs |
129 |
|
|
Group: System/Libraries |
130 |
|
|
Requires: %{name} = %{version}-%{release} |
131 |
blino |
19172 |
|
132 |
|
|
%description archive |
133 |
|
|
This package provides support for accessing files inside Zip and Tar archives, |
134 |
|
|
as well as ISO images, to applications using gvfs. |
135 |
|
|
|
136 |
|
|
%package gphoto2 |
137 |
wally |
121687 |
Summary: gphoto2 support for gvfs |
138 |
|
|
Group: System/Libraries |
139 |
|
|
Requires: %{name} = %{version}-%{release} |
140 |
blino |
19172 |
|
141 |
|
|
%description gphoto2 |
142 |
|
|
This package provides support for reading and writing files on |
143 |
|
|
PTP based cameras (Picture Transfer Protocol) and MTP based |
144 |
|
|
media players (Media Transfer Protocol) to applications using gvfs. |
145 |
|
|
|
146 |
|
|
%package iphone |
147 |
wally |
121687 |
Summary: iPhone support for gvfs |
148 |
|
|
Group: System/Libraries |
149 |
|
|
Requires: %{name} = %{version}-%{release} |
150 |
daviddavid |
1711427 |
Requires: usbmuxd |
151 |
blino |
19172 |
|
152 |
|
|
%description iphone |
153 |
|
|
This package provides support for reading and writing files on |
154 |
|
|
the iPhone and the iPod TouchP to applications using gvfs. |
155 |
|
|
|
156 |
dams |
427811 |
%package mtp |
157 |
|
|
Summary: MTP support for gvfs |
158 |
|
|
Group: System/Libraries |
159 |
|
|
Requires: %{name} = %{version}-%{release} |
160 |
|
|
|
161 |
|
|
%description mtp |
162 |
|
|
This package provides support for reading and writing files on MTP devices, |
163 |
|
|
using gvfs. |
164 |
|
|
|
165 |
|
|
%package goa |
166 |
|
|
Summary: GNOME Online Accounts support for gvfs |
167 |
|
|
Group: System/Libraries |
168 |
|
|
Requires: %{name} = %{version}-%{release} |
169 |
|
|
|
170 |
|
|
%description goa |
171 |
|
|
This package provides seamless integration with gnome-online-accounts |
172 |
|
|
file services, using gvfs. |
173 |
|
|
|
174 |
wally |
1399102 |
%package google |
175 |
|
|
Summary: Google Drive support for gvfs |
176 |
|
|
Group: System/Libraries |
177 |
|
|
Requires: %{name} = %{version}-%{release} |
178 |
|
|
Conflicts: gvfs < 1.40.1-4 |
179 |
|
|
|
180 |
|
|
%description google |
181 |
|
|
This package provides seamless integration with Google Drive |
182 |
|
|
file services, using gvfs. |
183 |
|
|
|
184 |
blino |
19172 |
%prep |
185 |
tv |
595716 |
%autosetup -p1 |
186 |
blino |
19172 |
|
187 |
|
|
%build |
188 |
wally |
1193912 |
%meson \ |
189 |
luigiwalser |
1789585 |
-Dgphoto2=%{?with_gphoto2:true}%{?!with_gphoto2:false} \ |
190 |
wally |
1193923 |
-Dafc=%{?with_iphone:true}%{?!with_iphone:false} \ |
191 |
wally |
1193912 |
-Dmtp=%{?with_mtp:true}%{?!with_mtp:false} \ |
192 |
|
|
-Dgoa=%{?with_goa:true}%{?!with_goa:false} \ |
193 |
|
|
-Dman=%{?with_man:true}%{?!with_man:false} |
194 |
|
|
%meson_build |
195 |
blino |
19172 |
|
196 |
|
|
%install |
197 |
wally |
1193912 |
%meson_install |
198 |
blino |
19172 |
|
199 |
|
|
%find_lang gvfs |
200 |
|
|
|
201 |
ahmad |
95229 |
%post |
202 |
|
|
# Reload .mount files: |
203 |
|
|
killall -USR1 gvfsd >&/dev/null || : |
204 |
blino |
19172 |
|
205 |
ahmad |
95229 |
# Reload .mount files when single subpackage is installed: |
206 |
|
|
%post archive |
207 |
|
|
killall -USR1 gvfsd >&/dev/null || : |
208 |
dmorgan |
105096 |
|
209 |
ahmad |
95229 |
%post gphoto2 |
210 |
|
|
killall -USR1 gvfsd >&/dev/null || : |
211 |
wally |
121687 |
|
212 |
ahmad |
95229 |
%post iphone |
213 |
|
|
killall -USR1 gvfsd >&/dev/null || : |
214 |
wally |
121687 |
|
215 |
ahmad |
95229 |
%post smb |
216 |
|
|
killall -USR1 gvfsd >&/dev/null || : |
217 |
blino |
19172 |
|
218 |
dams |
427811 |
%post mtp |
219 |
|
|
killall -USR1 gvfsd >&/dev/null || : |
220 |
|
|
|
221 |
|
|
%post goa |
222 |
|
|
killall -USR1 gvfsd >&/dev/null || : |
223 |
|
|
|
224 |
wally |
1399102 |
%post google |
225 |
|
|
killall -USR1 gvfsd >&/dev/null || : |
226 |
|
|
|
227 |
blino |
19172 |
%files -f gvfs.lang |
228 |
guillomovitch |
1250881 |
%doc README.md NEWS |
229 |
tv |
896433 |
%{_datadir}/dbus-1/services/org.gtk.vfs.Daemon.service |
230 |
|
|
%{_datadir}/dbus-1/services/org.gtk.vfs.Metadata.service |
231 |
tv |
882670 |
%{_datadir}/dbus-1/services/org.gtk.vfs.UDisks2VolumeMonitor.service |
232 |
ahmad |
75484 |
%dir %{_datadir}/gvfs |
233 |
|
|
%dir %{_datadir}/gvfs/mounts |
234 |
daviddavid |
2050316 |
%{_datadir}/gvfs/mounts/admin.mount |
235 |
ahmad |
75484 |
%{_datadir}/gvfs/mounts/sftp.mount |
236 |
|
|
%{_datadir}/gvfs/mounts/trash.mount |
237 |
|
|
%{_datadir}/gvfs/mounts/cdda.mount |
238 |
|
|
%{_datadir}/gvfs/mounts/computer.mount |
239 |
|
|
%{_datadir}/gvfs/mounts/dav.mount |
240 |
|
|
%{_datadir}/gvfs/mounts/dav+sd.mount |
241 |
|
|
%{_datadir}/gvfs/mounts/http.mount |
242 |
|
|
%{_datadir}/gvfs/mounts/localtest.mount |
243 |
|
|
%{_datadir}/gvfs/mounts/dns-sd.mount |
244 |
|
|
%{_datadir}/gvfs/mounts/network.mount |
245 |
|
|
%{_datadir}/gvfs/mounts/ftp.mount |
246 |
guillomovitch |
1250881 |
%{_datadir}/gvfs/mounts/ftpis.mount |
247 |
fwang |
272509 |
%{_datadir}/gvfs/mounts/recent.mount |
248 |
fwang |
136200 |
%{_datadir}/gvfs/mounts/afp-browse.mount |
249 |
ovitters |
839597 |
%{_datadir}/gvfs/mounts/ftps.mount |
250 |
fwang |
136200 |
%{_datadir}/gvfs/mounts/afp.mount |
251 |
wally |
1193912 |
%{_datadir}/gvfs/mounts/nfs.mount |
252 |
daviddavid |
2050316 |
%{_datadir}/gvfs/mounts/onedrive.mount |
253 |
|
|
%{_datadir}/gvfs/mounts/wsdd.mount |
254 |
colin |
203642 |
%dir %{_datadir}/gvfs/remote-volume-monitors |
255 |
|
|
%{_datadir}/gvfs/remote-volume-monitors/udisks2.monitor |
256 |
daviddavid |
2050316 |
%{_datadir}/glib-2.0/schemas/org.gnome.system.wsdd.gschema.xml |
257 |
dmorgan |
105096 |
%{_datadir}/GConf/gsettings/gvfs-dns-sd.convert |
258 |
|
|
%{_datadir}/glib-2.0/schemas/org.gnome.system.dns_sd.gschema.xml |
259 |
|
|
%{_datadir}/glib-2.0/schemas/org.gnome.system.gvfs.enums.xml |
260 |
ovitters |
1053841 |
%{_datadir}/polkit-1/actions/org.gtk.vfs.file-operations.policy |
261 |
|
|
%{_datadir}/polkit-1/rules.d/org.gtk.vfs.file-operations.rules |
262 |
wally |
1193912 |
%if %{with man} |
263 |
ovitters |
280233 |
%{_mandir}/man7/gvfs.* |
264 |
neoclust |
338316 |
%{_mandir}/man1/gvfsd.* |
265 |
|
|
%{_mandir}/man1/gvfsd-metadata.* |
266 |
wally |
1193912 |
%endif |
267 |
fwang |
338021 |
%{_libexecdir}/gvfs-udisks2-volume-monitor |
268 |
ahmad |
75484 |
%{_libexecdir}/gvfsd |
269 |
ovitters |
1053841 |
%{_libexecdir}/gvfsd-admin |
270 |
ahmad |
75484 |
%{_libexecdir}/gvfsd-ftp |
271 |
|
|
%{_libexecdir}/gvfsd-metadata |
272 |
|
|
%{_libexecdir}/gvfsd-sftp |
273 |
|
|
%{_libexecdir}/gvfsd-trash |
274 |
|
|
%{_libexecdir}/gvfsd-cdda |
275 |
|
|
%{_libexecdir}/gvfsd-computer |
276 |
|
|
%{_libexecdir}/gvfsd-dav |
277 |
|
|
%{_libexecdir}/gvfsd-http |
278 |
|
|
%{_libexecdir}/gvfsd-localtest |
279 |
|
|
%{_libexecdir}/gvfsd-dnssd |
280 |
|
|
%{_libexecdir}/gvfsd-network |
281 |
fwang |
136200 |
%{_libexecdir}/gvfsd-afp |
282 |
|
|
%{_libexecdir}/gvfsd-afp-browse |
283 |
fwang |
272509 |
%{_libexecdir}/gvfsd-recent |
284 |
wally |
1193912 |
%{_libexecdir}/gvfsd-nfs |
285 |
daviddavid |
2050316 |
%{_libexecdir}/gvfsd-onedrive |
286 |
|
|
%{_libexecdir}/gvfsd-wsdd |
287 |
ovitters |
653680 |
%{_libdir}/gvfs/libgvfscommon.so |
288 |
|
|
%{_libdir}/gvfs/libgvfsdaemon.so |
289 |
neoclust |
338316 |
%{_libdir}/gio/modules/libgioremote-volume-monitor.so |
290 |
|
|
%{_libdir}/gio/modules/libgvfsdbus.so |
291 |
dams |
427811 |
%{_prefix}/lib/tmpfiles.d/gvfsd-fuse-tmpfiles.conf |
292 |
wally |
1193912 |
%{_userunitdir}/gvfs-daemon.service |
293 |
|
|
%{_userunitdir}/gvfs-metadata.service |
294 |
|
|
%{_userunitdir}/gvfs-udisks2-volume-monitor.service |
295 |
|
|
|
296 |
ovitters |
653680 |
%files -n %{name}-devel |
297 |
wally |
121687 |
%{_includedir}/gvfs-client |
298 |
blino |
19172 |
|
299 |
|
|
%files fuse |
300 |
fwang |
277127 |
%{_libexecdir}/gvfsd-fuse |
301 |
wally |
1193912 |
%if %{with man} |
302 |
ovitters |
280234 |
%{_mandir}/man1/gvfsd-fuse.* |
303 |
wally |
1193912 |
%endif |
304 |
blino |
19172 |
|
305 |
|
|
%files smb |
306 |
|
|
%{_libexecdir}/gvfsd-smb |
307 |
|
|
%{_libexecdir}/gvfsd-smb-browse |
308 |
|
|
%{_datadir}/gvfs/mounts/smb-browse.mount |
309 |
|
|
%{_datadir}/gvfs/mounts/smb.mount |
310 |
dmorgan |
105096 |
%{_datadir}/glib-2.0/schemas/org.gnome.system.smb.gschema.xml |
311 |
|
|
%{_datadir}/GConf/gsettings/gvfs-smb.convert |
312 |
blino |
19172 |
|
313 |
|
|
%files archive |
314 |
|
|
%{_libexecdir}/gvfsd-archive |
315 |
|
|
%{_datadir}/gvfs/mounts/archive.mount |
316 |
|
|
|
317 |
wally |
1193912 |
%if %{with gphoto2} |
318 |
blino |
19172 |
%files gphoto2 |
319 |
|
|
%{_libexecdir}/gvfsd-gphoto2 |
320 |
|
|
%{_datadir}/gvfs/mounts/gphoto2.mount |
321 |
|
|
%{_libexecdir}/gvfs-gphoto2-volume-monitor |
322 |
tv |
882670 |
%{_datadir}/dbus-1/services/org.gtk.vfs.GPhoto2VolumeMonitor.service |
323 |
blino |
19172 |
%{_datadir}/gvfs/remote-volume-monitors/gphoto2.monitor |
324 |
wally |
1193912 |
%{_userunitdir}/gvfs-gphoto2-volume-monitor.service |
325 |
blino |
19172 |
%endif |
326 |
|
|
|
327 |
wally |
1193912 |
%if %{with iphone} |
328 |
blino |
19172 |
%files iphone |
329 |
ahmad |
75484 |
%{_libexecdir}/gvfs-afc-volume-monitor |
330 |
|
|
%{_libexecdir}/gvfsd-afc |
331 |
tv |
882670 |
%{_datadir}/dbus-1/services/org.gtk.vfs.AfcVolumeMonitor.service |
332 |
ahmad |
75484 |
%{_datadir}/gvfs/mounts/afc.mount |
333 |
|
|
%{_datadir}/gvfs/remote-volume-monitors/afc.monitor |
334 |
wally |
1193912 |
%{_userunitdir}/gvfs-afc-volume-monitor.service |
335 |
blino |
19172 |
%endif |
336 |
dams |
427811 |
|
337 |
wally |
1193912 |
%if %{with mtp} |
338 |
dams |
427811 |
%files mtp |
339 |
|
|
%{_libexecdir}/gvfsd-mtp |
340 |
|
|
%{_datadir}/gvfs/mounts/mtp.mount |
341 |
|
|
%{_libexecdir}/gvfs-mtp-volume-monitor |
342 |
tv |
882670 |
%{_datadir}/dbus-1/services/org.gtk.vfs.MTPVolumeMonitor.service |
343 |
dams |
427811 |
%{_datadir}/gvfs/remote-volume-monitors/mtp.monitor |
344 |
wally |
1193912 |
%{_userunitdir}/gvfs-mtp-volume-monitor.service |
345 |
dams |
427811 |
%endif |
346 |
|
|
|
347 |
wally |
1193912 |
%if %{with goa} |
348 |
dams |
427811 |
%files goa |
349 |
|
|
%{_libexecdir}/gvfs-goa-volume-monitor |
350 |
tv |
882670 |
%{_datadir}/dbus-1/services/org.gtk.vfs.GoaVolumeMonitor.service |
351 |
dams |
427811 |
%{_datadir}/gvfs/remote-volume-monitors/goa.monitor |
352 |
wally |
1193912 |
%{_userunitdir}/gvfs-goa-volume-monitor.service |
353 |
dams |
427811 |
%endif |
354 |
wally |
1399102 |
|
355 |
|
|
%files google |
356 |
|
|
%{_libexecdir}/gvfsd-google |
357 |
|
|
%{_datadir}/gvfs/mounts/google.mount |