1 |
# build with -j12 broken? |
2 |
%global _smp_ncpus_max 4 |
3 |
|
4 |
%bcond_without gphoto2 |
5 |
%bcond_without iphone |
6 |
%bcond_without mtp |
7 |
%bcond_without goa |
8 |
%bcond_without man |
9 |
|
10 |
%define url_ver %{lua: ver = rpm.expand("%{version}"); majmin, count1 = string.gsub(ver, "^([0123456789]+%.[0123456789]+).*", "%1", 1); if count1 == 0 then print(ver); return; end; maj, count2 = string.gsub(majmin, "^([0123456789]+).*", "%1", 1); if count2 == 0 then print(majmin) elseif tonumber(majmin) < 40 then print(majmin) else print(maj) end} |
11 |
|
12 |
Summary: Glib VFS library |
13 |
Name: gvfs |
14 |
Version: 1.56.0 |
15 |
Release: %mkrel 1 |
16 |
License: LGPLv2+ |
17 |
Group: System/Libraries |
18 |
Url: https://wiki.gnome.org/Projects/gvfs |
19 |
Source0: https://download.gnome.org/sources/%{name}/%{url_ver}/%{name}-%{version}.tar.xz |
20 |
|
21 |
BuildRequires: meson |
22 |
BuildRequires: gcc |
23 |
BuildRequires: gettext |
24 |
BuildRequires: cdda-devel |
25 |
BuildRequires: openssh-clients |
26 |
BuildRequires: pkgconfig(expat) |
27 |
BuildRequires: pkgconfig(libgcrypt) |
28 |
BuildRequires: pkgconfig(avahi-client) |
29 |
BuildRequires: pkgconfig(avahi-glib) |
30 |
BuildRequires: pkgconfig(bluez) |
31 |
BuildRequires: pkgconfig(dbus-1) |
32 |
BuildRequires: pkgconfig(fuse3) |
33 |
BuildRequires: pkgconfig(gio-2.0) |
34 |
BuildRequires: pkgconfig(gio-unix-2.0) |
35 |
BuildRequires: pkgconfig(libgdata) |
36 |
BuildRequires: pkgconfig(glib-2.0) |
37 |
BuildRequires: pkgconfig(gmodule-no-export-2.0) |
38 |
BuildRequires: pkgconfig(gobject-2.0) |
39 |
BuildRequires: pkgconfig(gtk+-3.0) |
40 |
BuildRequires: pkgconfig(gudev-1.0) |
41 |
BuildRequires: pkgconfig(libarchive) |
42 |
BuildRequires: pkgconfig(libbluray) |
43 |
BuildRequires: pkgconfig(libcdio_paranoia) |
44 |
BuildRequires: pkgconfig(gsettings-desktop-schemas) |
45 |
BuildRequires: pkgconfig(libnfs) |
46 |
BuildRequires: pkgconfig(libsecret-unstable) |
47 |
BuildRequires: pkgconfig(libsoup-3.0) |
48 |
BuildRequires: pkgconfig(libsystemd) |
49 |
BuildRequires: pkgconfig(msgraph-0.1) |
50 |
BuildRequires: pkgconfig(polkit-gobject-1) |
51 |
BuildRequires: pkgconfig(libudev) |
52 |
BuildRequires: pkgconfig(libxml-2.0) |
53 |
BuildRequires: pkgconfig(smbclient) |
54 |
BuildRequires: pkgconfig(udisks2) |
55 |
|
56 |
%if %{with gphoto2} |
57 |
BuildRequires: pkgconfig(libgphoto2) |
58 |
%endif |
59 |
|
60 |
%if %{with iphone} |
61 |
BuildRequires: pkgconfig(libimobiledevice-1.0) |
62 |
BuildRequires: pkgconfig(libplist-2.0) |
63 |
%endif |
64 |
|
65 |
%if %{with mtp} |
66 |
BuildRequires: pkgconfig(libmtp) |
67 |
%endif |
68 |
|
69 |
%if %{with goa} |
70 |
BuildRequires: pkgconfig(goa-1.0) |
71 |
%endif |
72 |
|
73 |
%if %{with_man} |
74 |
BuildRequires: xsltproc |
75 |
%endif |
76 |
|
77 |
#gw the dbus service depends on the daemon in the library package |
78 |
Requires: %{name} |
79 |
Requires: udisks2 |
80 |
Recommends: %{name}-fuse |
81 |
Recommends: %{name}-smb |
82 |
Recommends: %{name}-archive |
83 |
Recommends: %mklibname glib-networking |
84 |
|
85 |
%if %{with gphoto2} |
86 |
Recommends: %{name}-gphoto2 |
87 |
%endif |
88 |
|
89 |
%if %{with iphone} |
90 |
Recommends: %{name}-iphone |
91 |
%endif |
92 |
|
93 |
%if %{with mtp} |
94 |
Recommends: %{name}-mtp |
95 |
%endif |
96 |
|
97 |
Obsoletes: %{name}-devel < 1.56.0 |
98 |
|
99 |
%description |
100 |
This is a Virtual File System library based on gio and Glib. |
101 |
|
102 |
%package fuse |
103 |
Summary: FUSE support for gvfs |
104 |
Group: System/Libraries |
105 |
Requires: %{name} = %{version}-%{release} |
106 |
Requires: fuse3 |
107 |
|
108 |
%description fuse |
109 |
This package provides support for applications not using gio |
110 |
to access the gvfs filesystems. |
111 |
|
112 |
%package smb |
113 |
Summary: Windows fileshare support for gvfs |
114 |
Group: System/Libraries |
115 |
Requires: %{name} = %{version}-%{release} |
116 |
|
117 |
%description smb |
118 |
This package provides support for reading and writing files on windows |
119 |
shares (SMB) to applications using gvfs. |
120 |
|
121 |
%package archive |
122 |
Summary: Archiving support for gvfs |
123 |
Group: System/Libraries |
124 |
Requires: %{name} = %{version}-%{release} |
125 |
|
126 |
%description archive |
127 |
This package provides support for accessing files inside Zip and Tar archives, |
128 |
as well as ISO images, to applications using gvfs. |
129 |
|
130 |
%package gphoto2 |
131 |
Summary: gphoto2 support for gvfs |
132 |
Group: System/Libraries |
133 |
Requires: %{name} = %{version}-%{release} |
134 |
|
135 |
%description gphoto2 |
136 |
This package provides support for reading and writing files on |
137 |
PTP based cameras (Picture Transfer Protocol) and MTP based |
138 |
media players (Media Transfer Protocol) to applications using gvfs. |
139 |
|
140 |
%package iphone |
141 |
Summary: iPhone support for gvfs |
142 |
Group: System/Libraries |
143 |
Requires: %{name} = %{version}-%{release} |
144 |
Requires: usbmuxd |
145 |
|
146 |
%description iphone |
147 |
This package provides support for reading and writing files on |
148 |
the iPhone and the iPod TouchP to applications using gvfs. |
149 |
|
150 |
%package mtp |
151 |
Summary: MTP support for gvfs |
152 |
Group: System/Libraries |
153 |
Requires: %{name} = %{version}-%{release} |
154 |
|
155 |
%description mtp |
156 |
This package provides support for reading and writing files on MTP devices, |
157 |
using gvfs. |
158 |
|
159 |
%package goa |
160 |
Summary: GNOME Online Accounts support for gvfs |
161 |
Group: System/Libraries |
162 |
Requires: %{name} = %{version}-%{release} |
163 |
|
164 |
%description goa |
165 |
This package provides seamless integration with gnome-online-accounts |
166 |
file services, using gvfs. |
167 |
|
168 |
%package google |
169 |
Summary: Google Drive support for gvfs |
170 |
Group: System/Libraries |
171 |
Requires: %{name} = %{version}-%{release} |
172 |
Conflicts: gvfs < 1.40.1-4 |
173 |
|
174 |
%description google |
175 |
This package provides seamless integration with Google Drive |
176 |
file services, using gvfs. |
177 |
|
178 |
%prep |
179 |
%autosetup -p1 |
180 |
|
181 |
%build |
182 |
%meson \ |
183 |
-Dgphoto2=%{?with_gphoto2:true}%{?!with_gphoto2:false} \ |
184 |
-Dafc=%{?with_iphone:true}%{?!with_iphone:false} \ |
185 |
-Dmtp=%{?with_mtp:true}%{?!with_mtp:false} \ |
186 |
-Dgoa=%{?with_goa:true}%{?!with_goa:false} \ |
187 |
-Dman=%{?with_man:true}%{?!with_man:false} |
188 |
%meson_build |
189 |
|
190 |
%install |
191 |
%meson_install |
192 |
|
193 |
%find_lang gvfs |
194 |
|
195 |
%post |
196 |
# Reload .mount files: |
197 |
killall -USR1 gvfsd >&/dev/null || : |
198 |
|
199 |
# Reload .mount files when single subpackage is installed: |
200 |
%post archive |
201 |
killall -USR1 gvfsd >&/dev/null || : |
202 |
|
203 |
%post gphoto2 |
204 |
killall -USR1 gvfsd >&/dev/null || : |
205 |
|
206 |
%post iphone |
207 |
killall -USR1 gvfsd >&/dev/null || : |
208 |
|
209 |
%post smb |
210 |
killall -USR1 gvfsd >&/dev/null || : |
211 |
|
212 |
%post mtp |
213 |
killall -USR1 gvfsd >&/dev/null || : |
214 |
|
215 |
%post goa |
216 |
killall -USR1 gvfsd >&/dev/null || : |
217 |
|
218 |
%post google |
219 |
killall -USR1 gvfsd >&/dev/null || : |
220 |
|
221 |
%files -f gvfs.lang |
222 |
%doc README.md NEWS |
223 |
%{_datadir}/dbus-1/services/org.gtk.vfs.Daemon.service |
224 |
%{_datadir}/dbus-1/services/org.gtk.vfs.Metadata.service |
225 |
%{_datadir}/dbus-1/services/org.gtk.vfs.UDisks2VolumeMonitor.service |
226 |
%dir %{_datadir}/gvfs |
227 |
%dir %{_datadir}/gvfs/mounts |
228 |
%{_datadir}/gvfs/mounts/admin.mount |
229 |
%{_datadir}/gvfs/mounts/sftp.mount |
230 |
%{_datadir}/gvfs/mounts/trash.mount |
231 |
%{_datadir}/gvfs/mounts/cdda.mount |
232 |
%{_datadir}/gvfs/mounts/computer.mount |
233 |
%{_datadir}/gvfs/mounts/dav.mount |
234 |
%{_datadir}/gvfs/mounts/dav+sd.mount |
235 |
%{_datadir}/gvfs/mounts/http.mount |
236 |
%{_datadir}/gvfs/mounts/localtest.mount |
237 |
%{_datadir}/gvfs/mounts/dns-sd.mount |
238 |
%{_datadir}/gvfs/mounts/network.mount |
239 |
%{_datadir}/gvfs/mounts/ftp.mount |
240 |
%{_datadir}/gvfs/mounts/ftpis.mount |
241 |
%{_datadir}/gvfs/mounts/recent.mount |
242 |
%{_datadir}/gvfs/mounts/afp-browse.mount |
243 |
%{_datadir}/gvfs/mounts/ftps.mount |
244 |
%{_datadir}/gvfs/mounts/afp.mount |
245 |
%{_datadir}/gvfs/mounts/nfs.mount |
246 |
%{_datadir}/gvfs/mounts/onedrive.mount |
247 |
%{_datadir}/gvfs/mounts/wsdd.mount |
248 |
%dir %{_datadir}/gvfs/remote-volume-monitors |
249 |
%{_datadir}/gvfs/remote-volume-monitors/udisks2.monitor |
250 |
%{_datadir}/glib-2.0/schemas/org.gnome.system.wsdd.gschema.xml |
251 |
%{_datadir}/GConf/gsettings/gvfs-dns-sd.convert |
252 |
%{_datadir}/glib-2.0/schemas/org.gnome.system.dns_sd.gschema.xml |
253 |
%{_datadir}/glib-2.0/schemas/org.gnome.system.gvfs.enums.xml |
254 |
%{_datadir}/polkit-1/actions/org.gtk.vfs.file-operations.policy |
255 |
%{_datadir}/polkit-1/rules.d/org.gtk.vfs.file-operations.rules |
256 |
%if %{with man} |
257 |
%{_mandir}/man7/gvfs.* |
258 |
%{_mandir}/man1/gvfsd.* |
259 |
%{_mandir}/man1/gvfsd-metadata.* |
260 |
%endif |
261 |
%{_libexecdir}/gvfs-udisks2-volume-monitor |
262 |
%{_libexecdir}/gvfsd |
263 |
%{_libexecdir}/gvfsd-admin |
264 |
%{_libexecdir}/gvfsd-ftp |
265 |
%{_libexecdir}/gvfsd-metadata |
266 |
%{_libexecdir}/gvfsd-sftp |
267 |
%{_libexecdir}/gvfsd-trash |
268 |
%{_libexecdir}/gvfsd-cdda |
269 |
%{_libexecdir}/gvfsd-computer |
270 |
%{_libexecdir}/gvfsd-dav |
271 |
%{_libexecdir}/gvfsd-http |
272 |
%{_libexecdir}/gvfsd-localtest |
273 |
%{_libexecdir}/gvfsd-dnssd |
274 |
%{_libexecdir}/gvfsd-network |
275 |
%{_libexecdir}/gvfsd-afp |
276 |
%{_libexecdir}/gvfsd-afp-browse |
277 |
%{_libexecdir}/gvfsd-recent |
278 |
%{_libexecdir}/gvfsd-nfs |
279 |
%{_libexecdir}/gvfsd-onedrive |
280 |
%{_libexecdir}/gvfsd-wsdd |
281 |
%{_libdir}/gvfs/libgvfscommon.so |
282 |
%{_libdir}/gvfs/libgvfsdaemon.so |
283 |
%{_libdir}/gio/modules/libgioremote-volume-monitor.so |
284 |
%{_libdir}/gio/modules/libgvfsdbus.so |
285 |
%{_prefix}/lib/tmpfiles.d/gvfsd-fuse-tmpfiles.conf |
286 |
%{_userunitdir}/gvfs-daemon.service |
287 |
%{_userunitdir}/gvfs-metadata.service |
288 |
%{_userunitdir}/gvfs-udisks2-volume-monitor.service |
289 |
|
290 |
%files fuse |
291 |
%{_libexecdir}/gvfsd-fuse |
292 |
%if %{with man} |
293 |
%{_mandir}/man1/gvfsd-fuse.* |
294 |
%endif |
295 |
|
296 |
%files smb |
297 |
%{_libexecdir}/gvfsd-smb |
298 |
%{_libexecdir}/gvfsd-smb-browse |
299 |
%{_datadir}/gvfs/mounts/smb-browse.mount |
300 |
%{_datadir}/gvfs/mounts/smb.mount |
301 |
%{_datadir}/glib-2.0/schemas/org.gnome.system.smb.gschema.xml |
302 |
%{_datadir}/GConf/gsettings/gvfs-smb.convert |
303 |
|
304 |
%files archive |
305 |
%{_libexecdir}/gvfsd-archive |
306 |
%{_datadir}/gvfs/mounts/archive.mount |
307 |
|
308 |
%if %{with gphoto2} |
309 |
%files gphoto2 |
310 |
%{_libexecdir}/gvfsd-gphoto2 |
311 |
%{_datadir}/gvfs/mounts/gphoto2.mount |
312 |
%{_libexecdir}/gvfs-gphoto2-volume-monitor |
313 |
%{_datadir}/dbus-1/services/org.gtk.vfs.GPhoto2VolumeMonitor.service |
314 |
%{_datadir}/gvfs/remote-volume-monitors/gphoto2.monitor |
315 |
%{_userunitdir}/gvfs-gphoto2-volume-monitor.service |
316 |
%endif |
317 |
|
318 |
%if %{with iphone} |
319 |
%files iphone |
320 |
%{_libexecdir}/gvfs-afc-volume-monitor |
321 |
%{_libexecdir}/gvfsd-afc |
322 |
%{_datadir}/dbus-1/services/org.gtk.vfs.AfcVolumeMonitor.service |
323 |
%{_datadir}/gvfs/mounts/afc.mount |
324 |
%{_datadir}/gvfs/remote-volume-monitors/afc.monitor |
325 |
%{_userunitdir}/gvfs-afc-volume-monitor.service |
326 |
%endif |
327 |
|
328 |
%if %{with mtp} |
329 |
%files mtp |
330 |
%{_libexecdir}/gvfsd-mtp |
331 |
%{_datadir}/gvfs/mounts/mtp.mount |
332 |
%{_libexecdir}/gvfs-mtp-volume-monitor |
333 |
%{_datadir}/dbus-1/services/org.gtk.vfs.MTPVolumeMonitor.service |
334 |
%{_datadir}/gvfs/remote-volume-monitors/mtp.monitor |
335 |
%{_userunitdir}/gvfs-mtp-volume-monitor.service |
336 |
%endif |
337 |
|
338 |
%if %{with goa} |
339 |
%files goa |
340 |
%{_libexecdir}/gvfs-goa-volume-monitor |
341 |
%{_datadir}/dbus-1/services/org.gtk.vfs.GoaVolumeMonitor.service |
342 |
%{_datadir}/gvfs/remote-volume-monitors/goa.monitor |
343 |
%{_userunitdir}/gvfs-goa-volume-monitor.service |
344 |
%endif |
345 |
|
346 |
%files google |
347 |
%{_libexecdir}/gvfsd-google |
348 |
%{_datadir}/gvfs/mounts/google.mount |