/[packages]/cauldron/gvfs/current/SPECS/gvfs.spec
ViewVC logotype

Contents of /cauldron/gvfs/current/SPECS/gvfs.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 75484 - (show annotations) (download)
Tue Mar 22 17:13:16 2011 UTC (13 years, 6 months ago) by ahmad
File size: 7666 byte(s)
SILENT: minor spec cleaning
1 %define name gvfs
2 %define version 1.7.2
3 %define release %mkrel 1
4
5 %define major 0
6 %define libname %mklibname %name %major
7 %define develname %mklibname -d %name
8
9 %define enable_gphoto2 1
10 %define enable_iphone 0
11
12 %define giolibname %mklibname gio2.0_ 0
13
14 Summary: Glib VFS library
15 Name: %{name}
16 Version: %{version}
17 Release: %{release}
18 Source0: ftp://ftp.gnome.org/pub/GNOME/sources/gvfs/1.7/%{name}-%{version}.tar.bz2
19 Source1: bash-completion
20 #gw from Ubuntu, fix music player detection
21 # https://bugs.freedesktop.org/show_bug.cgi?id=24500
22 Patch0: gvfs-music-player-mimetype.patch
23 License: LGPLv2+
24 Group: System/Libraries
25 Url: http://www.gnome.org/
26 BuildRequires: libgudev-devel
27 BuildRequires: libcdio-devel
28 BuildRequires: fuse-devel
29 BuildRequires: libsmbclient-devel
30 BuildRequires: libsoup-devel >= 2.23.91
31 BuildRequires: glib2-devel >= 2.23.4
32 BuildRequires: libarchive-devel
33 BuildRequires: libGConf2-devel
34 BuildRequires: intltool
35 %if %{enable_gphoto2}
36 BuildRequires: gphoto2-devel
37 %endif
38 %if %{enable_iphone}
39 BuildRequires: libimobiledevice-devel >= 1.1.0
40 %endif
41 BuildRequires: libgnome-keyring-devel
42 BuildRequires: avahi-glib-devel
43 BuildRequires: avahi-client-devel
44 BuildRequires: bluez-devel
45 BuildRequires: dbus-glib-devel
46 BuildRequires: expat-devel
47 BuildRequires: gtk-doc
48 BuildRequires: libgdu-devel >= 2.29.0
49 #gw the dbus service depends on the daemon in the library package
50 Requires: %libname = %version
51 Suggests: %name-fuse
52 Suggests: %name-smb
53 Suggests: %name-archive
54 #Suggests: %name-obexftp
55 %if %{enable_gphoto2}
56 Suggests: %name-gphoto2
57 %endif
58
59 %description
60 This is a Virtual File System library based on gio and Glib.
61
62 %package -n %{libname}
63 Group: System/Libraries
64 Summary: Glib VFS library
65 Requires: %name >= %version
66 Requires(post): %giolibname
67 Requires(postun): %giolibname
68
69 %description -n %{libname}
70 This is a Virtual File System library based on gio and Glib.
71
72 %package -n %develname
73 Group: Development/C
74 Summary: Glib VFS Library - development files
75 Requires: %libname = %version
76 Provides: libgvfs-devel = %version-%release
77
78 %description -n %develname
79 This is a Virtual File System library based on gio and Glib.
80
81 %package fuse
82 Summary: FUSE support for gvfs
83 Group: System/Libraries
84 Requires: %{name} = %{version}-%{release}
85 Requires: fuse
86
87 %description fuse
88 This package provides support for applications not using gio
89 to access the gvfs filesystems.
90
91
92 %package smb
93 Summary: Windows fileshare support for gvfs
94 Group: System/Libraries
95 Requires: %{name} = %{version}-%{release}
96
97 %description smb
98 This package provides support for reading and writing files on windows
99 shares (SMB) to applications using gvfs.
100
101 %package archive
102 Summary: Archiving support for gvfs
103 Group: System/Libraries
104 Requires: %{name} = %{version}-%{release}
105
106 %description archive
107 This package provides support for accessing files inside Zip and Tar archives,
108 as well as ISO images, to applications using gvfs.
109
110
111 %package obexftp
112 Summary: ObexFTP support for gvfs
113 Group: System/Libraries
114 Requires: %{name} = %{version}-%{release}
115 Requires: obex-data-server >= 0.3.4-6
116
117 %description obexftp
118 This package provides support for reading files on Bluetooth mobile phones
119 and devices through ObexFTP to applications using gvfs.
120
121 %package gphoto2
122 Summary: gphoto2 support for gvfs
123 Group: System/Libraries
124 Requires: %{name} = %{version}-%{release}
125
126 %description gphoto2
127 This package provides support for reading and writing files on
128 PTP based cameras (Picture Transfer Protocol) and MTP based
129 media players (Media Transfer Protocol) to applications using gvfs.
130
131 %package iphone
132 Summary: iphone support for gvfs
133 Group: System/Libraries
134 Requires: %{name} = %{version}-%{release}
135
136 %description iphone
137 This package provides support for reading and writing files on
138 the iPhone and the iPod TouchP to applications using gvfs.
139
140
141 %prep
142 %setup -q
143 %apply_patches
144
145 %build
146 %configure2_5x --with-dbus-service-dir=%{_datadir}/dbus-1/services \
147 --enable-gdu \
148 %if %{enable_gphoto2}
149 --enable-gphoto2
150 %else
151 --disable-gphoto2
152 %endif
153
154 %make
155
156 %install
157 rm -rf %{buildroot}
158 %makeinstall_std
159
160 rm -f %buildroot%{_libdir}/gio/modules/*.la
161
162 %find_lang gvfs
163
164 # upstream bash completion is installed in the wrong place, with the wrong perms
165 # and redefine system variables without notice
166 rm -f %buildroot%_sysconfdir/profile.d/gvfs-bash-completion.sh
167 install -d -m 755 %buildroot%_sysconfdir/bash_completion.d
168 install -m 644 %{SOURCE1} %buildroot%_sysconfdir/bash_completion.d/%{name}
169
170 %clean
171 rm -rf %{buildroot}
172
173 %post -n %libname
174 %if %_lib != lib
175 %{_bindir}/gio-querymodules-64 %{_libdir}/gio/modules
176 %else
177 %{_bindir}/gio-querymodules-32 %{_libdir}/gio/modules
178 %endif
179
180 %postun -n %libname
181 if [ "$1" = "0" ]; then
182 %if %_lib != lib
183 %{_bindir}/gio-querymodules-64 %{_libdir}/gio/modules
184 %else
185 %{_bindir}/gio-querymodules-32 %{_libdir}/gio/modules
186 %endif
187 fi
188
189 glib-compile-schemas %{_datadir}/glib-2.0/schemas || :
190
191 %posttrans
192 glib-compile-schemas %{_datadir}/glib-2.0/schemas || :
193
194 %files -f gvfs.lang
195 %defattr(-,root,root)
196 %_sysconfdir/bash_completion.d/gvfs
197 %{_bindir}/gvfs-*
198 %{_datadir}/dbus-1/services/gvfs-daemon.service
199 %{_datadir}/dbus-1/services/gvfs-metadata.service
200 %{_datadir}/dbus-1/services/org.gtk.Private.GduVolumeMonitor.service
201 %dir %{_datadir}/gvfs
202 %dir %{_datadir}/gvfs/mounts
203 %dir %{_datadir}/gvfs/remote-volume-monitors
204 %{_datadir}/gvfs/remote-volume-monitors/gdu.monitor
205 %{_datadir}/gvfs/mounts/sftp.mount
206 %{_datadir}/gvfs/mounts/trash.mount
207 %{_datadir}/gvfs/mounts/cdda.mount
208 %{_datadir}/gvfs/mounts/computer.mount
209 %{_datadir}/gvfs/mounts/dav.mount
210 %{_datadir}/gvfs/mounts/dav+sd.mount
211 %{_datadir}/gvfs/mounts/http.mount
212 %{_datadir}/gvfs/mounts/localtest.mount
213 %{_datadir}/gvfs/mounts/burn.mount
214 %{_datadir}/gvfs/mounts/dns-sd.mount
215 %{_datadir}/gvfs/mounts/network.mount
216 %{_datadir}/gvfs/mounts/ftp.mount
217 %{_datadir}/GConf/gsettings/*.convert
218 %{_datadir}/glib-2.0/schemas/*.xml
219
220 %files -n %libname
221 %defattr(-,root,root)
222 %{_libdir}/gio/modules/libgioremote-volume-monitor.so
223 %{_libdir}/gio/modules/libgvfsdbus.so
224 %{_libexecdir}/gvfs-gdu-volume-monitor
225
226 %{_libexecdir}/gvfsd
227 %{_libexecdir}/gvfsd-ftp
228 %{_libexecdir}/gvfsd-metadata
229 %{_libexecdir}/gvfsd-sftp
230 %{_libexecdir}/gvfsd-trash
231 %{_libexecdir}/gvfsd-cdda
232 %{_libexecdir}/gvfsd-computer
233 %{_libexecdir}/gvfsd-dav
234 %{_libexecdir}/gvfsd-http
235 %{_libexecdir}/gvfsd-localtest
236 %{_libexecdir}/gvfsd-burn
237 %{_libexecdir}/gvfsd-dnssd
238 %{_libexecdir}/gvfsd-network
239 %{_libdir}/libgvfscommon.so.%{major}*
240 %{_libdir}/libgvfscommon-dnssd.so.%{major}*
241
242 %files -n %develname
243 %defattr(-,root,root)
244 %doc NEWS ChangeLog AUTHORS TODO
245 %{_libdir}/lib*.so
246 %{_libdir}/lib*.la
247 %_includedir/gvfs-client
248
249 %files fuse
250 %defattr(-, root, root, -)
251 %{_libexecdir}/gvfs-fuse-daemon
252
253
254 %files smb
255 %defattr(-, root, root, -)
256 %{_libexecdir}/gvfsd-smb
257 %{_libexecdir}/gvfsd-smb-browse
258 %{_datadir}/gvfs/mounts/smb-browse.mount
259 %{_datadir}/gvfs/mounts/smb.mount
260
261 %files archive
262 %defattr(-, root, root, -)
263 %{_libexecdir}/gvfsd-archive
264 %{_datadir}/gvfs/mounts/archive.mount
265
266
267 %files obexftp
268 %defattr(-, root, root, -)
269 %{_libexecdir}/gvfsd-obexftp
270 %{_datadir}/gvfs/mounts/obexftp.mount
271
272 %if %{enable_gphoto2}
273 %files gphoto2
274 %defattr(-, root, root, -)
275 %{_libexecdir}/gvfsd-gphoto2
276 %{_datadir}/gvfs/mounts/gphoto2.mount
277 %{_libexecdir}/gvfs-gphoto2-volume-monitor
278 %{_datadir}/dbus-1/services/org.gtk.Private.GPhoto2VolumeMonitor.service
279 %{_datadir}/gvfs/remote-volume-monitors/gphoto2.monitor
280 %endif
281
282 %if %{enable_iphone}
283 %files iphone
284 %defattr(-, root, root, -)
285 %{_libexecdir}/gvfs-afc-volume-monitor
286 %{_libexecdir}/gvfsd-afc
287 %{_datadir}/dbus-1/services/org.gtk.Private.AfcVolumeMonitor.service
288 %{_datadir}/gvfs/mounts/afc.mount
289 %{_datadir}/gvfs/remote-volume-monitors/afc.monitor
290 %endif

  ViewVC Help
Powered by ViewVC 1.1.30