/[packages]/cauldron/gvfs/current/SPECS/gvfs.spec
ViewVC logotype

Contents of /cauldron/gvfs/current/SPECS/gvfs.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 75561 - (show annotations) (download)
Tue Mar 22 19:42:58 2011 UTC (13 years, 6 months ago) by ahmad
File size: 7695 byte(s)
- add BR sqlite3-devel
1 %define name gvfs
2 %define version 1.7.2
3 %define release %mkrel 1
4
5 %define major 0
6 %define libname %mklibname %name %major
7 %define develname %mklibname -d %name
8
9 %define enable_gphoto2 1
10 %define enable_iphone 0
11
12 %define giolibname %mklibname gio2.0_ 0
13
14 Summary: Glib VFS library
15 Name: %{name}
16 Version: %{version}
17 Release: %{release}
18 Source0: ftp://ftp.gnome.org/pub/GNOME/sources/gvfs/1.7/%{name}-%{version}.tar.bz2
19 Source1: bash-completion
20 #gw from Ubuntu, fix music player detection
21 # https://bugs.freedesktop.org/show_bug.cgi?id=24500
22 Patch0: gvfs-music-player-mimetype.patch
23 License: LGPLv2+
24 Group: System/Libraries
25 Url: http://www.gnome.org/
26 BuildRequires: libgudev-devel
27 BuildRequires: libcdio-devel
28 BuildRequires: fuse-devel
29 BuildRequires: libsmbclient-devel
30 BuildRequires: libsoup-devel >= 2.23.91
31 BuildRequires: glib2-devel >= 2.23.4
32 BuildRequires: libarchive-devel
33 BuildRequires: libGConf2-devel
34 BuildRequires: intltool
35 %if %{enable_gphoto2}
36 BuildRequires: gphoto2-devel
37 %endif
38 %if %{enable_iphone}
39 BuildRequires: libimobiledevice-devel >= 1.1.0
40 %endif
41 BuildRequires: libgnome-keyring-devel
42 BuildRequires: avahi-glib-devel
43 BuildRequires: avahi-client-devel
44 BuildRequires: bluez-devel
45 BuildRequires: dbus-glib-devel
46 BuildRequires: expat-devel
47 BuildRequires: gtk-doc
48 BuildRequires: libgdu-devel >= 2.29.0
49 BuildRequires: sqlite3-devel
50 #gw the dbus service depends on the daemon in the library package
51 Requires: %libname = %version
52 Suggests: %name-fuse
53 Suggests: %name-smb
54 Suggests: %name-archive
55 #Suggests: %name-obexftp
56 %if %{enable_gphoto2}
57 Suggests: %name-gphoto2
58 %endif
59
60 %description
61 This is a Virtual File System library based on gio and Glib.
62
63 %package -n %{libname}
64 Group: System/Libraries
65 Summary: Glib VFS library
66 Requires: %name >= %version
67 Requires(post): %giolibname
68 Requires(postun): %giolibname
69
70 %description -n %{libname}
71 This is a Virtual File System library based on gio and Glib.
72
73 %package -n %develname
74 Group: Development/C
75 Summary: Glib VFS Library - development files
76 Requires: %libname = %version
77 Provides: libgvfs-devel = %version-%release
78
79 %description -n %develname
80 This is a Virtual File System library based on gio and Glib.
81
82 %package fuse
83 Summary: FUSE support for gvfs
84 Group: System/Libraries
85 Requires: %{name} = %{version}-%{release}
86 Requires: fuse
87
88 %description fuse
89 This package provides support for applications not using gio
90 to access the gvfs filesystems.
91
92
93 %package smb
94 Summary: Windows fileshare support for gvfs
95 Group: System/Libraries
96 Requires: %{name} = %{version}-%{release}
97
98 %description smb
99 This package provides support for reading and writing files on windows
100 shares (SMB) to applications using gvfs.
101
102 %package archive
103 Summary: Archiving support for gvfs
104 Group: System/Libraries
105 Requires: %{name} = %{version}-%{release}
106
107 %description archive
108 This package provides support for accessing files inside Zip and Tar archives,
109 as well as ISO images, to applications using gvfs.
110
111
112 %package obexftp
113 Summary: ObexFTP support for gvfs
114 Group: System/Libraries
115 Requires: %{name} = %{version}-%{release}
116 Requires: obex-data-server >= 0.3.4-6
117
118 %description obexftp
119 This package provides support for reading files on Bluetooth mobile phones
120 and devices through ObexFTP to applications using gvfs.
121
122 %package gphoto2
123 Summary: gphoto2 support for gvfs
124 Group: System/Libraries
125 Requires: %{name} = %{version}-%{release}
126
127 %description gphoto2
128 This package provides support for reading and writing files on
129 PTP based cameras (Picture Transfer Protocol) and MTP based
130 media players (Media Transfer Protocol) to applications using gvfs.
131
132 %package iphone
133 Summary: iphone support for gvfs
134 Group: System/Libraries
135 Requires: %{name} = %{version}-%{release}
136
137 %description iphone
138 This package provides support for reading and writing files on
139 the iPhone and the iPod TouchP to applications using gvfs.
140
141
142 %prep
143 %setup -q
144 %apply_patches
145
146 %build
147 %configure2_5x --with-dbus-service-dir=%{_datadir}/dbus-1/services \
148 --enable-gdu \
149 %if %{enable_gphoto2}
150 --enable-gphoto2
151 %else
152 --disable-gphoto2
153 %endif
154
155 %make
156
157 %install
158 rm -rf %{buildroot}
159 %makeinstall_std
160
161 rm -f %buildroot%{_libdir}/gio/modules/*.la
162
163 %find_lang gvfs
164
165 # upstream bash completion is installed in the wrong place, with the wrong perms
166 # and redefine system variables without notice
167 rm -f %buildroot%_sysconfdir/profile.d/gvfs-bash-completion.sh
168 install -d -m 755 %buildroot%_sysconfdir/bash_completion.d
169 install -m 644 %{SOURCE1} %buildroot%_sysconfdir/bash_completion.d/%{name}
170
171 %clean
172 rm -rf %{buildroot}
173
174 %post -n %libname
175 %if %_lib != lib
176 %{_bindir}/gio-querymodules-64 %{_libdir}/gio/modules
177 %else
178 %{_bindir}/gio-querymodules-32 %{_libdir}/gio/modules
179 %endif
180
181 %postun -n %libname
182 if [ "$1" = "0" ]; then
183 %if %_lib != lib
184 %{_bindir}/gio-querymodules-64 %{_libdir}/gio/modules
185 %else
186 %{_bindir}/gio-querymodules-32 %{_libdir}/gio/modules
187 %endif
188 fi
189
190 glib-compile-schemas %{_datadir}/glib-2.0/schemas || :
191
192 %posttrans
193 glib-compile-schemas %{_datadir}/glib-2.0/schemas || :
194
195 %files -f gvfs.lang
196 %defattr(-,root,root)
197 %_sysconfdir/bash_completion.d/gvfs
198 %{_bindir}/gvfs-*
199 %{_datadir}/dbus-1/services/gvfs-daemon.service
200 %{_datadir}/dbus-1/services/gvfs-metadata.service
201 %{_datadir}/dbus-1/services/org.gtk.Private.GduVolumeMonitor.service
202 %dir %{_datadir}/gvfs
203 %dir %{_datadir}/gvfs/mounts
204 %dir %{_datadir}/gvfs/remote-volume-monitors
205 %{_datadir}/gvfs/remote-volume-monitors/gdu.monitor
206 %{_datadir}/gvfs/mounts/sftp.mount
207 %{_datadir}/gvfs/mounts/trash.mount
208 %{_datadir}/gvfs/mounts/cdda.mount
209 %{_datadir}/gvfs/mounts/computer.mount
210 %{_datadir}/gvfs/mounts/dav.mount
211 %{_datadir}/gvfs/mounts/dav+sd.mount
212 %{_datadir}/gvfs/mounts/http.mount
213 %{_datadir}/gvfs/mounts/localtest.mount
214 %{_datadir}/gvfs/mounts/burn.mount
215 %{_datadir}/gvfs/mounts/dns-sd.mount
216 %{_datadir}/gvfs/mounts/network.mount
217 %{_datadir}/gvfs/mounts/ftp.mount
218 %{_datadir}/GConf/gsettings/*.convert
219 %{_datadir}/glib-2.0/schemas/*.xml
220
221 %files -n %libname
222 %defattr(-,root,root)
223 %{_libdir}/gio/modules/libgioremote-volume-monitor.so
224 %{_libdir}/gio/modules/libgvfsdbus.so
225 %{_libexecdir}/gvfs-gdu-volume-monitor
226
227 %{_libexecdir}/gvfsd
228 %{_libexecdir}/gvfsd-ftp
229 %{_libexecdir}/gvfsd-metadata
230 %{_libexecdir}/gvfsd-sftp
231 %{_libexecdir}/gvfsd-trash
232 %{_libexecdir}/gvfsd-cdda
233 %{_libexecdir}/gvfsd-computer
234 %{_libexecdir}/gvfsd-dav
235 %{_libexecdir}/gvfsd-http
236 %{_libexecdir}/gvfsd-localtest
237 %{_libexecdir}/gvfsd-burn
238 %{_libexecdir}/gvfsd-dnssd
239 %{_libexecdir}/gvfsd-network
240 %{_libdir}/libgvfscommon.so.%{major}*
241 %{_libdir}/libgvfscommon-dnssd.so.%{major}*
242
243 %files -n %develname
244 %defattr(-,root,root)
245 %doc NEWS ChangeLog AUTHORS TODO
246 %{_libdir}/lib*.so
247 %{_libdir}/lib*.la
248 %_includedir/gvfs-client
249
250 %files fuse
251 %defattr(-, root, root, -)
252 %{_libexecdir}/gvfs-fuse-daemon
253
254
255 %files smb
256 %defattr(-, root, root, -)
257 %{_libexecdir}/gvfsd-smb
258 %{_libexecdir}/gvfsd-smb-browse
259 %{_datadir}/gvfs/mounts/smb-browse.mount
260 %{_datadir}/gvfs/mounts/smb.mount
261
262 %files archive
263 %defattr(-, root, root, -)
264 %{_libexecdir}/gvfsd-archive
265 %{_datadir}/gvfs/mounts/archive.mount
266
267
268 %files obexftp
269 %defattr(-, root, root, -)
270 %{_libexecdir}/gvfsd-obexftp
271 %{_datadir}/gvfs/mounts/obexftp.mount
272
273 %if %{enable_gphoto2}
274 %files gphoto2
275 %defattr(-, root, root, -)
276 %{_libexecdir}/gvfsd-gphoto2
277 %{_datadir}/gvfs/mounts/gphoto2.mount
278 %{_libexecdir}/gvfs-gphoto2-volume-monitor
279 %{_datadir}/dbus-1/services/org.gtk.Private.GPhoto2VolumeMonitor.service
280 %{_datadir}/gvfs/remote-volume-monitors/gphoto2.monitor
281 %endif
282
283 %if %{enable_iphone}
284 %files iphone
285 %defattr(-, root, root, -)
286 %{_libexecdir}/gvfs-afc-volume-monitor
287 %{_libexecdir}/gvfsd-afc
288 %{_datadir}/dbus-1/services/org.gtk.Private.AfcVolumeMonitor.service
289 %{_datadir}/gvfs/mounts/afc.mount
290 %{_datadir}/gvfs/remote-volume-monitors/afc.monitor
291 %endif

  ViewVC Help
Powered by ViewVC 1.1.30