/[packages]/cauldron/iec16022/current/SPECS/iec16022.spec
ViewVC logotype

Contents of /cauldron/iec16022/current/SPECS/iec16022.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 73285 - (show annotations) (download)
Thu Mar 17 17:19:46 2011 UTC (13 years, 8 months ago) by wally
File size: 1711 byte(s)
- fix group tag
1 # TODO: shared lib calls exit
2
3 %define name iec16022
4 %define version 0.2.4
5 %define rel 2
6
7 %define major 0
8 %define libname %mklibname %{name}_ %{major}
9 %define devname %mklibname %{name} -d
10
11 Name: %{name}
12 Version: %{version}
13 Release: %mkrel %{rel}
14 Summary: Generate ISO/IEC 16022 2D barcodes
15 Group: Graphics
16 License: GPLv2+
17 URL: http://www.datenfreihafen.org/projects/iec16022.html
18 Source0: http://www.datenfreihafen.org/~stefan/iec16022/%{name}-%{version}.tar.gz
19 Patch0: %{name}-%{version}-test-suite-fix.patch
20
21 BuildRequires: popt-devel
22 BuildRequires: zlib-devel
23
24 %description
25 iec16022 is a program for producing ISO/IEC 16022 2D barcodes, also
26 known as Data Matrix. These barcodes are defined in the ISO/IEC 16022
27 standard.
28
29 %package -n %{libname}
30 Summary: ISO/IEC 16022 libraries
31 Group: System/Libraries
32
33 %description -n %{libname}
34 Shared libraries for %{name}.
35
36 %package -n %{devname}
37 Summary: ISO/IEC 16022 development files
38 Group: Development/C
39
40 %description -n %{devname}
41 Development files for %{name}.
42
43 %prep
44 %setup -q
45 %patch0 -p1 -b .orig
46
47 %build
48 %configure2_5x --disable-static
49 %make
50
51 %install
52 rm -rf %{buildroot}
53 %makeinstall_std
54
55 #we don't want these
56 rm -f %{buildroot}%{_libdir}/libiec16022.la
57
58 %check
59 export LD_LIBRARY_PATH=%{buildroot}%{_libdir}
60 %make -C test check
61
62 %clean
63 rm -rf %{buildroot}
64
65 %files
66 %defattr(-,root,root)
67 %{_bindir}/iec16022
68 %{_mandir}/man1/iec16022.1*
69
70 %files -n %{libname}
71 %defattr(-,root,root)
72 %doc AUTHORS ChangeLog README TODO
73 %{_libdir}/libiec16022.so.%{major}*
74
75 %files -n %{devname}
76 %defattr(-,root,root)
77 %{_includedir}/iec16022/
78 %{_libdir}/libiec16022.so
79 %{_libdir}/pkgconfig/libiec16022.pc

  ViewVC Help
Powered by ViewVC 1.1.30