1 |
dmorgan |
501201 |
%global namedreltag .Final |
2 |
gil |
216156 |
%global namedversion %{version}%{?namedreltag} |
3 |
|
|
|
4 |
pterjan |
805022 |
# Use this switch to rebuild without infinispan |
5 |
|
|
# This is useful to break the infinispan circular dependency |
6 |
|
|
%define with_infinispan 1 |
7 |
|
|
|
8 |
pterjan |
806362 |
# Does not build |
9 |
|
|
# org.infinispan.lucene.impl.InfinispanIndexInputV4 is not abstract and does not override abstract method slice(java.lang.String,long,long) in org.apache.lucene.store.IndexInput |
10 |
|
|
%define with_lucene4 0 |
11 |
|
|
|
12 |
dmorgan |
291804 |
Name: infinispan |
13 |
pterjan |
805022 |
Version: 6.0.2 |
14 |
pterjan |
806358 |
Release: %mkrel 2 |
15 |
dmorgan |
563584 |
Group: Development/Java |
16 |
dmorgan |
291804 |
Summary: Data grid platform |
17 |
|
|
License: LGPLv2+ |
18 |
|
|
URL: http://www.jboss.org/infinispan |
19 |
dmorgan |
501201 |
Source0: https://github.com/infinispan/infinispan/archive/%{namedversion}.tar.gz |
20 |
dmorgan |
291804 |
|
21 |
dmorgan |
501201 |
Patch0: 0001-Avro-1.6.2-support.patch |
22 |
pterjan |
805022 |
Patch1: 0002-ISPN-3974-Make-it-compile-with-JDK8.patch |
23 |
gil |
216171 |
|
24 |
dmorgan |
291804 |
BuildArch: noarch |
25 |
gil |
216156 |
|
26 |
dmorgan |
563599 |
BuildRequires: aesh |
27 |
dmorgan |
291804 |
BuildRequires: apache-commons-math |
28 |
dmorgan |
501201 |
BuildRequires: apache-commons-pool |
29 |
dmorgan |
291804 |
BuildRequires: avro |
30 |
|
|
BuildRequires: c3p0 |
31 |
|
|
BuildRequires: jcip-annotations |
32 |
|
|
BuildRequires: jboss-logging-tools |
33 |
pterjan |
805022 |
BuildRequires: jboss-parent |
34 |
dmorgan |
291804 |
BuildRequires: jboss-marshalling |
35 |
|
|
BuildRequires: jboss-naming |
36 |
|
|
BuildRequires: jboss-transaction-1.1-api |
37 |
dmorgan |
501201 |
BuildRequires: jgroups |
38 |
|
|
BuildRequires: geronimo-jpa |
39 |
|
|
BuildRequires: xstream |
40 |
|
|
BuildRequires: narayana |
41 |
|
|
BuildRequires: maven-local |
42 |
dmorgan |
291804 |
BuildRequires: maven-enforcer-plugin |
43 |
|
|
BuildRequires: maven-plugin-exec |
44 |
|
|
BuildRequires: maven-resources-plugin |
45 |
|
|
BuildRequires: maven-remote-resources-plugin |
46 |
|
|
BuildRequires: staxmapper |
47 |
dmorgan |
501201 |
BuildRequires: antlr3-java |
48 |
|
|
BuildRequires: maven-failsafe-plugin |
49 |
|
|
BuildRequires: maven-invoker-plugin |
50 |
pterjan |
806358 |
|
51 |
|
|
BuildRequires: lucene3 |
52 |
|
|
BuildRequires: lucene3-contrib |
53 |
|
|
|
54 |
pterjan |
806362 |
%if %{with_lucene4} |
55 |
dmorgan |
501201 |
BuildRequires: lucene |
56 |
|
|
BuildRequires: lucene-contrib |
57 |
pterjan |
806362 |
%endif |
58 |
pterjan |
806358 |
|
59 |
dmorgan |
501201 |
BuildRequires: maven-dependency-plugin |
60 |
dmorgan |
563522 |
BuildRequires: maven-plugin-bundle |
61 |
pterjan |
806362 |
BuildRequires: hibernate-search >= 4.5.1-2 |
62 |
dmorgan |
563599 |
BuildRequires: hibernate-hql |
63 |
|
|
BuildRequires: protostream |
64 |
|
|
BuildRequires: gnu-getopt |
65 |
gil |
216171 |
|
66 |
pterjan |
805022 |
%if %{with_infinispan} |
67 |
|
|
BuildRequires: infinispan |
68 |
|
|
%endif |
69 |
|
|
|
70 |
gil |
216156 |
%description |
71 |
|
|
Infinispan is an extremely scalable, highly available data grid |
72 |
|
|
platform - 100% open source, and written in Java. The purpose of |
73 |
|
|
Infinispan is to expose a data structure that is highly concurrent, |
74 |
|
|
designed ground-up to make the most of modern multi-processor/multi-core |
75 |
|
|
architectures while at the same time providing distributed cache |
76 |
|
|
capabilities. At its core Infinispan exposes a Cache interface which |
77 |
|
|
extends java.util.Map. It is also optionally is backed by a peer-to-peer |
78 |
|
|
network architecture to distribute state efficiently around a data grid. |
79 |
|
|
|
80 |
|
|
%package javadoc |
81 |
dmorgan |
291804 |
Summary: Javadocs for %{name} |
82 |
gil |
216156 |
|
83 |
|
|
%description javadoc |
84 |
|
|
This package contains the API documentation for %{name}. |
85 |
|
|
|
86 |
|
|
%prep |
87 |
|
|
%setup -q -n %{name}-%{namedversion} |
88 |
dmorgan |
501201 |
|
89 |
gil |
216156 |
%patch0 -p1 |
90 |
pterjan |
805022 |
%patch1 -p1 |
91 |
gil |
216156 |
|
92 |
dmorgan |
291804 |
# Rename the license file |
93 |
|
|
cp -r license/src/main/resources/META-INF/LICENSE.txt.vm LICENSE.txt |
94 |
gil |
216171 |
|
95 |
dmorgan |
501201 |
# Disable unnecessary at this point modules |
96 |
dmorgan |
563599 |
%pom_disable_module extended-statistics |
97 |
dmorgan |
501201 |
%pom_disable_module tools |
98 |
|
|
%pom_disable_module tree |
99 |
pterjan |
806362 |
%if ! %{with_lucene4} |
100 |
|
|
%pom_disable_module lucene/lucene-v4 |
101 |
|
|
%endif |
102 |
dmorgan |
501201 |
%pom_disable_module server |
103 |
|
|
%pom_disable_module server/core |
104 |
|
|
%pom_disable_module server/memcached |
105 |
|
|
%pom_disable_module server/hotrod |
106 |
|
|
%pom_disable_module server/websocket |
107 |
|
|
%pom_disable_module server/rest |
108 |
|
|
%pom_disable_module cli/cli-server |
109 |
|
|
%pom_disable_module rhq-plugin |
110 |
|
|
%pom_disable_module spring |
111 |
|
|
%pom_disable_module demos/gui |
112 |
|
|
%pom_disable_module demos/ec2 |
113 |
|
|
%pom_disable_module demos/distexec |
114 |
|
|
%pom_disable_module demos/ec2-ui |
115 |
|
|
%pom_disable_module demos/directory |
116 |
|
|
%pom_disable_module demos/lucene-directory-demo |
117 |
|
|
%pom_disable_module demos/gridfs-webdav |
118 |
|
|
%pom_disable_module demos/nearcache |
119 |
|
|
%pom_disable_module demos/nearcache-client |
120 |
|
|
%pom_disable_module cdi/extension |
121 |
dmorgan |
563599 |
%pom_disable_module integrationtests/luceneintegration |
122 |
|
|
%pom_disable_module remote-query/remote-query-server |
123 |
pterjan |
805022 |
%pom_disable_module persistence/leveldb |
124 |
|
|
%pom_disable_module persistence/rest |
125 |
|
|
%pom_disable_module server/integration |
126 |
dmorgan |
563599 |
|
127 |
|
|
# Remove the 5.2.x migration support |
128 |
|
|
rm persistence/remote/src/main/java/org/infinispan/persistence/remote/upgrade/HotRodTargetMigrator.java |
129 |
|
|
%pom_remove_dep ":infinispan-adaptor52x" persistence/remote |
130 |
|
|
%pom_disable_module compatibility52x |
131 |
pterjan |
805022 |
|
132 |
dmorgan |
563599 |
%pom_disable_module compatibility52x/adaptor52x |
133 |
|
|
%pom_disable_module compatibility52x/custom52x-store |
134 |
|
|
%pom_disable_module compatibility52x/cli-migrator52x |
135 |
|
|
|
136 |
dmorgan |
501201 |
%pom_disable_module as-modules |
137 |
|
|
%pom_disable_module jcache |
138 |
gil |
216156 |
|
139 |
pterjan |
805022 |
%if !%{with_infinispan} |
140 |
|
|
%pom_disable_module query |
141 |
|
|
%endif |
142 |
|
|
|
143 |
dmorgan |
563522 |
%pom_remove_dep "org.jboss.arquillian:arquillian-bom" parent/pom.xml |
144 |
|
|
%pom_remove_dep "org.jboss.shrinkwrap.resolver:shrinkwrap-resolver-bom" parent/pom.xml |
145 |
gil |
216156 |
|
146 |
dmorgan |
563522 |
%pom_remove_plugin ":maven-remote-resources-plugin" parent/pom.xml |
147 |
gil |
216156 |
|
148 |
dmorgan |
563522 |
%pom_xpath_remove "pom:dependencies/pom:dependency[pom:scope = 'test']/pom:scope" lucene/lucene-directory/pom.xml |
149 |
gil |
216156 |
|
150 |
pterjan |
806362 |
%if ! %{with_lucene4} |
151 |
|
|
# Lucene 4 is unavailable |
152 |
|
|
%pom_remove_dep ":infinispan-lucene-v4" lucene/lucene-directory/pom.xml |
153 |
|
|
%pom_remove_dep ":infinispan-lucene-v4" parent/pom.xml |
154 |
|
|
%pom_xpath_remove "pom:build/pom:plugins/pom:plugin[pom:artifactId = 'maven-dependency-plugin']/pom:executions/pom:execution/pom:configuration/pom:artifactItems/pom:artifactItem[pom:artifactId = 'infinispan-lucene-v4']" lucene/lucene-directory/pom.xml |
155 |
|
|
%endif |
156 |
|
|
|
157 |
dmorgan |
563599 |
%pom_remove_plugin ":animal-sniffer-maven-plugin" parent/pom.xml |
158 |
dmorgan |
563522 |
|
159 |
|
|
# Support for JGroups 3.4.0 |
160 |
|
|
sed -i "s|SiteUUID.getSiteName(src.getSite())|src.getSite()|" core/src/main/java/org/infinispan/xsite/BackupReceiverRepositoryImpl.java |
161 |
|
|
|
162 |
pterjan |
806358 |
# Use lucene3 compat package |
163 |
|
|
sed -i "s|version.lucene.v3>3.6.2<|version.lucene.v3>3<|" parent/pom.xml |
164 |
|
|
|
165 |
dmorgan |
563522 |
# TMP |
166 |
|
|
sed -i "s|error|first|" lucene/lucene-directory/pom.xml |
167 |
|
|
|
168 |
dmorgan |
563599 |
%pom_remove_dep "org.scala-lang:scala-library" server/pom.xml |
169 |
|
|
%pom_remove_plugin "org.scala-tools:maven-scala-plugin" server/core/pom.xml |
170 |
|
|
|
171 |
pterjan |
805022 |
%pom_remove_dep "org.jboss.as:jboss-as-parent" server/integration/versions/pom.xml |
172 |
|
|
%pom_remove_plugin ":animal-sniffer-maven-plugin" server/integration/versions/pom.xml |
173 |
|
|
|
174 |
dmorgan |
501201 |
%build |
175 |
|
|
%mvn_build -f |
176 |
dmorgan |
291804 |
|
177 |
dmorgan |
501201 |
%install |
178 |
|
|
%mvn_install |
179 |
dmorgan |
291804 |
|
180 |
dmorgan |
501201 |
%files -f .mfiles |
181 |
|
|
%dir %{_javadir}/%{name} |
182 |
dmorgan |
563599 |
%doc LICENSE.txt README.md |
183 |
gil |
216156 |
|
184 |
dmorgan |
501201 |
%files javadoc -f .mfiles-javadoc |
185 |
dmorgan |
291804 |
%doc LICENSE.txt |
186 |
|
|
|