/[packages]/cauldron/java-gnome/current/SPECS/java-gnome.spec
ViewVC logotype

Contents of /cauldron/java-gnome/current/SPECS/java-gnome.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 130304 - (show annotations) (download)
Thu Jul 28 20:20:58 2011 UTC (12 years, 9 months ago) by dmorgan
File size: 2838 byte(s)
imported package java-gnome
1 Summary: Java GNOME bindings
2 Name: java-gnome
3 Version: 4.1.1
4 Release: %mkrel 1
5 URL: http://java-gnome.sourceforge.net
6 Source0: http://ftp.gnome.org/pub/gnome/sources/java-gnome/4.0/java-gnome-%{version}.tar.xz
7 # This is the "Classpath" exception.
8 License: GPLv2 with exceptions
9 Group: Development/Java
10 BuildRequires: pkgconfig
11 BuildRequires: pkgconfig(atk)
12 BuildRequires: pkgconfig(cairo-svg)
13 BuildRequires: pkgconfig(enchant)
14 BuildRequires: pkgconfig(gdk-3.0)
15 BuildRequires: pkgconfig(glib-2.0)
16 BuildRequires: pkgconfig(gtk+-3.0)
17 BuildRequires: pkgconfig(gtk+-unix-print-3.0)
18 BuildRequires: pkgconfig(gtksourceview-3.0)
19 BuildRequires: pkgconfig(gtkspell-2.0)
20 BuildRequires: pkgconfig(libnotify)
21 BuildRequires: pkgconfig(pango)
22 BuildRequires: pkgconfig(unique-3.0)
23 BuildRequires: pkgconfig(librsvg-2.0)
24 BuildRequires: gettext
25 BuildRequires: junit
26 BuildRequires: python
27 BuildRequires: java-devel >= 1:1.6.0
28 BuildRequires: jpackage-utils
29 Requires: java >= 1:1.6.0
30 Requires: jpackage-utils
31
32 %description
33 These are the Java bindings for GTK and GNOME! Featuring a robust
34 engineering design, completely generated internals, a lovingly
35 crafted layer presenting the public API, and steadily increasing
36 coverage of the underlying libraries.
37
38 You can use java-gnome to develop sophisticated user interfaces
39 for Linux applications so that they richly integrate with the
40 GNOME Desktop while leveraging the power of the Java language
41 and your expertise with it.
42
43 %package javadoc
44 Summary: Javadoc for %{name}
45 Group: Development/Java
46 Requires: %{name} = %{version}-%{release}
47 Requires: jpackage-utils
48 BuildArch: noarch
49
50 %description javadoc
51 This package contains the API documentation for %{name}, along with
52 design documentation and sample code.
53
54 %prep
55 %setup -q
56
57 if find -name '*.class' -o -name '*.jar' | grep . >&2; then
58 echo >&2 "Prebuilt binaries found in the sources. See https://fedoraproject.org/wiki/Packaging:Java#Pre-built_JAR_files_.2F_Other_bundled_software for instructions."
59 exit 1
60 fi
61
62 %build
63 # It'll get two conflicting --libdir parameters, but the last one
64 # happens to win which is what we want.
65 %configure --jardir=%{_libdir}/%{name} --libdir=%{_libdir}/%{name}
66
67 # The build system does not support parallell builds, so no
68 # _smp_mflags.
69 make V=1 build-java doc
70
71 %install
72 rm -rf %{buildroot}
73
74 mkdir -p %{buildroot}%{_javadir}
75 make install DESTDIR=%{buildroot}
76
77 mkdir -p %{buildroot}%{_javadocdir}
78 cp -rp doc/api %{buildroot}%{_javadocdir}/%{name}-%{version}
79 ln -s %{name}-%{version} %{buildroot}%{_javadocdir}/%{name}
80
81 %files
82 %doc README NEWS LICENCE
83 %dir %{_libdir}/%{name}
84 %{_libdir}/%{name}/*.jar
85 %{_libdir}/%{name}/*.so
86
87 %files javadoc
88 # Note that not all here is javadoc. Two subpackages for documentation
89 # seems silly.
90 %doc doc/design doc/examples
91 %{_javadocdir}/%{name}
92 %{_javadocdir}/%{name}-%{version}
93

  ViewVC Help
Powered by ViewVC 1.1.30