1 |
neoclust |
989211 |
%global mod_name ssh-credentials-plugin |
2 |
|
|
%global short_name ssh-credentials |
3 |
|
|
%global plugin_home %{_datadir}/jenkins/webroot/WEB-INF/plugins/ |
4 |
|
|
|
5 |
|
|
Name: jenkins-ssh-credentials-plugin |
6 |
|
|
Version: 1.11 |
7 |
|
|
Release: %mkrel 4 |
8 |
|
|
Group: Development/Java |
9 |
|
|
Summary: Jenkins SSH Credentials Plugin |
10 |
|
|
|
11 |
|
|
License: MIT |
12 |
|
|
URL: https://github.com/jenkinsci/ssh-credentials-plugin |
13 |
|
|
Source0: https://github.com/jenkinsci/%{mod_name}/archive/%{short_name}-%{version}.tar.gz |
14 |
|
|
|
15 |
|
|
Patch0: implement-missing-method.patch |
16 |
|
|
|
17 |
|
|
BuildRequires: maven-local |
18 |
|
|
BuildRequires: mvn(com.jcraft:jsch) |
19 |
|
|
BuildRequires: mvn(junit:junit) |
20 |
|
|
BuildRequires: mvn(net.jcip:jcip-annotations) |
21 |
|
|
BuildRequires: mvn(org.apache.maven.plugins:maven-release-plugin) |
22 |
|
|
BuildRequires: mvn(org.apache.sshd:sshd-core) |
23 |
|
|
BuildRequires: mvn(org.jenkins-ci.plugins:credentials) |
24 |
|
|
BuildRequires: mvn(org.jenkins-ci.plugins:plugin:pom:) |
25 |
|
|
BuildRequires: mvn(org.jenkins-ci.tools:maven-hpi-plugin) |
26 |
|
|
BuildRequires: mvn(org.slf4j:slf4j-api) |
27 |
|
|
BuildRequires: mvn(org.slf4j:slf4j-jdk14) |
28 |
|
|
BuildRequires: mvn(org.kohsuke:access-modifier-checker) |
29 |
|
|
BuildRequires: mvn(org.jenkins-ci.main:jenkins-core) |
30 |
|
|
BuildRequires: mvn(com.google.code.findbugs:annotations) |
31 |
|
|
|
32 |
|
|
BuildRequires: zip |
33 |
|
|
|
34 |
|
|
BuildArch: noarch |
35 |
|
|
|
36 |
|
|
%description |
37 |
|
|
This package provides Jenkins SSH credentials plugin. |
38 |
|
|
|
39 |
|
|
%package javadoc |
40 |
|
|
Summary: Javadoc for %{name} |
41 |
|
|
|
42 |
|
|
%description javadoc |
43 |
|
|
This package contains the API documentation for %{name}. |
44 |
|
|
|
45 |
|
|
%prep |
46 |
|
|
%setup -q -n %{mod_name}-%{short_name}-%{version} |
47 |
|
|
|
48 |
wally |
2094259 |
%patch -P 0 -p1 |
49 |
neoclust |
989211 |
|
50 |
|
|
%pom_add_dep net.jcip:jcip-annotations |
51 |
|
|
%pom_add_dep com.google.code.findbugs:annotations::provided |
52 |
|
|
%mvn_file ::hpi:: %{name}/%{short_name} |
53 |
|
|
|
54 |
|
|
%build |
55 |
|
|
# missing dep org.codehaus.mojo:findbugs-maven-plugin |
56 |
|
|
%mvn_build -f |
57 |
|
|
|
58 |
|
|
%install |
59 |
|
|
install -d -m 755 %{buildroot}/%{plugin_home} |
60 |
|
|
unzip -d target/%{short_name}.hpi-unpacked target/%{short_name}.hpi |
61 |
|
|
pushd target/%{short_name}.hpi-unpacked/WEB-INF/lib/ |
62 |
|
|
rm %{short_name}.jar && ln -s %{_javadir}/%{name}/%{short_name}.jar . |
63 |
|
|
xmvn-subst -s . |
64 |
|
|
popd |
65 |
|
|
pushd target/%{short_name}.hpi-unpacked/ |
66 |
|
|
zip -y -r %{short_name}.hpi . |
67 |
|
|
popd |
68 |
|
|
mv target/%{short_name}.hpi-unpacked/%{short_name}.hpi target/ |
69 |
|
|
cp target/%{short_name}.hpi %{buildroot}/%{plugin_home}/ |
70 |
|
|
%mvn_install |
71 |
|
|
|
72 |
|
|
%files -f .mfiles |
73 |
|
|
%dir %{_javadir}/%{name} |
74 |
|
|
%dir %{_mavenpomdir}/%{name} |
75 |
|
|
%{plugin_home} |
76 |
|
|
%doc LICENSE.txt |
77 |
|
|
%files javadoc -f .mfiles-javadoc |
78 |
|
|
%doc LICENSE.txt |
79 |
|
|
|