/[packages]/cauldron/kipi-plugins/current/SPECS/kipi-plugins.spec
ViewVC logotype

Contents of /cauldron/kipi-plugins/current/SPECS/kipi-plugins.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 53456 - (show annotations) (download)
Fri Feb 18 02:35:05 2011 UTC (13 years, 4 months ago) by mikala
File size: 3037 byte(s)
Update to 1.8.0
- Remove buildroot
- Drop some redundant BR

1 Name: kipi-plugins
2 Version: 1.8.0
3 Release: %mkrel 1
4 Summary: KDE image Interface Plugins
5 License: GPLv2+
6 Group: System/Libraries
7 Source0: http://downloads.sourceforge.net/kipi/%{name}-%{version}.tar.bz2
8 URL: http://www.kipi-plugins.org
9 Epoch: 1
10 Requires: mjpegtools
11 Requires: vorbis-tools
12 Requires: mpg123
13 Requires: imagemagick >= 5.5.4
14 Suggests: hugin
15 BuildRequires: kdepimlibs4-devel
16 BuildRequires: libkipi-devel
17 BuildRequires: libgpod-devel
18 BuildRequires: kdegraphics4-devel
19 BuildRequires: tiff-devel
20 BuildRequires: libMagick-devel
21 BuildRequires: libxslt-devel
22 BuildRequires: libgphoto-devel
23 BuildRequires: imlib2-devel
24 BuildRequires: libxml2-utils
25 BuildRequires: libmesaglu-devel
26 BuildRequires: opencv-devel
27 Obsoletes: %{_lib}kipi-plugins0 < 1:0.2.0-0.824094.3
28
29 %description
30 The library of the KDE Image Plugin Interface.
31
32 Libkipi allows image applications to use a plugin architecture
33 for additional functionality such as: RawConverter, SlideShow,
34 ImagesGallery, HTMLExport, PrintAssistant...
35
36 %files -f %name.lang
37 %defattr(-,root,root)
38 %doc README
39 %{_kde_bindir}/dngconverter
40 %{_kde_bindir}/scangui
41 %{_kde_bindir}/expoblending
42 %{_kde_datadir}/apps/*
43 %{_kde_libdir}/kde4/kipiplugin_*
44 %{_kde_iconsdir}/*/*/*/*
45 %{_kde_datadir}/kde4/services/kipiplugin_*
46
47 #----------------------------------------------------------------------------
48
49 %define kipiplugins_major 1
50 %define lib_name %mklibname kipiplugins %kipiplugins_major
51
52 %package -n %lib_name
53 Summary: Library files for %{name}
54 Group: System/Libraries
55 Requires: %{name} = %{epoch}:%{version}-%{release}
56 Conflicts: %{_lib}kipi-plugins0
57
58 %description -n %lib_name
59 Library files for %{name}
60
61 %files -n %lib_name
62 %defattr(-,root,root)
63 %{_kde_libdir}/libkipiplugins.so.%{kipiplugins_major}*
64
65 #----------------------------------------------------------------------------
66
67 %package devel
68 Summary: Development files for %{name}
69 Group: Development/C
70 Requires: %{lib_name} = %{epoch}:%{version}-%{release}
71 Obsoletes: %{_lib}kipi-plugins-devel < 1:0.2.0
72
73 %description devel
74 Development files for %{name}
75
76 %files devel
77 %defattr(-,root,root)
78 %{_kde_libdir}/*.so
79
80 #----------------------------------------------------------------------------
81
82 %prep
83 %setup -q -n %{name}-%{version}
84
85 %build
86 %cmake_kde4
87 %make
88
89 %install
90 rm -rf %buildroot
91 %makeinstall_std -C build
92
93 install -d %{buildroot}/%{_kde_datadir}/doc/%{name}/htmlexport/
94 install -d %{buildroot}/%{_kde_datadir}/doc/%{name}/printimages/
95 install -m644 %{buildroot}/%{_kde_datadir}/apps/kipiplugin_htmlexport/THEME_HOWTO -D %{buildroot}/%{_kde_datadir}/doc/%{name}/htmlexport/THEME_HOWTO
96 install -m644 %{buildroot}/%{_kde_datadir}/apps/kipiplugin_printimages/TEMPLATE_HOWTO -D %{buildroot}/%{_kde_datadir}/doc/%{name}/printimages/TEMPLATE_HOWTO
97
98 #removing wrong files
99 rm -f %{buildroot}/%{_kde_datadir}/apps/kipiplugin_htmlexport/THEME_HOWTO
100 rm -f %{buildroot}/%{_kde_datadir}/apps/kipiplugin_printimages/TEMPLATE_HOWTO
101 rm -f %{buildroot}/%{_kde_datadir}/applications/kde4/*.desktop
102
103 %find_lang %name --all-name
104
105 %clean
106 rm -rf %buildroot

  ViewVC Help
Powered by ViewVC 1.1.30