/[packages]/cauldron/laf-widget/current/SPECS/laf-widget.spec
ViewVC logotype

Contents of /cauldron/laf-widget/current/SPECS/laf-widget.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 132628 - (show annotations) (download)
Wed Aug 10 21:21:45 2011 UTC (12 years, 8 months ago) by dmorgan
File size: 3180 byte(s)
imported package laf-widget
1 # Copyright (c) 2000-2010, JPackage Project
2 # All rights reserved.
3 #
4 # Redistribution and use in source and binary forms, with or without
5 # modification, are permitted provided that the following conditions
6 # are met:
7 #
8 # 1. Redistributions of source code must retain the above copyright
9 # notice, this list of conditions and the following disclaimer.
10 # 2. Redistributions in binary form must reproduce the above copyright
11 # notice, this list of conditions and the following disclaimer in the
12 # documentation and/or other materials provided with the
13 # distribution.
14 # 3. Neither the name of the JPackage Project nor the names of its
15 # contributors may be used to endorse or promote products derived
16 # from this software without specific prior written permission.
17 #
18 # THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
19 # "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
20 # LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
21 # A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
22 # OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
23 # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
24 # LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
25 # DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
26 # THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
27 # (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
28 # OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
29 #
30
31 Name: laf-widget
32 Version: 4.3
33 Release: %mkrel 1
34 Summary: Support for common "feel" widgets in look-and-feel libraries
35
36 Group: Development/Java
37 License: BSD and zlib
38 URL: https://laf-widget.dev.java.net/
39 Source0: https://laf-widget.dev.java.net/files/documents/5097/135952/laf-widget-all.zip
40 Patch0: laf-widget-build.patch
41
42 BuildArch: noarch
43
44 BuildRequires: java-devel >= 0:1.6.0
45 BuildRequires: jpackage-utils
46 BuildRequires: ant >= 0:1.7.1
47 BuildRequires: asm2
48
49 Requires: java >= 0:1.6.0
50 Requires: jpackage-utils
51 Requires: asm2
52
53 %description
54 The goal of this project is to provide support for and base
55 set of additional behaviour and widgets in look-and-feels.
56
57 %package javadoc
58 Summary: Javadoc for %{name}
59 Group: Development/Java
60
61 %description javadoc
62 %{summary}.
63
64 %prep
65 %setup -q -c %{name}-%{version}
66 for j in $(find . -name "*.jar"); do
67 mv $j $j.no
68 done
69 %patch0 -b .sav0
70
71 ln -s %{_javadir}/asm2-all.jar lib/asm-all-2.2.2.jar
72
73 %build
74 %{ant} -Djdk.home=%{_jvmdir}/java all javadoc
75
76
77 %install
78 rm -rf %{buildroot}
79 install -d -m 755 $RPM_BUILD_ROOT%{_javadir} \
80 $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}
81
82 install -m644 drop/%{name}.jar $RPM_BUILD_ROOT%{_javadir}/%{name}-%{version}.jar
83 ln -s %{name}-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/%{name}.jar
84
85 cp -pr api/* $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}
86 cd $RPM_BUILD_ROOT%{_javadocdir}
87 ln -s %{name}-%{version} %{name}
88
89 %files
90 %{_javadir}/*.jar
91
92 %files javadoc
93 %defattr(644,root,root,755)
94 %{_javadocdir}/%{name}-%{version}
95 %{_javadocdir}/%{name}
96

  ViewVC Help
Powered by ViewVC 1.1.30