/[packages]/cauldron/libavif/current/SPECS/libavif.spec
ViewVC logotype

Contents of /cauldron/libavif/current/SPECS/libavif.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1738332 - (show annotations) (download)
Sat Jul 31 15:32:37 2021 UTC (2 years, 1 month ago) by luigiwalser
File size: 2835 byte(s)
rebuild for aom
1 %define major 12
2 %define libname %mklibname avif %{major}
3 %define develname %mklibname avif -d
4
5 Name: libavif
6 Version: 0.9.2
7 Release: %mkrel 2
8 Summary: Library for encoding and decoding .avif files
9 Group: System/Libraries
10 License: BSD
11 URL: https://github.com/AOMediaCodec/libavif
12 Source0: https://github.com/AOMediaCodec/libavif/archive/v%{version}/%{name}-%{version}.tar.gz
13
14 BuildRequires: cmake
15 BuildRequires: nasm
16 BuildRequires: pkgconfig(aom)
17 BuildRequires: pkgconfig(dav1d)
18 BuildRequires: pkgconfig(libjpeg)
19 BuildRequires: pkgconfig(libpng)
20 BuildRequires: pkgconfig(zlib)
21 # not yet in mageia repo
22 #BuildRequires: pkgconfig(rav1e)
23 #BuildRequires: pkgconfig(libyuv)
24
25 %description
26 This library aims to be a friendly, portable C implementation of the AV1 Image
27 File Format, as described here:
28
29 https://aomediacodec.github.io/av1-avif/
30
31 #------------------------------------------------
32
33 %package -n %{libname}
34 Summary: Library for encoding and decoding .avif files
35 Group: System/Libraries
36
37 %description -n %{libname}
38 This library aims to be a friendly, portable C implementation of the AV1 Image
39 File Format, as described here:
40
41 https://aomediacodec.github.io/av1-avif/
42
43 #------------------------------------------------
44
45 %package -n %{develname}
46 Summary: Development package for %{name}
47 Group: Development/C++
48 Requires: %{libname} = %{version}-%{release}
49 Provides: avif-devel = %{version}-%{release}
50
51 %description -n %{develname}
52 Header files for development with %{name}.
53
54 #------------------------------------------------
55
56 %package tools
57 Summary: Tools to encode and decode AVIF files
58 Group: Development/Tools
59
60 %description tools
61 This library aims to be a friendly, portable C implementation of the AV1 Image
62 File Format, as described here:
63
64 https://aomediacodec.github.io/av1-avif/
65
66 This package holds the commandline tools to encode and decode AVIF files.
67
68 #------------------------------------------------
69
70 %package -n avif-pixbuf-loader
71 Summary: AVIF image loader for GTK+ applications
72 Group: Development/Tools
73 BuildRequires: pkgconfig(gdk-pixbuf-2.0)
74 Requires: gdk-pixbuf2.0
75
76 %description -n avif-pixbuf-loader
77 Avif-pixbuf-loader contains a plugin to load AVIF images in GTK+ applications.
78
79 #------------------------------------------------
80
81 %prep
82 %autosetup -p1
83
84 %build
85 %cmake -DAVIF_CODEC_AOM=1 \
86 -DAVIF_CODEC_DAV1D=1 \
87 -DAVIF_CODEC_RAV1E=0 \
88 -DAVIF_BUILD_APPS=1 \
89 -DAVIF_BUILD_GDK_PIXBUF=1
90 %cmake_build
91
92 %install
93 %cmake_install
94
95 %files -n %{libname}
96 %{_libdir}/libavif.so.%{major}{,.*}
97
98 %files -n %{develname}
99 %{_libdir}/libavif.so
100 %{_includedir}/avif/
101 %{_libdir}/cmake/libavif/
102 %{_libdir}/pkgconfig/libavif.pc
103
104 %files tools
105 %doc CHANGELOG.md README.md
106 %{_bindir}/avifdec
107 %{_bindir}/avifenc
108
109 %files -n avif-pixbuf-loader
110 %{_libdir}/gdk-pixbuf-2.0/*/loaders/libpixbufloader-avif.so

  ViewVC Help
Powered by ViewVC 1.1.28