1 |
%define name libdvdcss |
2 |
%define version 1.3.0 |
3 |
%define release %mkrel 3 |
4 |
%define major 2 |
5 |
%define libname %mklibname dvdcss %{major} |
6 |
%define develname %mklibname -d dvdcss |
7 |
|
8 |
Name: %{name} |
9 |
Version: %{version} |
10 |
Release: %{release} |
11 |
Summary: Library for accessing DVDs as a block device using deCSS if needed |
12 |
Source: http://download.videolan.org/pub/%{name}/%{version}/%{name}-%{version}.tar.bz2 |
13 |
License: GPLv2+ |
14 |
Group: System/Libraries |
15 |
URL: http://www.videolan.org/libdvdcss |
16 |
|
17 |
%description |
18 |
libdvdcss is a simple library designed for accessing DVDs like a block device |
19 |
without having to bother about the decryption. The important features are: |
20 |
* Portability. Currently supported platforms are GNU/Linux, FreeBSD, NetBSD, |
21 |
OpenBSD, BSD/OS, BeOS, Windows 95/98, Windows NT/2000, MacOS X, Solaris, |
22 |
and HP-UX. |
23 |
* Simplicity. There are currently 7 functions in the API, and we intend to |
24 |
keep this number low. |
25 |
* Freedom. libdvdcss is released under the General Public License, ensuring |
26 |
it will stay free, and used only for free software products. |
27 |
* Just better. Unlike most similar projects, libdvdcss doesn't require the |
28 |
region of your drive to be set. |
29 |
|
30 |
This package is in 'tainted' as it may violate patents in some countries. |
31 |
|
32 |
%package -n %{libname} |
33 |
Summary: A library for accessing DVDs as a block device using deCSS if needed |
34 |
Group: System/Libraries |
35 |
Provides: %{name} = %{version}-%{release} |
36 |
|
37 |
%description -n %{libname} |
38 |
libdvdcss is a simple library designed for accessing DVDs like a block device |
39 |
without having to bother about the decryption. The important features are: |
40 |
* Portability. Currently supported platforms are GNU/Linux, FreeBSD, NetBSD, |
41 |
OpenBSD, BSD/OS, BeOS, Windows 95/98, Windows NT/2000, MacOS X, Solaris, |
42 |
and HP-UX. |
43 |
* Simplicity. There are currently 7 functions in the API, and we intend to |
44 |
keep this number low. |
45 |
* Freedom. libdvdcss is released under the General Public License, ensuring |
46 |
it will stay free, and used only for free software products. |
47 |
* Just better. Unlike most similar projects, libdvdcss doesn't require the |
48 |
region of your drive to be set. |
49 |
|
50 |
%package -n %{develname} |
51 |
Summary: Development tools for programs which will use the %{name} library |
52 |
Group: Development/C |
53 |
Requires: %{libname} = %{version} |
54 |
Provides: %{name}-devel = %{version}-%{release} |
55 |
Obsoletes: %mklibname -d dvdcss 2 |
56 |
|
57 |
%description -n %{develname} |
58 |
The %{name}-devel package includes the header files and static libraries |
59 |
necessary for developing programs which will manipulate DVDs files using |
60 |
the %{name} library. |
61 |
|
62 |
If you are going to develop programs which will manipulate DVDs, you |
63 |
should install %{name}-devel. You'll also need to have the %{name} |
64 |
package installed. |
65 |
|
66 |
%prep |
67 |
%setup -q |
68 |
|
69 |
%build |
70 |
%configure2_5x |
71 |
%make |
72 |
|
73 |
%install |
74 |
%makeinstall_std |
75 |
|
76 |
rm -rf %{buildroot}%{_docdir}/%{name} |
77 |
|
78 |
%files -n %{libname} |
79 |
%doc AUTHORS README |
80 |
%{_libdir}/*.so.%{major}* |
81 |
|
82 |
%files -n %{develname} |
83 |
%doc ChangeLog COPYING |
84 |
%{_libdir}/*.a |
85 |
%{_libdir}/*.la |
86 |
%{_libdir}/*.so |
87 |
%{_includedir}/* |
88 |
%_libdir/pkgconfig/*.pc |