1 |
%global major 0 |
2 |
%define libname %mklibname eot %major |
3 |
%define devname %mklibname -d eot |
4 |
Name: libeot |
5 |
Version: 0.01 |
6 |
Release: %mkrel 1 |
7 |
Summary: A library for parsing Embedded OpenType font files |
8 |
|
9 |
Group: System/Libraries |
10 |
License: MPLv2.0 |
11 |
URL: https://github.com/umanwizard/libeot |
12 |
Source: http://dev-www.libreoffice.org/src/%{name}-%{version}.tar.bz2 |
13 |
|
14 |
%description |
15 |
%{name} is a library for parsing Embedded OpenType files (Microsoft |
16 |
embedded font "standard") and converting them to other formats. |
17 |
|
18 |
%package -n %libname |
19 |
Summary: A library for parsing Embedded OpenType font files |
20 |
Group: System/Libraries |
21 |
|
22 |
%description -n %libname |
23 |
%{libname} is a library for parsing Embedded OpenType files (Microsoft |
24 |
embedded font "standard") and converting them to other formats. |
25 |
|
26 |
%package -n %devname |
27 |
Summary: Development files for %{name} |
28 |
Group: Development/C |
29 |
Requires: %{libname} = %{version}-%{release} |
30 |
|
31 |
%description -n %devname |
32 |
The %{name}-devel package contains libraries and header files for |
33 |
developing applications that use %{name}. |
34 |
|
35 |
%package tools |
36 |
Summary: Tools to transform EOT font files into other formats |
37 |
Group: Office/Utilities |
38 |
Requires: %{libname} = %{version}-%{release} |
39 |
|
40 |
%description tools |
41 |
Tools to transform EOT font files into other formats. Only TTF is |
42 |
supported currently. |
43 |
|
44 |
%prep |
45 |
%setup -q |
46 |
|
47 |
%build |
48 |
%configure --disable-silent-rules --disable-static |
49 |
sed -i \ |
50 |
-e 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' \ |
51 |
-e 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' \ |
52 |
libtool |
53 |
%make |
54 |
|
55 |
%install |
56 |
%makeinstall_std |
57 |
rm -f %{buildroot}/%{_libdir}/*.la |
58 |
|
59 |
|
60 |
|
61 |
%files -n %libname |
62 |
%doc LICENSE PATENTS |
63 |
%{_libdir}/%{name}.so.* |
64 |
|
65 |
%files -n %devname |
66 |
%{_includedir}/%{name} |
67 |
%{_libdir}/%{name}.so |
68 |
%{_libdir}/pkgconfig/%{name}.pc |
69 |
|
70 |
%files tools |
71 |
%{_bindir}/eot2ttf |
72 |
|