1 |
%define pkgname libgnomedb |
2 |
%define api 4.0 |
3 |
%define name %{pkgname}%{api} |
4 |
%define major 4 |
5 |
%define oname gnomedb |
6 |
%define libname %mklibname %{oname}%{api}_ %major |
7 |
%define libnamedev %mklibname -d %{oname}%{api} |
8 |
%define gdaver 3.99.7 |
9 |
%define git 20090503 |
10 |
|
11 |
Summary: GNOME DB |
12 |
Name: %name |
13 |
Version: 3.99.8 |
14 |
Release: %mkrel 0.%git.4 |
15 |
License: GPLv2+ and LGPLv2+ |
16 |
Group: Databases |
17 |
URL: http://www.gnome-db.org/ |
18 |
Source0: ftp://ftp.gnome.org/pub/GNOME/sources/%{pkgname}/%{pkgname}-%git.tar.bz2 |
19 |
Patch1: libgnomedb-fix-str-fmt.patch |
20 |
Patch2: libgnomedb-remove-duplicated-header.patch |
21 |
BuildRoot: %{_tmppath}/%{name}-%{version}-root |
22 |
BuildRequires: libgnomeui2-devel |
23 |
BuildRequires: libgda4.0-devel >= %gdaver |
24 |
BuildRequires: scrollkeeper |
25 |
BuildRequires: gtk-doc |
26 |
BuildRequires: docbook-dtd412-xml |
27 |
BuildRequires: libglade2.0-devel |
28 |
BuildRequires: gtksourceview1-devel |
29 |
BuildRequires: evolution-data-server-devel |
30 |
BuildRequires: glade3-devel >= 3.1.5 |
31 |
BuildRequires: libgoocanvas-devel >= 0.9 |
32 |
BuildRequires: graphviz-devel |
33 |
BuildRequires: desktop-file-utils |
34 |
BuildRequires: intltool |
35 |
BuildRequires: gnome-common |
36 |
|
37 |
%description |
38 |
Gnome DB is a frontend to the GDA architecture, being developed as part |
39 |
of the GNOME project. It adds, to the already powerful GDA architecture, |
40 |
a nice GUI front end for users, as well as a whole set of software |
41 |
components intended to be reused in other unrelated applications. |
42 |
|
43 |
This package contains the core components of GNOME-DB. |
44 |
|
45 |
%package -n %{libname} |
46 |
Summary: GNOME DB libraries |
47 |
Group: System/Libraries |
48 |
Requires: %name >= %version |
49 |
#gw /usr/lib/glade3/modules/libgladegnomedb.so |
50 |
Conflicts: gnome-db2.0 < 3.1.2-10 |
51 |
|
52 |
%description -n %{libname} |
53 |
Gnome DB is a frontend to the GDA architecture, being developed as part |
54 |
of the GNOME project. It adds, to the already powerful GDA architecture, |
55 |
a nice GUI front end for users, as well as a whole set of software |
56 |
components intended to be reused in other unrelated applications. |
57 |
|
58 |
|
59 |
%package -n %{libnamedev} |
60 |
Summary: GNOME DB Development |
61 |
Group: Development/Databases |
62 |
Requires: %{libname} = %{version} |
63 |
Provides: %{name}-devel = %{version} |
64 |
Requires(post): scrollkeeper |
65 |
Requires(postun): scrollkeeper |
66 |
|
67 |
%description -n %{libnamedev} |
68 |
Gnome DB is a frontend to the GDA architecture, being developed as part |
69 |
of the GNOME project. It adds, to the already powerful GDA architecture, |
70 |
a nice GUI front end for users, as well as a whole set of software |
71 |
components intended to be reused in other unrelated applications. |
72 |
|
73 |
This package contains libraries, header files and tools to let |
74 |
you develop GNOME-DB applications. |
75 |
|
76 |
|
77 |
%prep |
78 |
%setup -q -n %{pkgname} |
79 |
%patch1 -p1 -b .str |
80 |
%patch2 -p1 |
81 |
./autogen.sh |
82 |
|
83 |
%build |
84 |
%configure2_5x |
85 |
%make |
86 |
|
87 |
%install |
88 |
rm -rf $RPM_BUILD_ROOT |
89 |
|
90 |
GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1 %makeinstall_std |
91 |
|
92 |
desktop-file-install --vendor="" \ |
93 |
--add-category="GNOME" \ |
94 |
--add-category="GTK" \ |
95 |
--dir $RPM_BUILD_ROOT%{_datadir}/applications $RPM_BUILD_ROOT%{_datadir}/applications/* |
96 |
|
97 |
%{find_lang} %{pkgname}-%api --with-gnome |
98 |
|
99 |
# remove unpackaged files |
100 |
rm -rf $RPM_BUILD_ROOT%{_libdir}/libglade/2.0/*.{la,a} \ |
101 |
$RPM_BUILD_ROOT%{_libdir}/glade3/modules/*a \ |
102 |
$RPM_BUILD_ROOT%{_libdir}/libgnomedb/plugins/*a |
103 |
|
104 |
%clean |
105 |
rm -rf $RPM_BUILD_ROOT |
106 |
|
107 |
%preun |
108 |
%preun_uninstall_gconf_schemas libgnomedb-%{api} |
109 |
|
110 |
%files -f %{pkgname}-%api.lang |
111 |
%defattr(-, root, root) |
112 |
%doc AUTHORS COPYING NEWS |
113 |
%_sysconfdir/gconf/schemas/libgnomedb-%{api}.schemas |
114 |
%{_bindir}/* |
115 |
%{_datadir}/pixmaps/* |
116 |
%_libdir/glade3/modules/libgladegnomedb.so |
117 |
%_datadir/glade3/ |
118 |
%dir %_datadir/gnome-db-%{api}/ |
119 |
%_datadir/gnome-db-%{api}/dtd |
120 |
%_datadir/gnome-db-%{api}/*.xml |
121 |
%_datadir/gnome-db-%{api}/*.glade |
122 |
%_datadir/applications/database-properties-%{api}.desktop |
123 |
%{_libdir}/libglade/2.0/* |
124 |
%dir %{_libdir}/gnome-db-%{api}/ |
125 |
%{_libdir}/gnome-db-%{api}/plugins/ |
126 |
|
127 |
%files -n %{libname} |
128 |
%defattr(-, root, root) |
129 |
%{_libdir}/libgnomedb*-%{api}.so.%{major}* |
130 |
|
131 |
%files -n %{libnamedev} |
132 |
%defattr(-, root, root) |
133 |
%doc %{_datadir}/gtk-doc/html/* |
134 |
%{_libdir}/*.so |
135 |
%attr(644,root,root) %{_libdir}/*.la |
136 |
%{_libdir}/*.a |
137 |
%{_libdir}/pkgconfig/* |
138 |
%{_includedir}/* |
139 |
%dir %{_datadir}/omf/* |
140 |
%{_datadir}/omf/*/*-C.omf |
141 |
%_datadir/gnome-db-%{api}/demo |
142 |
|
143 |
|