/[packages]/cauldron/libgpg-error/pristine/SPECS/libgpg-error.spec
ViewVC logotype

Contents of /cauldron/libgpg-error/pristine/SPECS/libgpg-error.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 493 - (show annotations) (download)
Sat Jan 8 11:43:09 2011 UTC (11 years, 10 months ago) by schedbot
File size: 2579 byte(s)
Copying release 1.10-1.mga1 to pristine/ directory.
1 %define version 1.10
2 %define release %mkrel 1
3
4 %define major 0
5 %define libname %mklibname gpg-error %{major}
6 %define develname %mklibname gpg-error -d
7
8 Summary: Library containing common error values for GnuPG components
9 Name: libgpg-error
10 Version: %{version}
11 Release: %{release}
12 License: LGPLv2+
13 Group: System/Libraries
14 URL: http://www.gnupg.org/
15 Source0: ftp://ftp.gnupg.org/gcrypt/%{name}/%{name}-%{version}.tar.bz2
16 Source1: %{SOURCE0}.sig
17 Patch0: libgpg-error-1.9-libdir.patch
18 Buildroot: %{_tmppath}/%{name}-%{version}-root
19
20 %description
21 This is a library that defines common error values for all GnuPG
22 components. Among these are GPG, GPGSM, GPGME, GPG-Agent, libgcrypt,
23 pinentry, SmartCard Daemon and possibly more in the future.
24
25 %package common
26 Summary: Common files for libgpg-error
27 Group: System/Libraries
28 Conflicts: libgpg-error < 1.7
29
30 %description common
31 This package contains the common files that are used by the
32 libgpg-error library.
33
34 %package -n %{libname}
35 Summary: Library containing common error values for GnuPG components
36 Group: System/Libraries
37 Provides: %{name} = %{version}-%{release}
38 Requires: %{name}-common >= %{version}-%{release}
39
40 %description -n %{libname}
41 This is a library that defines common error values for all GnuPG
42 components. Among these are GPG, GPGSM, GPGME, GPG-Agent, libgcrypt,
43 pinentry, SmartCard Daemon and possibly more in the future.
44
45 %package -n %{develname}
46 Summary: Development related files of %{name}
47 Group: Development/Other
48 Provides: %{name}-devel = %{version}-%{release}
49 Requires: %{libname} = %{version}-%{release}
50 Obsoletes: %mklibname gpg-error 0 -d
51
52 %description -n %{develname}
53 %{name} is a library that defines common error values for all
54 GnuPG components. Among these are GPG, GPGSM, GPGME, GPG-Agent,
55 libgcrypt, pinentry, SmartCard Daemon and possibly more in the future.
56
57 This package contains headers and other necessary files to develop
58 or compile applications that use %{name}.
59
60 %prep
61 %setup -q
62 %patch0 -p0 -b .libdir
63
64 %build
65 %configure2_5x
66 %make
67
68 %check
69 make check
70
71 %install
72 rm -rf %{buildroot}
73 %makeinstall_std
74
75 %multiarch_binaries %{buildroot}%{_bindir}/gpg-error-config
76
77 %find_lang %{name}
78
79 %clean
80 rm -rf %{buildroot}
81
82 %files common -f %{name}.lang
83 %defattr(-,root,root)
84
85 %files -n %{libname}
86 %defattr(-,root,root)
87 %{_libdir}/lib*.so.%{major}*
88
89 %files -n %{develname}
90 %defattr(-,root,root)
91 %doc AUTHORS ChangeLog NEWS README
92 %{_bindir}/*
93 %{multiarch_bindir}/gpg-error-config
94 %{_datadir}/aclocal/*.m4
95 %{_libdir}/lib*.so
96 %{_libdir}/lib*.la
97 %{_includedir}/*
98 %{_datadir}/common-lisp/source/gpg-error
99
100

  ViewVC Help
Powered by ViewVC 1.1.28