/[packages]/cauldron/libgpod/current/SPECS/libgpod.spec
ViewVC logotype

Annotation of /cauldron/libgpod/current/SPECS/libgpod.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 134735 - (hide annotations) (download)
Sun Aug 21 11:44:23 2011 UTC (12 years, 8 months ago) by wally
File size: 3847 byte(s)
- new version 0.8.2
- disable static build
- clean .spec a bit
1 wally 134735 %define build_hal 0
2 ahmad 35921
3 wally 134735 %define major 4
4     %define libname %mklibname gpod %{major}
5     %define libnamedev %mklibname -d gpod
6     %define api 1.0
7    
8     Summary: Library to access an iPod audio player
9     Name: libgpod
10     Version: 0.8.2
11     Release: %mkrel 1
12     Source0: http://prdownloads.sourceforge.net/gtkpod/%{name}-%{version}.tar.bz2
13     License: LGPLv2+
14     Group: System/Libraries
15     Url: http://www.gtkpod.org/
16     BuildRequires: gtk+2-devel
17     BuildRequires: udev-devel
18     BuildRequires: dbus-glib-devel
19    
20     %if %{build_hal}
21     BuildRequires: hal-devel
22 ahmad 35828 %endif
23    
24 wally 134735 BuildRequires: libsgutils-devel
25     BuildRequires: taglib-devel
26     BuildRequires: libxml2-devel
27     BuildRequires: libsqlite3-devel
28     BuildRequires: libusb1-devel
29     BuildRequires: libimobiledevice-devel
30     BuildRequires: gtk-doc
31     BuildRequires: eject
32     BuildRequires: intltool
33    
34 ahmad 35828 %description
35     libgpod is a library meant to abstract access to an iPod content. It
36     provides an easy to use API to retrieve the list of files and playlist
37     stored on an iPod, to modify them and to save them back to the iPod.
38    
39 wally 134735 %package -n %{libname}
40     Group: System/Libraries
41     Summary: Library to access an iPod audio player
42     Requires: eject
43     Requires: %{name} >= %{version}-%{release}
44 ahmad 35828
45 wally 134735 %description -n %{libname}
46 ahmad 35828 libgpod is a library meant to abstract access to an iPod content. It
47     provides an easy to use API to retrieve the list of files and playlist
48     stored on an iPod, to modify them and to save them back to the iPod.
49    
50 wally 134735 %package -n %{libnamedev}
51     Group: Development/C
52     Summary: Library to access an iPod audio player
53     Requires: %{libname} = %{version}-%{release}
54     Requires: %{name}-sharp = %{version}-%{release}
55     Provides: %{name}-devel = %{version}-%{release}
56     Obsoletes: %mklibname -d gpod 2
57 ahmad 35828
58 wally 134735 %description -n %{libnamedev}
59 ahmad 35828 libgpod is a library meant to abstract access to an iPod content. It
60     provides an easy to use API to retrieve the list of files and playlist
61     stored on an iPod, to modify them and to save them back to the iPod.
62    
63     %package -n python-gpod
64 wally 134735 Group: Development/Python
65     Summary: Python module for iPod access
66     BuildRequires: python-gobject-devel
67     BuildRequires: python-devel
68     BuildRequires: mutagen
69     BuildRequires: swig
70     Requires: mutagen
71     Requires: %{libname} = %{version}-%{release}
72 ahmad 35828
73     %description -n python-gpod
74     libgpod is a library meant to abstract access to an iPod content. It
75     provides an easy to use API to retrieve the list of files and playlist
76     stored on an iPod, to modify them and to save them back to the iPod.
77    
78     This is a Python binding for libgpod.
79    
80     %package sharp
81 wally 134735 Group: Development/Other
82     Summary: Mono binding to libgpod for iPod access
83     BuildRequires: mono-devel
84     BuildRequires: gtk-sharp2
85     BuildRequires: gtk-sharp2-devel
86     Requires: %libname = %{version}-%{release}
87 ahmad 35828
88     %description sharp
89     libgpod is a library meant to abstract access to an iPod content. It
90     provides an easy to use API to retrieve the list of files and playlist
91     stored on an iPod, to modify them and to save them back to the iPod.
92    
93     This is a Mono binding for libgpod.
94    
95     %prep
96 wally 134735 %setup -q
97 ahmad 35828 %apply_patches
98    
99     %build
100 wally 134735 %configure2_5x \
101     --enable-gtk-doc \
102     --disable-static \
103     --enable-udev \
104     %if !%{build_hal}
105     --without-hal
106 ahmad 35828 %endif
107    
108     %make
109    
110     %install
111 wally 134735 rm -rf %{buildroot}
112 ahmad 35828 %makeinstall_std
113 ahmad 35921
114 wally 134735 #we don't want these
115     find %{buildroot} -name "*.la" -delete
116 ahmad 35828
117 wally 134735 %find_lang %{name}
118    
119     %files -f %{name}.lang
120 ahmad 35828 %doc README* AUTHORS
121 wally 134735 %{_bindir}/ipod-read-sysinfo-extended
122 ahmad 35828 /lib/udev/iphone-set-info
123     /lib/udev/ipod-set-info
124     /lib/udev/rules.d/90-libgpod.rules
125 wally 134735
126 ahmad 35828 %if %build_hal
127 wally 134735 %{_libdir}/hal/scripts/*
128     %{_datadir}/hal/fdi/policy/20thirdparty/*
129 ahmad 35828 %endif
130    
131 wally 134735 %files -n %{libname}
132     %{_libdir}/%{name}.so.%{major}*
133 ahmad 35828
134 wally 134735 %files -n %{libnamedev}
135 ahmad 35828 %doc ChangeLog
136 wally 134735 %doc %{_datadir}/gtk-doc/html/%{name}
137     %{_libdir}/%{name}.so
138     %{_libdir}/pkgconfig/%{name}-%{api}.pc
139     %{_libdir}/pkgconfig/%{name}-sharp.pc
140     %{_includedir}/gpod-%{api}/
141 ahmad 35828
142     %files -n python-gpod
143 wally 134735 %{py_platsitedir}/gpod/
144 ahmad 35828
145     %files sharp
146 wally 134735 %dir %{_libdir}/%{name}
147     %{_libdir}/%{name}/%{name}-sharp*

  ViewVC Help
Powered by ViewVC 1.1.30