/[packages]/cauldron/libgpod/current/SPECS/libgpod.spec
ViewVC logotype

Annotation of /cauldron/libgpod/current/SPECS/libgpod.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 232282 - (hide annotations) (download)
Sat Apr 21 12:06:01 2012 UTC (11 years, 11 months ago) by remmy
File size: 4113 byte(s)
Change dependency on sharp lib into a suggest (closes mga#3429)

1 wally 134735 %define build_hal 0
2 remmy 232282 %bcond_without python
3     %bcond_without sharp
4 ahmad 35921
5 wally 134735 %define major 4
6     %define libname %mklibname gpod %{major}
7     %define libnamedev %mklibname -d gpod
8     %define api 1.0
9    
10     Summary: Library to access an iPod audio player
11     Name: libgpod
12     Version: 0.8.2
13 remmy 232282 Release: %mkrel 2
14 wally 134735 Source0: http://prdownloads.sourceforge.net/gtkpod/%{name}-%{version}.tar.bz2
15     License: LGPLv2+
16     Group: System/Libraries
17     Url: http://www.gtkpod.org/
18     BuildRequires: gtk+2-devel
19     BuildRequires: udev-devel
20     BuildRequires: dbus-glib-devel
21    
22     %if %{build_hal}
23     BuildRequires: hal-devel
24 ahmad 35828 %endif
25    
26 wally 134735 BuildRequires: libsgutils-devel
27     BuildRequires: taglib-devel
28     BuildRequires: libxml2-devel
29     BuildRequires: libsqlite3-devel
30     BuildRequires: libusb1-devel
31     BuildRequires: libimobiledevice-devel
32     BuildRequires: gtk-doc
33     BuildRequires: eject
34     BuildRequires: intltool
35    
36 ahmad 35828 %description
37     libgpod is a library meant to abstract access to an iPod content. It
38     provides an easy to use API to retrieve the list of files and playlist
39     stored on an iPod, to modify them and to save them back to the iPod.
40    
41 wally 134735 %package -n %{libname}
42     Group: System/Libraries
43     Summary: Library to access an iPod audio player
44     Requires: eject
45     Requires: %{name} >= %{version}-%{release}
46 ahmad 35828
47 wally 134735 %description -n %{libname}
48 ahmad 35828 libgpod is a library meant to abstract access to an iPod content. It
49     provides an easy to use API to retrieve the list of files and playlist
50     stored on an iPod, to modify them and to save them back to the iPod.
51    
52 wally 134735 %package -n %{libnamedev}
53     Group: Development/C
54     Summary: Library to access an iPod audio player
55     Requires: %{libname} = %{version}-%{release}
56 remmy 232282 Suggests: %{name}-sharp = %{version}-%{release}
57 wally 134735 Provides: %{name}-devel = %{version}-%{release}
58     Obsoletes: %mklibname -d gpod 2
59 ahmad 35828
60 wally 134735 %description -n %{libnamedev}
61 ahmad 35828 libgpod is a library meant to abstract access to an iPod content. It
62     provides an easy to use API to retrieve the list of files and playlist
63     stored on an iPod, to modify them and to save them back to the iPod.
64    
65 remmy 232282 %if %{with python}
66 ahmad 35828 %package -n python-gpod
67 wally 134735 Group: Development/Python
68     Summary: Python module for iPod access
69     BuildRequires: python-gobject-devel
70     BuildRequires: python-devel
71     BuildRequires: mutagen
72     BuildRequires: swig
73     Requires: mutagen
74     Requires: %{libname} = %{version}-%{release}
75 ahmad 35828
76     %description -n python-gpod
77     libgpod is a library meant to abstract access to an iPod content. It
78     provides an easy to use API to retrieve the list of files and playlist
79     stored on an iPod, to modify them and to save them back to the iPod.
80    
81     This is a Python binding for libgpod.
82 remmy 232282 %endif
83 ahmad 35828
84 remmy 232282 %if %{with sharp}
85 ahmad 35828 %package sharp
86 wally 134735 Group: Development/Other
87     Summary: Mono binding to libgpod for iPod access
88     BuildRequires: mono-devel
89     BuildRequires: gtk-sharp2
90     BuildRequires: gtk-sharp2-devel
91     Requires: %libname = %{version}-%{release}
92 ahmad 35828
93     %description sharp
94     libgpod is a library meant to abstract access to an iPod content. It
95     provides an easy to use API to retrieve the list of files and playlist
96     stored on an iPod, to modify them and to save them back to the iPod.
97    
98     This is a Mono binding for libgpod.
99 remmy 232282 %endif
100 ahmad 35828
101     %prep
102 wally 134735 %setup -q
103 ahmad 35828 %apply_patches
104    
105     %build
106 wally 134735 %configure2_5x \
107     --enable-gtk-doc \
108     --disable-static \
109     --enable-udev \
110     %if !%{build_hal}
111     --without-hal
112 ahmad 35828 %endif
113    
114     %make
115    
116     %install
117 wally 134735 rm -rf %{buildroot}
118 ahmad 35828 %makeinstall_std
119 ahmad 35921
120 wally 134735 #we don't want these
121     find %{buildroot} -name "*.la" -delete
122 remmy 232282 %if !%{with sharp}
123     rm -f %{buildroot}/%{_libdir}/pkgconfig/%{name}-sharp.pc
124     %endif
125 ahmad 35828
126 wally 134735 %find_lang %{name}
127    
128     %files -f %{name}.lang
129 ahmad 35828 %doc README* AUTHORS
130 wally 134735 %{_bindir}/ipod-read-sysinfo-extended
131 ahmad 35828 /lib/udev/iphone-set-info
132     /lib/udev/ipod-set-info
133     /lib/udev/rules.d/90-libgpod.rules
134 wally 134735
135 ahmad 35828 %if %build_hal
136 wally 134735 %{_libdir}/hal/scripts/*
137     %{_datadir}/hal/fdi/policy/20thirdparty/*
138 ahmad 35828 %endif
139    
140 wally 134735 %files -n %{libname}
141     %{_libdir}/%{name}.so.%{major}*
142 ahmad 35828
143 wally 134735 %files -n %{libnamedev}
144 ahmad 35828 %doc ChangeLog
145 wally 134735 %doc %{_datadir}/gtk-doc/html/%{name}
146     %{_libdir}/%{name}.so
147     %{_libdir}/pkgconfig/%{name}-%{api}.pc
148     %{_libdir}/pkgconfig/%{name}-sharp.pc
149     %{_includedir}/gpod-%{api}/
150 ahmad 35828
151 remmy 232282 %if %{with python}
152 ahmad 35828 %files -n python-gpod
153 wally 134735 %{py_platsitedir}/gpod/
154 remmy 232282 %endif
155 ahmad 35828
156 remmy 232282 %if %{with sharp}
157 ahmad 35828 %files sharp
158 remmy 232282 %{_libdir}/pkgconfig/%{name}-sharp.pc
159 wally 134735 %dir %{_libdir}/%{name}
160     %{_libdir}/%{name}/%{name}-sharp*
161 remmy 232282 %endif

  ViewVC Help
Powered by ViewVC 1.1.30