/[packages]/cauldron/libgpod/current/SPECS/libgpod.spec
ViewVC logotype

Annotation of /cauldron/libgpod/current/SPECS/libgpod.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 461037 - (hide annotations) (download)
Tue Jul 30 10:22:06 2013 UTC (10 years, 8 months ago) by fwang
File size: 3933 byte(s)
drop unneeded sharp files
1 remmy 232282 %bcond_without python
2 rtp 401075 %ifnarch %arm %mips
3 remmy 232282 %bcond_without sharp
4 rtp 401075 %endif
5 ahmad 35921
6 wally 134735 %define major 4
7     %define libname %mklibname gpod %{major}
8     %define libnamedev %mklibname -d gpod
9     %define api 1.0
10    
11     Summary: Library to access an iPod audio player
12     Name: libgpod
13     Version: 0.8.2
14 fwang 461037 Release: %mkrel 8
15 wally 134735 Source0: http://prdownloads.sourceforge.net/gtkpod/%{name}-%{version}.tar.bz2
16 blino 451546 Patch0: libgpod-0.8.2-imobiledevice-1.1.5.patch
17 wally 134735 License: LGPLv2+
18     Group: System/Libraries
19     Url: http://www.gtkpod.org/
20     BuildRequires: gtk+2-devel
21     BuildRequires: udev-devel
22     BuildRequires: dbus-glib-devel
23     BuildRequires: libsgutils-devel
24     BuildRequires: taglib-devel
25     BuildRequires: libxml2-devel
26     BuildRequires: libsqlite3-devel
27     BuildRequires: libusb1-devel
28     BuildRequires: libimobiledevice-devel
29     BuildRequires: gtk-doc
30     BuildRequires: eject
31     BuildRequires: intltool
32    
33 ahmad 35828 %description
34     libgpod is a library meant to abstract access to an iPod content. It
35     provides an easy to use API to retrieve the list of files and playlist
36     stored on an iPod, to modify them and to save them back to the iPod.
37    
38 wally 134735 %package -n %{libname}
39     Group: System/Libraries
40     Summary: Library to access an iPod audio player
41     Requires: eject
42     Requires: %{name} >= %{version}-%{release}
43 ahmad 35828
44 wally 134735 %description -n %{libname}
45 ahmad 35828 libgpod is a library meant to abstract access to an iPod content. It
46     provides an easy to use API to retrieve the list of files and playlist
47     stored on an iPod, to modify them and to save them back to the iPod.
48    
49 wally 134735 %package -n %{libnamedev}
50     Group: Development/C
51     Summary: Library to access an iPod audio player
52     Requires: %{libname} = %{version}-%{release}
53     Provides: %{name}-devel = %{version}-%{release}
54     Obsoletes: %mklibname -d gpod 2
55 ahmad 35828
56 wally 134735 %description -n %{libnamedev}
57 ahmad 35828 libgpod is a library meant to abstract access to an iPod content. It
58     provides an easy to use API to retrieve the list of files and playlist
59     stored on an iPod, to modify them and to save them back to the iPod.
60    
61 remmy 232282 %if %{with python}
62 ahmad 35828 %package -n python-gpod
63 wally 134735 Group: Development/Python
64     Summary: Python module for iPod access
65     BuildRequires: python-gobject-devel
66     BuildRequires: python-devel
67     BuildRequires: mutagen
68     BuildRequires: swig
69     Requires: mutagen
70     Requires: %{libname} = %{version}-%{release}
71 ahmad 35828
72     %description -n python-gpod
73     libgpod is a library meant to abstract access to an iPod content. It
74     provides an easy to use API to retrieve the list of files and playlist
75     stored on an iPod, to modify them and to save them back to the iPod.
76    
77     This is a Python binding for libgpod.
78 remmy 232282 %endif
79 ahmad 35828
80 remmy 232282 %if %{with sharp}
81 ahmad 35828 %package sharp
82 wally 134735 Group: Development/Other
83     Summary: Mono binding to libgpod for iPod access
84     BuildRequires: mono-devel
85     BuildRequires: gtk-sharp2
86     BuildRequires: gtk-sharp2-devel
87     Requires: %libname = %{version}-%{release}
88 ahmad 35828
89     %description sharp
90     libgpod is a library meant to abstract access to an iPod content. It
91     provides an easy to use API to retrieve the list of files and playlist
92     stored on an iPod, to modify them and to save them back to the iPod.
93    
94     This is a Mono binding for libgpod.
95 remmy 232282 %endif
96 ahmad 35828
97     %prep
98 wally 134735 %setup -q
99 ahmad 35828 %apply_patches
100    
101     %build
102 wally 134735 %configure2_5x \
103     --disable-static \
104 fwang 442336 --enable-udev --with-udev-dir=%{_prefix}/lib/udev \
105 wally 134735 --without-hal
106 ahmad 35828
107     %make
108    
109     %install
110     %makeinstall_std
111 ahmad 35921
112 wally 134735 #we don't want these
113     find %{buildroot} -name "*.la" -delete
114 wally 279838
115 remmy 232282 %if !%{with sharp}
116     rm -f %{buildroot}/%{_libdir}/pkgconfig/%{name}-sharp.pc
117     %endif
118 ahmad 35828
119 wally 134735 %find_lang %{name}
120    
121     %files -f %{name}.lang
122 ahmad 35828 %doc README* AUTHORS
123 wally 134735 %{_bindir}/ipod-read-sysinfo-extended
124 fwang 442336 %{_prefix}/lib/udev/iphone-set-info
125     %{_prefix}/lib/udev/ipod-set-info
126     %{_udevrulesdir}/90-libgpod.rules
127 wally 134735
128     %files -n %{libname}
129     %{_libdir}/%{name}.so.%{major}*
130 ahmad 35828
131 wally 134735 %files -n %{libnamedev}
132 ahmad 35828 %doc ChangeLog
133 wally 134735 %doc %{_datadir}/gtk-doc/html/%{name}
134     %{_libdir}/%{name}.so
135     %{_libdir}/pkgconfig/%{name}-%{api}.pc
136     %{_includedir}/gpod-%{api}/
137 ahmad 35828
138 remmy 232282 %if %{with python}
139 ahmad 35828 %files -n python-gpod
140 wally 134735 %{py_platsitedir}/gpod/
141 remmy 232282 %endif
142 ahmad 35828
143 remmy 232282 %if %{with sharp}
144 ahmad 35828 %files sharp
145 remmy 232282 %{_libdir}/pkgconfig/%{name}-sharp.pc
146 wally 134735 %dir %{_libdir}/%{name}
147     %{_libdir}/%{name}/%{name}-sharp*
148 remmy 232282 %endif

  ViewVC Help
Powered by ViewVC 1.1.30