/[packages]/cauldron/libgpod/current/SPECS/libgpod.spec
ViewVC logotype

Annotation of /cauldron/libgpod/current/SPECS/libgpod.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 77421 - (hide annotations) (download)
Fri Mar 25 18:07:51 2011 UTC (13 years ago) by ahmad
File size: 3928 byte(s)
- bump rel and submit to core/testing to build against libimobiledevice-1.1.0
1 ahmad 35828 %define name libgpod
2     %define version 0.8.0
3     %define git 20100829
4 ahmad 77421 %define release %mkrel 4
5 ahmad 35828 %define major 4
6     %define libname %mklibname gpod %major
7     %define libnamedev %mklibname -d gpod
8     %define api 1.0
9     %define build_hal 0
10 ahmad 35921
11 ahmad 35828 Summary: Library to access an iPod audio player
12     Name: %{name}
13     Version: %{version}
14     Release: %{release}
15     Source0: http://prdownloads.sourceforge.net/gtkpod/%{name}-%{version}.tar.gz
16     License: LGPLv2+
17     Group: System/Libraries
18     Url: http://www.gtkpod.org/
19     BuildRequires: gtk+2-devel
20     BuildRequires: udev-devel dbus-glib-devel
21     %if %build_hal
22     BuildRequires: hal-devel
23     %endif
24     BuildRequires: libsgutils-devel
25     BuildRequires: taglib-devel
26     BuildRequires: libxml2-devel
27     BuildRequires: libsqlite3-devel
28     BuildRequires: libusb1-devel
29     BuildRequires: libimobiledevice-devel
30     BuildRequires: gtk-doc
31     BuildRequires: eject
32     BuildRequires: intltool
33    
34     %description
35     libgpod is a library meant to abstract access to an iPod content. It
36     provides an easy to use API to retrieve the list of files and playlist
37     stored on an iPod, to modify them and to save them back to the iPod.
38    
39     %package -n %libname
40     Group: System/Libraries
41     Summary: Library to access an iPod audio player
42     Requires: eject
43     Requires: %name >= %version-release
44    
45     %description -n %libname
46     libgpod is a library meant to abstract access to an iPod content. It
47     provides an easy to use API to retrieve the list of files and playlist
48     stored on an iPod, to modify them and to save them back to the iPod.
49    
50     %package -n %libnamedev
51     Group: Development/C
52     Summary: Library to access an iPod audio player
53     Requires: %libname = %version-%release
54     Requires: %name-sharp = %version-%release
55     Provides: %name-devel = %version-%release
56     Obsoletes: %mklibname -d gpod 2
57    
58     %description -n %libnamedev
59     libgpod is a library meant to abstract access to an iPod content. It
60     provides an easy to use API to retrieve the list of files and playlist
61     stored on an iPod, to modify them and to save them back to the iPod.
62    
63     %package -n python-gpod
64     Group: Development/Python
65     Summary: Python module for iPod access
66     BuildRequires: python-gobject-devel
67 ahmad 77421 BuildRequires: python-devel
68 ahmad 35828 BuildRequires: mutagen
69     BuildRequires: swig
70     Requires: mutagen
71     Requires: %libname = %version-%release
72    
73     %description -n python-gpod
74     libgpod is a library meant to abstract access to an iPod content. It
75     provides an easy to use API to retrieve the list of files and playlist
76     stored on an iPod, to modify them and to save them back to the iPod.
77    
78     This is a Python binding for libgpod.
79    
80     %package sharp
81     Group: Development/Other
82     Summary: Mono binding to libgpod for iPod access
83     BuildRequires: mono-devel
84     BuildRequires: gtk-sharp2
85     BuildRequires: gtk-sharp2-devel
86     Requires: %libname = %version-%release
87    
88     %description sharp
89     libgpod is a library meant to abstract access to an iPod content. It
90     provides an easy to use API to retrieve the list of files and playlist
91     stored on an iPod, to modify them and to save them back to the iPod.
92    
93     This is a Mono binding for libgpod.
94    
95     %prep
96     %setup -q -n %{name}-%version
97     %apply_patches
98    
99     %build
100     %configure2_5x --enable-gtk-doc --enable-udev \
101     %if !%build_hal
102     --without-hal
103     %endif
104    
105     %make
106    
107     %install
108 ahmad 35921 rm -rf %{buildroot} %name.lang
109    
110 ahmad 35828 %makeinstall_std
111 ahmad 35921
112 ahmad 35828 %find_lang %name
113    
114     %clean
115 ahmad 35921 rm -rf %{buildroot}
116 ahmad 35828
117     %files -f %name.lang
118     %defattr(-,root,root)
119     %doc README* AUTHORS
120     %_bindir/ipod-read-sysinfo-extended
121     /lib/udev/iphone-set-info
122     /lib/udev/ipod-set-info
123     /lib/udev/rules.d/90-libgpod.rules
124     %if %build_hal
125     %_libdir/hal/scripts/*
126     %_datadir/hal/fdi/policy/20thirdparty/*
127     %endif
128    
129     %files -n %libname
130     %defattr(-,root,root)
131     %_libdir/lib*.so.%{major}*
132    
133     %files -n %libnamedev
134     %defattr(-,root,root)
135     %doc ChangeLog
136     %_libdir/lib*.so
137     %attr(644,root,root) %_libdir/lib*a
138     %_libdir/pkgconfig/libgpod-%api.pc
139     %_libdir/pkgconfig/libgpod-sharp.pc
140     %_includedir/gpod-%api/
141     %_datadir/gtk-doc/html/*
142    
143     %files -n python-gpod
144     %defattr(-,root,root)
145     %py_platsitedir/gpod/
146    
147     %files sharp
148     %defattr(-,root,root)
149     %dir %_libdir/%name/
150     %_libdir/%name/libgpod-sharp*

  ViewVC Help
Powered by ViewVC 1.1.30