/[packages]/cauldron/libgpod/current/SPECS/libgpod.spec
ViewVC logotype

Contents of /cauldron/libgpod/current/SPECS/libgpod.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 232282 - (show annotations) (download)
Sat Apr 21 12:06:01 2012 UTC (11 years, 11 months ago) by remmy
File size: 4113 byte(s)
Change dependency on sharp lib into a suggest (closes mga#3429)

1 %define build_hal 0
2 %bcond_without python
3 %bcond_without sharp
4
5 %define major 4
6 %define libname %mklibname gpod %{major}
7 %define libnamedev %mklibname -d gpod
8 %define api 1.0
9
10 Summary: Library to access an iPod audio player
11 Name: libgpod
12 Version: 0.8.2
13 Release: %mkrel 2
14 Source0: http://prdownloads.sourceforge.net/gtkpod/%{name}-%{version}.tar.bz2
15 License: LGPLv2+
16 Group: System/Libraries
17 Url: http://www.gtkpod.org/
18 BuildRequires: gtk+2-devel
19 BuildRequires: udev-devel
20 BuildRequires: dbus-glib-devel
21
22 %if %{build_hal}
23 BuildRequires: hal-devel
24 %endif
25
26 BuildRequires: libsgutils-devel
27 BuildRequires: taglib-devel
28 BuildRequires: libxml2-devel
29 BuildRequires: libsqlite3-devel
30 BuildRequires: libusb1-devel
31 BuildRequires: libimobiledevice-devel
32 BuildRequires: gtk-doc
33 BuildRequires: eject
34 BuildRequires: intltool
35
36 %description
37 libgpod is a library meant to abstract access to an iPod content. It
38 provides an easy to use API to retrieve the list of files and playlist
39 stored on an iPod, to modify them and to save them back to the iPod.
40
41 %package -n %{libname}
42 Group: System/Libraries
43 Summary: Library to access an iPod audio player
44 Requires: eject
45 Requires: %{name} >= %{version}-%{release}
46
47 %description -n %{libname}
48 libgpod is a library meant to abstract access to an iPod content. It
49 provides an easy to use API to retrieve the list of files and playlist
50 stored on an iPod, to modify them and to save them back to the iPod.
51
52 %package -n %{libnamedev}
53 Group: Development/C
54 Summary: Library to access an iPod audio player
55 Requires: %{libname} = %{version}-%{release}
56 Suggests: %{name}-sharp = %{version}-%{release}
57 Provides: %{name}-devel = %{version}-%{release}
58 Obsoletes: %mklibname -d gpod 2
59
60 %description -n %{libnamedev}
61 libgpod is a library meant to abstract access to an iPod content. It
62 provides an easy to use API to retrieve the list of files and playlist
63 stored on an iPod, to modify them and to save them back to the iPod.
64
65 %if %{with python}
66 %package -n python-gpod
67 Group: Development/Python
68 Summary: Python module for iPod access
69 BuildRequires: python-gobject-devel
70 BuildRequires: python-devel
71 BuildRequires: mutagen
72 BuildRequires: swig
73 Requires: mutagen
74 Requires: %{libname} = %{version}-%{release}
75
76 %description -n python-gpod
77 libgpod is a library meant to abstract access to an iPod content. It
78 provides an easy to use API to retrieve the list of files and playlist
79 stored on an iPod, to modify them and to save them back to the iPod.
80
81 This is a Python binding for libgpod.
82 %endif
83
84 %if %{with sharp}
85 %package sharp
86 Group: Development/Other
87 Summary: Mono binding to libgpod for iPod access
88 BuildRequires: mono-devel
89 BuildRequires: gtk-sharp2
90 BuildRequires: gtk-sharp2-devel
91 Requires: %libname = %{version}-%{release}
92
93 %description sharp
94 libgpod is a library meant to abstract access to an iPod content. It
95 provides an easy to use API to retrieve the list of files and playlist
96 stored on an iPod, to modify them and to save them back to the iPod.
97
98 This is a Mono binding for libgpod.
99 %endif
100
101 %prep
102 %setup -q
103 %apply_patches
104
105 %build
106 %configure2_5x \
107 --enable-gtk-doc \
108 --disable-static \
109 --enable-udev \
110 %if !%{build_hal}
111 --without-hal
112 %endif
113
114 %make
115
116 %install
117 rm -rf %{buildroot}
118 %makeinstall_std
119
120 #we don't want these
121 find %{buildroot} -name "*.la" -delete
122 %if !%{with sharp}
123 rm -f %{buildroot}/%{_libdir}/pkgconfig/%{name}-sharp.pc
124 %endif
125
126 %find_lang %{name}
127
128 %files -f %{name}.lang
129 %doc README* AUTHORS
130 %{_bindir}/ipod-read-sysinfo-extended
131 /lib/udev/iphone-set-info
132 /lib/udev/ipod-set-info
133 /lib/udev/rules.d/90-libgpod.rules
134
135 %if %build_hal
136 %{_libdir}/hal/scripts/*
137 %{_datadir}/hal/fdi/policy/20thirdparty/*
138 %endif
139
140 %files -n %{libname}
141 %{_libdir}/%{name}.so.%{major}*
142
143 %files -n %{libnamedev}
144 %doc ChangeLog
145 %doc %{_datadir}/gtk-doc/html/%{name}
146 %{_libdir}/%{name}.so
147 %{_libdir}/pkgconfig/%{name}-%{api}.pc
148 %{_libdir}/pkgconfig/%{name}-sharp.pc
149 %{_includedir}/gpod-%{api}/
150
151 %if %{with python}
152 %files -n python-gpod
153 %{py_platsitedir}/gpod/
154 %endif
155
156 %if %{with sharp}
157 %files sharp
158 %{_libdir}/pkgconfig/%{name}-sharp.pc
159 %dir %{_libdir}/%{name}
160 %{_libdir}/%{name}/%{name}-sharp*
161 %endif

  ViewVC Help
Powered by ViewVC 1.1.30