/[packages]/cauldron/libiodbc/current/SPECS/libiodbc.spec
ViewVC logotype

Contents of /cauldron/libiodbc/current/SPECS/libiodbc.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 914458 - (show annotations) (download)
Thu Dec 24 21:40:18 2015 UTC (8 years, 4 months ago) by luigiwalser
File size: 5698 byte(s)
- 3.52.10
- fix source URL
- re-enable parallel make (fixed upstream)

1 Name: libiodbc
2 Version: 3.52.10
3 Release: %mkrel 1
4 Summary: The iODBC Driver Manager
5 Group: System/Libraries
6 License: BSD
7 URL: http://www.iodbc.org/
8 Source: http://downloads.sourceforge.net/project/iodbc/iodbc/%{version}/%{name}-%{version}.tar.gz
9 BuildRequires: gtk+2-devel
10
11 %description
12 The iODBC Driver Manager is a free implementation of the SAG CLI and
13 ODBC compliant driver manager which allows developers to write ODBC
14 compliant applications that can connect to various databases using
15 appropriate backend drivers.
16
17 #---------------------------------------------------------------
18
19 %define soname 2
20 %define libname %mklibname iodbc %{soname}
21
22 %package -n %{libname}
23 Summary: The iODBC Driver Manager main library
24 Group: System/Libraries
25
26 %description -n %{libname}
27 The iODBC Driver Manager is a free implementation of the SAG CLI and
28 ODBC compliant driver manager which allows developers to write ODBC
29 compliant applications that can connect to various databases using
30 appropriate backend drivers.
31
32 %files -n %{libname}
33 %{_libdir}/libiodbc.so.%{soname}{,.*}
34
35 #---------------------------------------------------------------
36
37 %define instsoname 2
38 %define libnameinst %mklibname iodbcinst %{instsoname}
39
40 %package -n %{libnameinst}
41 Summary: The iODBC Driver Manager main library
42 Group: System/Libraries
43
44 %description -n %{libnameinst}
45 The iODBC Driver Manager is a free implementation of the SAG CLI and
46 ODBC compliant driver manager which allows developers to write ODBC
47 compliant applications that can connect to various databases using
48 appropriate backend drivers.
49
50 %files -n %{libnameinst}
51 %{_libdir}/libiodbcinst.so.%{instsoname}{,.*}
52
53 #---------------------------------------------------------------
54
55 %package util
56 Summary: The iODBC Driver Manager common binary files
57 Group: System/Libraries
58
59 %description util
60 The iODBC Driver Manager is a free implementation of the SAG CLI and
61 ODBC compliant driver manager which allows developers to write ODBC
62 compliant applications that can connect to various databases using
63 appropriate backend drivers.
64
65 %files util
66 %{_bindir}/iodbctest
67 %{_bindir}/iodbctestw
68 %{_mandir}/man1/iodbctest.1*
69 %{_mandir}/man1/iodbctestw.1*
70
71 #---------------------------------------------------------------
72
73 %define drvproxysoname 2
74 %define libnamedrvproxy %mklibname drvproxy %{drvproxysoname}
75
76 %package -n %{libnamedrvproxy}
77 Summary: The iODBC Driver Manager main library
78 Group: System/Libraries
79
80 %description -n %{libnamedrvproxy}
81 The iODBC Driver Manager is a free implementation of the SAG CLI and
82 ODBC compliant driver manager which allows developers to write ODBC
83 compliant applications that can connect to various databases using
84 appropriate backend drivers.
85
86 %files -n %{libnamedrvproxy}
87 %{_libdir}/libdrvproxy.so.2*
88
89 #---------------------------------------------------------------
90
91 %define admsoname 2
92 %define libnameadm %mklibname iodbcadm %{admsoname}
93
94 %package -n %{libnameadm}
95 Summary: The iODBC Driver Manager main library
96 Group: System/Libraries
97
98 %description -n %{libnameadm}
99 The iODBC Driver Manager is a free implementation of the SAG CLI and
100 ODBC compliant driver manager which allows developers to write ODBC
101 compliant applications that can connect to various databases using
102 appropriate backend drivers.
103
104 %files -n %{libnameadm}
105 %{_libdir}/libiodbcadm.so.%{admsoname}{,.*}
106
107 #---------------------------------------------------------------
108
109 %package admin
110 Summary: GTK based administrator for iODBC development
111 Group: System/Libraries
112
113 %description admin
114 The iODBC Driver Manager is a free implementation of the SAG CLI and
115 ODBC compliant driver manager which allows developers to write ODBC
116 compliant applications that can connect to various databases using
117 appropriate backend drivers.
118
119 This package contains a GTK based administrator program for maintaining
120 DSN information in odbc.ini and odbcinst.ini files.
121
122 %files admin
123 %{_bindir}/iodbcadm-gtk
124 %{_mandir}/man1/iodbcadm-gtk.1*
125
126
127 #---------------------------------------------------------------
128
129 %define libdev %mklibname iodbc -d
130
131 %package -n %{libdev}
132 Summary: header files and libraries for iODBC development
133 Group: Development/Databases
134 Provides: iodbc-devel
135 Provides: %name-devel
136 Requires: %{libname}
137 Requires: %{libnameinst}
138 Requires: %{name}-util
139 Requires: %{libnamedrvproxy}
140 Requires: %{libnameadm}
141 Requires: unixODBC-devel
142
143 %description -n %{libdev}
144 The iODBC Driver Manager is a free implementation of the SAG CLI and
145 ODBC compliant driver manager which allows developers to write ODBC
146 compliant applications that can connect to various databases using
147 appropriate backend drivers.
148
149 This package contains the header files and libraries needed to develop
150 program that use the driver manager.
151
152 %files -n %{libdev}
153 %doc AUTHORS
154 %doc AUTHORS
155 %doc LICENSE
156 %doc LICENSE.LGPL
157 %doc LICENSE.BSD
158 %doc ChangeLog
159 %doc NEWS
160 %doc README
161 %doc README.CVS
162 %doc etc/odbc.ini.sample
163 %doc etc/odbcinst.ini.sample
164 %{_includedir}/*
165 %{_libdir}/*.so
166 %{_libdir}/*.la
167 %{_bindir}/iodbc-config
168 %{_libdir}/pkgconfig/libiodbc.pc
169 %{_mandir}/man1/iodbc-config.1*
170 %{_datadir}/libiodbc
171 %multiarch %{_bindir}/%{multiarch_platform}/iodbc-config
172
173 #---------------------------------------------------------------
174
175 %prep
176 %setup -q
177
178 %build
179 %configure2_5x \
180 --enable-odbc3 \
181 --disable-libodbc \
182 --enable-gui \
183 --disable-static \
184 --with-iodbc-inidir=%{_sysconfdir} \
185 --includedir=%{_includedir}/iodbc \
186 --enable-pthreads
187
188 # Remove rpath from libtool
189 sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
190 sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
191
192 %make
193
194 %install
195 %makeinstall_std
196
197 # Multiarch fixes
198 %multiarch_binaries %{buildroot}/%{_bindir}/iodbc-config
199
200

  ViewVC Help
Powered by ViewVC 1.1.30