/[packages]/cauldron/libneon0.27/current/SPECS/libneon0.27.spec
ViewVC logotype

Contents of /cauldron/libneon0.27/current/SPECS/libneon0.27.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 3521 - (show annotations) (download)
Sun Jan 9 17:36:44 2011 UTC (13 years, 3 months ago) by blino
File size: 4846 byte(s)
imported package libneon0.27
1 %define rname neon
2
3 %define major 0.27
4 %define libname %mklibname %{rname} %{major}
5
6 Summary: An HTTP and WebDAV client library, with a C interface
7 Name: libneon0.27
8 Version: 0.29.5
9 Release: %mkrel 1
10 Group: Development/Other
11 License: GPLv2+ and LGPLv2+
12 URL: http://www.webdav.org/neon/
13 Source0: http://www.webdav.org/neon/%{rname}-%{version}.tar.gz
14 Source1: http://www.webdav.org/neon/%{rname}-%{version}.tar.gz.asc
15 Patch0: neon-locales.diff
16 Patch1: neon-fail_parse.diff
17 Patch2: neon-borked_addr_reverse.diff
18 Patch3: neon-borked_retry_notcompress_and_retry_compress.diff
19 Patch4: neon-borked_read_reset.diff
20 Patch5: neon-borked_simple_sslv2.diff
21 # http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=476571
22 Patch6: neon-0.28.2-fix-segfault.patch
23 Provides: libneon
24 Provides: neon
25 BuildRequires: openssl-devel >= 0.9.7
26 BuildRequires: libxml2-devel
27 BuildRequires: pkgconfig
28 BuildRequires: krb5-devel
29 BuildRequires: rootcerts
30 BuildRequires: zlib-devel
31 BuildRequires: libtool
32 BuildRequires: autoconf2.5
33 Requires: rootcerts
34 Requires: openssl >= 0.9.7
35 %if %mdkversion >= 1020
36 BuildRequires: multiarch-utils >= 1.0.3
37 %endif
38 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
39
40 %description
41 neon is an HTTP and WebDAV client library for Unix systems,
42 with a C language API. It provides high-level interfaces to
43 HTTP/1.1 and WebDAV methods, and a low-level interface to
44 HTTP request/response handling, allowing new methods to be
45 easily implemented.
46
47 %if "%{_lib}" != "lib"
48 %package -n %{libname}
49 Summary: Header files and develpment documentation for libnet
50 Group: System/Libraries
51 Requires: %{libname} = %{version}
52 Requires: rootcerts
53 Requires: openssl >= 0.9.7
54 Provides: libneon
55 Provides: neon
56
57 %description -n %{libname}
58 neon is an HTTP and WebDAV client library for Unix systems,
59 with a C language API. It provides high-level interfaces to
60 HTTP/1.1 and WebDAV methods, and a low-level interface to
61 HTTP request/response handling, allowing new methods to be
62 easily implemented.
63 %endif
64
65 %package -n %{libname}-devel
66 Summary: Headers for developing programs that will use %{name}
67 Group: Development/C++
68 Requires: %{libname} = %{version}
69 Provides: libneon-devel = %{version}
70 Provides: neon-devel = %{version}
71 Provides: neon0.27-devel = %{version}
72 Provides: libneon0.27-devel = %{version}
73 Conflicts: %{mklibname neon 0.24}-devel
74 Conflicts: %{mklibname neon 0.26}-devel
75
76 %description -n %{libname}-devel
77 This package contains the headers that programmers will need to develop
78 applications which will use %{name}.
79
80 %package -n %{libname}-static-devel
81 Summary: Static %{libname} library
82 Group: Development/C++
83 Requires: %{libname}-devel = %{version}
84 Provides: libneon-static-devel = %{version}
85 Provides: neon-static-devel = %{version}
86 Provides: neon0.27-static-devel = %{version}
87 Provides: libneon0.27-static-devel = %{version}
88 Conflicts: %{mklibname neon 0.24}-static-devel
89 Conflicts: %{mklibname neon 0.26}-static-devel
90
91 %description -n %{libname}-static-devel
92 Static %{libname} library.
93
94 %prep
95
96 %setup -q -n %{rname}-%{version}
97 %patch0 -p1
98 %patch1 -p0
99 %patch2 -p0
100 %patch3 -p0
101 %patch4 -p0
102 %patch5 -p0
103 %patch6 -p1
104
105 # fix mo clash (#28428)
106 perl -pi -e "s|_LIBNAME_|%{libname}|g" Makefile.in src/ne_internal.h
107
108 # clean up CVS stuff
109 for i in `find . -type d -name CVS` `find . -type f -name .cvs\*` `find . -type f -name .#\*`; do
110 if [ -e "$i" ]; then rm -r $i; fi >&/dev/null
111 done
112
113 # this value has to be raised on x86_64
114 perl -pi -e "s|^ulimit \-v .*|ulimit \-v 40960|g" test/run.sh
115
116 %build
117
118 # wierd stuff...
119 %define __libtoolize /bin/true
120
121 %serverbuild
122
123 %configure2_5x \
124 --enable-shared \
125 --enable-static \
126 --with-ssl=openssl \
127 --enable-threadsafe-ssl=posix \
128 --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt \
129 --with-libxml2
130
131 %make
132
133 %check
134 make check
135
136 %install
137 [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
138
139 %makeinstall
140
141 cp src/README README.neon
142
143 # fix this
144 rm -rf %{buildroot}%{_datadir}/doc
145
146 %if %mdkversion >= 1020
147 %multiarch_binaries %{buildroot}%{_bindir}/neon-config
148 %endif
149
150 %find_lang %{libname} --all-name
151
152 %if %mdkversion < 200900
153 %post -n %{libname} -p /sbin/ldconfig
154 %endif
155
156 %if %mdkversion < 200900
157 %postun -n %{libname} -p /sbin/ldconfig
158 %endif
159
160 %clean
161 [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
162
163 %files -n %{libname} -f %{libname}.lang
164 %defattr(-,root,root,755)
165 %doc doc/*.txt README.neon
166 %{_libdir}/lib*.so.*
167
168 %files -n %{libname}-devel
169 %defattr(-,root,root,755)
170 %doc AUTHORS BUGS doc/html ChangeLog NEWS README THANKS TODO
171 %if %mdkversion >= 1020
172 %multiarch %{multiarch_bindir}/neon-config
173 %endif
174 %{_bindir}/neon-config
175 %{_libdir}/lib*.so
176 %{_libdir}/lib*.la
177 %{_libdir}/pkgconfig/neon.pc
178 %dir %{_includedir}/neon
179 %{_includedir}/neon/*
180 %{_mandir}/man1/*
181 %{_mandir}/man3/*
182
183 %files -n %{libname}-static-devel
184 %defattr(644,root,root,755)
185 %{_libdir}/lib*.a
186
187

  ViewVC Help
Powered by ViewVC 1.1.30