1 |
%define major 3 |
2 |
%define libname %mklibname qt5xdg %{major} |
3 |
%define libloadername %mklibname qt5xdgiconloader %{major} |
4 |
%define devname %mklibname qt5xdg -d |
5 |
|
6 |
%define rel 1 |
7 |
|
8 |
Name: libqtxdg |
9 |
Version: 3.11.0 |
10 |
Release: %mkrel %rel |
11 |
Summary: Library providing freedesktop.org specs implementations for Qt |
12 |
License: LGPLv2+ |
13 |
Group: System/Libraries |
14 |
URL: https://lxqt-project.org/ |
15 |
Source0: https://github.com/lxqt/libqtxdg/releases/download/%{version}/%{name}-%{version}.tar.xz |
16 |
|
17 |
BuildRequires: cmake |
18 |
BuildRequires: cmake(lxqt-build-tools) |
19 |
BuildRequires: ninja |
20 |
BuildRequires: magic-devel |
21 |
|
22 |
BuildRequires: pkgconfig(Qt5Core) |
23 |
BuildRequires: pkgconfig(Qt5Gui) |
24 |
BuildRequires: pkgconfig(Qt5Widgets) |
25 |
BuildRequires: pkgconfig(Qt5Xml) |
26 |
BuildRequires: pkgconfig(Qt5Help) |
27 |
BuildRequires: pkgconfig(Qt5Test) |
28 |
BuildRequires: pkgconfig(Qt5DBus) |
29 |
BuildRequires: pkgconfig(Qt5Svg) |
30 |
|
31 |
BuildRequires: qttools5 |
32 |
|
33 |
%description |
34 |
Library providing freedesktop.org specs implementations for Qt. |
35 |
|
36 |
%files |
37 |
%{_qt5_plugindir}/iconengines/libQt5XdgIconPlugin.so |
38 |
%{_sysconfdir}/xdg/*.conf |
39 |
|
40 |
#-------------------------------------------------------------------- |
41 |
|
42 |
%package -n %{libname} |
43 |
Summary: Library providing freedesktop.org specs implementations for Qt |
44 |
Group: System/Libraries |
45 |
|
46 |
Requires: %name = %version-%release |
47 |
|
48 |
%description -n %{libname} |
49 |
Library providing freedesktop.org specs implementations for Qt. |
50 |
|
51 |
%files -n %{libname} |
52 |
%{_libdir}/libQt5Xdg.so.%{major}{,.*} |
53 |
|
54 |
#-------------------------------------------------------------------- |
55 |
|
56 |
%package -n %{libloadername} |
57 |
Summary: Library providing freedesktop.org specs implementations for Qt |
58 |
Group: System/Libraries |
59 |
|
60 |
%description -n %{libloadername} |
61 |
Library providing freedesktop.org specs implementations for Qt. |
62 |
|
63 |
%files -n %{libloadername} |
64 |
%{_libdir}/libQt5XdgIconLoader.so.%{major}{,.*} |
65 |
|
66 |
#-------------------------------------------------------------------- |
67 |
|
68 |
%package -n %{devname} |
69 |
Summary: Development files for %{name} |
70 |
Group: Development/C |
71 |
Requires: %libname = %version |
72 |
Requires: %libloadername = %version |
73 |
Provides: %name-devel = %version-%release |
74 |
Provides: lib%name-devel = %version-%release |
75 |
|
76 |
%description -n %{devname} |
77 |
Development files (Headers etc.) for %{name}, a library providing |
78 |
freedesktop.org specs implementations for Qt. |
79 |
|
80 |
%files -n %{devname} |
81 |
%{_includedir}/* |
82 |
%{_libdir}/libQt5Xdg.so |
83 |
%{_libdir}/libQt5XdgIconLoader.so |
84 |
%{_libdir}/pkgconfig/*.pc |
85 |
%{_datadir}/cmake/qt5xdg |
86 |
%{_datadir}/cmake/qt5xdgiconloader |
87 |
|
88 |
#-------------------------------------------------------------------- |
89 |
|
90 |
%prep |
91 |
%setup -q |
92 |
%autopatch -p1 |
93 |
|
94 |
%build |
95 |
%cmake_qt5 -DBUILD_TESTS=on |
96 |
%cmake_build |
97 |
|
98 |
%install |
99 |
%cmake_install |
100 |
|