/[packages]/cauldron/libtermcap/current/SPECS/libtermcap.spec
ViewVC logotype

Contents of /cauldron/libtermcap/current/SPECS/libtermcap.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 273158 - (show annotations) (download)
Sat Jul 21 17:42:31 2012 UTC (11 years, 9 months ago) by colin
File size: 4298 byte(s)
Update for usrmove
1 %define name libtermcap
2 %define version 2.0.8
3
4 %define major 2
5 %define libname_orig libtermcap
6 %define libname %mklibname termcap %{major}
7 %define develname %mklibname termcap -d
8
9 Summary: A basic system library for accessing the termcap database
10 Name: %{name}
11 Version: %{version}
12 Release: %mkrel 52
13 Source: termcap-%{version}.tar.bz2
14 Url: ftp://metalab.unc.edu/pub/Linux/GCC/
15 License: LGPL+
16 Group: System/Libraries
17 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
18
19 Patch0: termcap-2.0.8-shared.patch
20 Patch1: termcap-2.0.8-setuid.patch
21 Patch2: termcap-2.0.8-instnoroot.patch
22 Patch3: termcap-2.0.8-compat21.patch
23 Patch4: termcap-2.0.8-xref.patch
24 Patch5: termcap-2.0.8-fix-tc.patch
25 Patch6: termcap-2.0.8-ignore-p.patch
26 Patch7: termcap-buffer.patch
27 # This patch is a REALLY BAD IDEA without patch #10 below....
28 Patch8: termcap-2.0.8-bufsize.patch
29 Patch9: termcap-2.0.8-colon.patch
30 Patch10: libtermcap-aaargh.patch
31 # (gc) conflicting definition of `bcopy' against latest glibc 2.1.95
32 Patch11: termcap-fix-glibc-2.2.patch
33 Patch12: termcap-2.0.8-LDFLAGS.diff
34 Requires: termcap
35 Requires(posttrans): ldconfig glibc
36 Requires(postun): ldconfig
37 BuildRequires: texinfo
38
39 %description
40 The libtermcap package contains a basic system library needed to access
41 the termcap database. The termcap library supports easy access to the
42 termcap database, so that programs can output character-based displays in
43 a terminal-independent manner.
44
45 %package -n %{libname}
46 Summary: Development tools for programs which will access the termcap database
47 Group: System/Libraries
48 Obsoletes: %{libname_orig}
49 Requires(pre): filesystem >= 2.1.9-18
50 Provides: %{libname_orig}
51
52 %description -n %{libname}
53 The libtermcap package contains a basic system library needed to access
54 the termcap database. The termcap library supports easy access to the
55 termcap database, so that programs can output character-based displays in
56 a terminal-independent manner.
57
58 %package -n %{develname}
59 Summary: Development tools for programs which will access the termcap database
60 Group: Development/C
61 Requires: %{libname} = %version
62 Provides: %{libname_orig}-devel = %{version}-%{release}
63 Provides: termcap-devel = %{version}-%{release}
64 Requires(pre): filesystem >= 2.1.9-18
65 Requires(post): info-install
66 Requires(preun): info-install
67
68 %description -n %{develname}
69 This package includes the libraries and header files necessary for
70 developing programs which will access the termcap database.
71
72 If you need to develop programs which will access the termcap database,
73 you'll need to install this package. You'll also need to install the
74 libtermcap package.
75
76 %prep
77 %setup -q -n termcap-2.0.8
78 %patch0 -p1
79 %patch1 -p1
80 %patch2 -p1 -b .nochown
81 %patch3 -p1 -b .compat21
82 %patch4 -p1
83 %patch5 -p1 -b .fix-tc
84 %patch6 -p1 -b .ignore-p
85 %patch7 -p1 -b .buffer
86 %patch8 -p1 -b .bufsize
87 %patch9 -p1 -b .colon
88 %patch10 -p1 -b .aaargh
89 %patch11 -p0
90 %patch12 -p0
91
92 %build
93 %make CFLAGS="%{optflags} -I." LDFLAGS="%{ldflags}"
94
95 %install
96 rm -rf %{buildroot}
97 # (gb) They should do proper Makefiles
98
99 mkdir -p %{buildroot}%{_libdir}
100 install -m 644 libtermcap.a %{buildroot}%{_libdir}/
101 install -m 755 libtermcap.so.* %{buildroot}%{_libdir}/
102 ln -s libtermcap.so.2.0.8 %{buildroot}%{_libdir}/libtermcap.so
103 ln -s libtermcap.so.2.0.8 %{buildroot}%{_libdir}/libtermcap.so.2
104
105 mkdir -p %{buildroot}%{_infodir}
106 install -m 644 termcap.info* %{buildroot}%{_infodir}/
107
108 mkdir -p %{buildroot}%{_includedir}
109 install -m 644 termcap.h %{buildroot}%{_includedir}
110
111 mkdir -p %{buildroot}%{_sysconfdir}
112 install -m 644 termcap.src %{buildroot}%{_sysconfdir}/termcap
113
114 rm -f %{buildroot}%{_sysconfdir}/termcap
115
116 %post -n %{develname}
117 /sbin/install-info \
118 --section="Libraries" --entry="* Termcap: (termcap). The GNU termcap library." \
119 --info-dir=%{_infodir} %{_infodir}/termcap.info%{_extension}
120
121 %preun -n %{develname}
122 if [ $1 = 0 ]; then
123 /sbin/install-info --delete \
124 --section="Libraries" --entry="* Termcap: (termcap). The GNU termcap library." \
125 --info-dir=%{_infodir} %{_infodir}/termcap.info%{_extension}
126 fi
127
128 %files -n %{libname}
129 %defattr(-,root,root)
130 %{_libdir}/*.so.*
131
132 %files -n %{develname}
133 %defattr(-,root,root)
134 %doc ChangeLog README
135 %{_infodir}/termcap.info*
136 %{_libdir}/libtermcap.a
137 %{_libdir}/libtermcap.so
138 %{_includedir}/termcap.h
139
140

  ViewVC Help
Powered by ViewVC 1.1.30